New port: devel/util-linux: Random collection of Linux utilities
This commit is contained in:
parent
5a41ae7832
commit
8ca96141b7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=550102
@ -6744,6 +6744,7 @@
|
||||
SUBDIR += urjtag
|
||||
SUBDIR += utf8cpp
|
||||
SUBDIR += uthash
|
||||
SUBDIR += util-linux
|
||||
SUBDIR += valgrind
|
||||
SUBDIR += valgrind-devel
|
||||
SUBDIR += varconf
|
||||
|
40
devel/util-linux/Makefile
Normal file
40
devel/util-linux/Makefile
Normal file
@ -0,0 +1,40 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= util-linux
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.36
|
||||
CATEGORIES= devel
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Random collection of Linux utilities
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libpcre2-8.so:devel/pcre2 \
|
||||
libuuid.so:misc/e2fsprogs-libuuid
|
||||
RUN_DEPENDS= bash:shells/bash
|
||||
|
||||
USES= autoreconf gettext gmake libtool ncurses pkgconfig shebangfix
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= karelzak
|
||||
|
||||
SHEBANG_FILES= misc-utils/getopt-parse.bash
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-ipcmk --disable-ipcrm --disable-ipcs --disable-makeinstall-chown --disable-makeinstall-setuid
|
||||
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
OPTIONS_DEFINE= UUID
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
UUID_DESC= Install libuuid
|
||||
UUID_CONFIGURE_ENABLE= libuuid
|
||||
|
||||
post-install: # https://github.com/karelzak/util-linux/issues/1149
|
||||
${RM} -r ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/util-linux/distinfo
Normal file
3
devel/util-linux/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1601080727
|
||||
SHA256 (karelzak-util-linux-v2.36_GH0.tar.gz) = 5e4a6f73b28aadceab66ec4490bb5fc77861066660f27b5ec605648809205522
|
||||
SIZE (karelzak-util-linux-v2.36_GH0.tar.gz) = 7806261
|
19
devel/util-linux/files/patch-Makefile.am
Normal file
19
devel/util-linux/files/patch-Makefile.am
Normal file
@ -0,0 +1,19 @@
|
||||
--- Makefile.am.orig 2020-07-23 09:26:04 UTC
|
||||
+++ Makefile.am
|
||||
@@ -65,7 +65,7 @@ CHECK_LOCALS =
|
||||
EXTRA_DIST =
|
||||
CLEANFILES =
|
||||
|
||||
-SUBDIRS = po
|
||||
+SUBDIRS = # po
|
||||
|
||||
RCS_FIND_IGNORE = \( -name SCCS -o -name BitKeeper -o -name .svn -o \
|
||||
-name CVS -o -name .pc -o -name .hg -o -name .git \) -prune -o
|
||||
@@ -76,7 +76,6 @@ EXTRA_DIST += \
|
||||
.version \
|
||||
autogen.sh \
|
||||
Documentation \
|
||||
- po/update-potfiles \
|
||||
README.licensing
|
||||
|
||||
include tools/Makemodule.am
|
3
devel/util-linux/pkg-descr
Normal file
3
devel/util-linux/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
util-linux is a random collection of Linux utilities.
|
||||
|
||||
WWW: https://github.com/karelzak/util-linux
|
162
devel/util-linux/pkg-plist
Normal file
162
devel/util-linux/pkg-plist
Normal file
@ -0,0 +1,162 @@
|
||||
bin/cal
|
||||
bin/chrt
|
||||
bin/col
|
||||
bin/colcrt
|
||||
bin/colrm
|
||||
bin/column
|
||||
bin/flock
|
||||
bin/getopt
|
||||
bin/hardlink
|
||||
bin/hexdump
|
||||
bin/ipcmk
|
||||
bin/isosize
|
||||
bin/logger
|
||||
bin/look
|
||||
bin/mcookie
|
||||
bin/mesg
|
||||
bin/namei
|
||||
bin/rename
|
||||
bin/renice
|
||||
bin/rev
|
||||
bin/scriptreplay
|
||||
bin/setsid
|
||||
bin/ul
|
||||
%%UUID%%bin/uuidgen
|
||||
%%UUID%%bin/uuidparse
|
||||
bin/wall
|
||||
bin/whereis
|
||||
include/blkid/blkid.h
|
||||
%%UUID%%include/libfdisk/libfdisk.h
|
||||
include/libsmartcols/libsmartcols.h
|
||||
%%UUID%%include/uuid/uuid.h
|
||||
lib/libblkid.a
|
||||
lib/libblkid.so
|
||||
lib/libblkid.so.1
|
||||
lib/libblkid.so.1.1.0
|
||||
%%UUID%%lib/libfdisk.a
|
||||
%%UUID%%lib/libfdisk.so
|
||||
%%UUID%%lib/libfdisk.so.1
|
||||
%%UUID%%lib/libfdisk.so.1.1.0
|
||||
lib/libsmartcols.a
|
||||
lib/libsmartcols.so
|
||||
lib/libsmartcols.so.1
|
||||
lib/libsmartcols.so.1.1.0
|
||||
%%UUID%%lib/libuuid.a
|
||||
%%UUID%%lib/libuuid.so
|
||||
%%UUID%%lib/libuuid.so.1
|
||||
%%UUID%%lib/libuuid.so.1.3.0
|
||||
libdata/pkgconfig/blkid.pc
|
||||
%%UUID%%libdata/pkgconfig/fdisk.pc
|
||||
libdata/pkgconfig/smartcols.pc
|
||||
%%UUID%%libdata/pkgconfig/uuid.pc
|
||||
man/man1/cal.1.gz
|
||||
man/man1/chrt.1.gz
|
||||
man/man1/col.1.gz
|
||||
man/man1/colcrt.1.gz
|
||||
man/man1/colrm.1.gz
|
||||
man/man1/column.1.gz
|
||||
man/man1/flock.1.gz
|
||||
man/man1/getopt.1.gz
|
||||
man/man1/hardlink.1.gz
|
||||
man/man1/hexdump.1.gz
|
||||
man/man1/ipcmk.1.gz
|
||||
man/man1/logger.1.gz
|
||||
man/man1/look.1.gz
|
||||
man/man1/mcookie.1.gz
|
||||
man/man1/mesg.1.gz
|
||||
man/man1/namei.1.gz
|
||||
man/man1/rename.1.gz
|
||||
man/man1/renice.1.gz
|
||||
man/man1/rev.1.gz
|
||||
man/man1/scriptreplay.1.gz
|
||||
man/man1/setsid.1.gz
|
||||
man/man1/ul.1.gz
|
||||
%%UUID%%man/man1/uuidgen.1.gz
|
||||
%%UUID%%man/man1/uuidparse.1.gz
|
||||
man/man1/wall.1.gz
|
||||
man/man1/whereis.1.gz
|
||||
man/man3/libblkid.3.gz
|
||||
%%UUID%%man/man3/uuid.3.gz
|
||||
%%UUID%%man/man3/uuid_clear.3.gz
|
||||
%%UUID%%man/man3/uuid_compare.3.gz
|
||||
%%UUID%%man/man3/uuid_copy.3.gz
|
||||
%%UUID%%man/man3/uuid_generate.3.gz
|
||||
%%UUID%%man/man3/uuid_generate_random.3.gz
|
||||
%%UUID%%man/man3/uuid_generate_time.3.gz
|
||||
%%UUID%%man/man3/uuid_generate_time_safe.3.gz
|
||||
%%UUID%%man/man3/uuid_is_null.3.gz
|
||||
%%UUID%%man/man3/uuid_parse.3.gz
|
||||
%%UUID%%man/man3/uuid_time.3.gz
|
||||
%%UUID%%man/man3/uuid_unparse.3.gz
|
||||
man/man5/terminal-colors.d.5.gz
|
||||
man/man8/blkid.8.gz
|
||||
%%UUID%%man/man8/cfdisk.8.gz
|
||||
%%UUID%%man/man8/fdisk.8.gz
|
||||
man/man8/findfs.8.gz
|
||||
man/man8/fsck.cramfs.8.gz
|
||||
man/man8/fsck.minix.8.gz
|
||||
man/man8/isosize.8.gz
|
||||
man/man8/mkfs.8.gz
|
||||
man/man8/mkfs.bfs.8.gz
|
||||
man/man8/mkfs.cramfs.8.gz
|
||||
man/man8/mkfs.minix.8.gz
|
||||
man/man8/mkswap.8.gz
|
||||
man/man8/nologin.8.gz
|
||||
%%UUID%%man/man8/sfdisk.8.gz
|
||||
man/man8/swaplabel.8.gz
|
||||
man/man8/wipefs.8.gz
|
||||
sbin/blkid
|
||||
%%UUID%%sbin/cfdisk
|
||||
%%UUID%%sbin/fdisk
|
||||
sbin/findfs
|
||||
sbin/fsck.cramfs
|
||||
sbin/fsck.minix
|
||||
sbin/mkfs
|
||||
sbin/mkfs.bfs
|
||||
sbin/mkfs.cramfs
|
||||
sbin/mkfs.minix
|
||||
sbin/mkswap
|
||||
sbin/nologin
|
||||
%%UUID%%sbin/sfdisk
|
||||
sbin/swaplabel
|
||||
sbin/wipefs
|
||||
share/bash-completion/completions/blkid
|
||||
share/bash-completion/completions/cal
|
||||
%%UUID%%share/bash-completion/completions/cfdisk
|
||||
share/bash-completion/completions/chrt
|
||||
share/bash-completion/completions/col
|
||||
share/bash-completion/completions/colcrt
|
||||
share/bash-completion/completions/colrm
|
||||
share/bash-completion/completions/column
|
||||
%%UUID%%share/bash-completion/completions/fdisk
|
||||
share/bash-completion/completions/findfs
|
||||
share/bash-completion/completions/flock
|
||||
share/bash-completion/completions/fsck.cramfs
|
||||
share/bash-completion/completions/fsck.minix
|
||||
share/bash-completion/completions/getopt
|
||||
share/bash-completion/completions/hexdump
|
||||
share/bash-completion/completions/ipcmk
|
||||
share/bash-completion/completions/isosize
|
||||
share/bash-completion/completions/logger
|
||||
share/bash-completion/completions/look
|
||||
share/bash-completion/completions/mcookie
|
||||
share/bash-completion/completions/mesg
|
||||
share/bash-completion/completions/mkfs
|
||||
share/bash-completion/completions/mkfs.bfs
|
||||
share/bash-completion/completions/mkfs.cramfs
|
||||
share/bash-completion/completions/mkfs.minix
|
||||
share/bash-completion/completions/mkswap
|
||||
share/bash-completion/completions/namei
|
||||
share/bash-completion/completions/rename
|
||||
share/bash-completion/completions/renice
|
||||
share/bash-completion/completions/rev
|
||||
share/bash-completion/completions/scriptreplay
|
||||
share/bash-completion/completions/setsid
|
||||
%%UUID%%share/bash-completion/completions/sfdisk
|
||||
share/bash-completion/completions/swaplabel
|
||||
share/bash-completion/completions/ul
|
||||
%%UUID%%share/bash-completion/completions/uuidgen
|
||||
%%UUID%%share/bash-completion/completions/uuidparse
|
||||
share/bash-completion/completions/wall
|
||||
share/bash-completion/completions/whereis
|
||||
share/bash-completion/completions/wipefs
|
Loading…
Reference in New Issue
Block a user