Import libgtop, It's gnome top library.
This commit is contained in:
parent
a9e43cb60f
commit
8c89cf135d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13553
24
devel/libgtop/Makefile
Normal file
24
devel/libgtop/Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
# New ports collection makefile for: libgtop
|
||||
# Version required: 0.26.2
|
||||
# Date Created: 26 Sep 1998
|
||||
# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
|
||||
#
|
||||
# $Id:$
|
||||
#
|
||||
|
||||
DISTNAME= libgtop-0.26.2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://ftp.home-of-linux.org/pub/libgtop/
|
||||
|
||||
MAINTAINER= vanilla@FreeBSD.ORG
|
||||
|
||||
LIB_DEPENDS= glib11.0:${PORTSDIR}/devel/glib
|
||||
|
||||
#USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
post-install:
|
||||
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/libgtop/distinfo
Normal file
1
devel/libgtop/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (libgtop-0.26.2.tar.gz) = 5d0636375fa2e5732732c8adbc5412e8
|
65
devel/libgtop/files/patch-ab
Normal file
65
devel/libgtop/files/patch-ab
Normal file
@ -0,0 +1,65 @@
|
||||
--- lib/Makefile.in.orig Sun Sep 27 22:28:31 1998
|
||||
+++ lib/Makefile.in Wed Sep 30 01:47:05 1998
|
||||
@@ -125,7 +125,7 @@
|
||||
LT_CURRENT = @LT_CURRENT@
|
||||
LT_RELEASE = @LT_RELEASE@
|
||||
LT_REVISION = @LT_REVISION@
|
||||
-LT_VERSION_INFO = @LT_VERSION_INFO@
|
||||
+LT_VERSION_INFO = --version-info 0:0:0
|
||||
MAKEINFO = @MAKEINFO@
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MSGFMT = @MSGFMT@
|
||||
--- sysdeps/common/Makefile.in.orig Sun Sep 27 22:28:06 1998
|
||||
+++ sysdeps/common/Makefile.in Wed Sep 30 01:48:11 1998
|
||||
@@ -125,7 +125,7 @@
|
||||
LT_CURRENT = @LT_CURRENT@
|
||||
LT_RELEASE = @LT_RELEASE@
|
||||
LT_REVISION = @LT_REVISION@
|
||||
-LT_VERSION_INFO = @LT_VERSION_INFO@
|
||||
+LT_VERSION_INFO = --version-info 0:0:0
|
||||
MAKEINFO = @MAKEINFO@
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MSGFMT = @MSGFMT@
|
||||
--- sysdeps/freebsd/Makefile.in.orig Sun Sep 27 22:28:24 1998
|
||||
+++ sysdeps/freebsd/Makefile.in Wed Sep 30 01:48:46 1998
|
||||
@@ -124,7 +124,7 @@
|
||||
LT_CURRENT = @LT_CURRENT@
|
||||
LT_RELEASE = @LT_RELEASE@
|
||||
LT_REVISION = @LT_REVISION@
|
||||
-LT_VERSION_INFO = @LT_VERSION_INFO@
|
||||
+LT_VERSION_INFO = --version-info 0:0:0
|
||||
MAKEINFO = @MAKEINFO@
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MSGFMT = @MSGFMT@
|
||||
--- sysdeps/names/Makefile.in.orig Sun Sep 27 22:28:15 1998
|
||||
+++ sysdeps/names/Makefile.in Wed Sep 30 01:49:10 1998
|
||||
@@ -125,7 +125,7 @@
|
||||
LT_CURRENT = @LT_CURRENT@
|
||||
LT_RELEASE = @LT_RELEASE@
|
||||
LT_REVISION = @LT_REVISION@
|
||||
-LT_VERSION_INFO = @LT_VERSION_INFO@
|
||||
+LT_VERSION_INFO = --version-info 0:0:0
|
||||
MAKEINFO = @MAKEINFO@
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MSGFMT = @MSGFMT@
|
||||
--- Makefile.in.orig Sun Sep 27 22:27:55 1998
|
||||
+++ Makefile.in Wed Sep 30 03:49:17 1998
|
||||
@@ -163,8 +163,7 @@
|
||||
@GUILE_TRUE@guile_SUBDIRS = guile
|
||||
@GUILE_FALSE@guile_SUBDIRS =
|
||||
|
||||
-SUBDIRS = po intl support macros include sysdeps lib src \
|
||||
- $(examples_SUBDIRS)
|
||||
+SUBDIRS = po intl macros include sysdeps lib src
|
||||
|
||||
DIST_SUBDIRS = po intl support macros include sysdeps src lib guile examples
|
||||
|
||||
@@ -174,7 +173,7 @@
|
||||
LIBGTOP-VERSION features.def perl/Makefile.PL.in perl/perl.awk \
|
||||
perl/MANIFEST perl/Changes libgtop-config.in RELNOTES-0.25
|
||||
|
||||
-confexecdir=$(libdir)
|
||||
+confexecdir=$(sysconfdir)
|
||||
confexec_DATA = $(top_builddir)/libgtopConf.sh
|
||||
|
||||
bin_SCRIPTS = $(top_builddir)/libgtop-config
|
20
devel/libgtop/files/patch-ac
Normal file
20
devel/libgtop/files/patch-ac
Normal file
@ -0,0 +1,20 @@
|
||||
--- configure.orig Sun Sep 27 21:43:04 1998
|
||||
+++ configure Wed Sep 30 01:50:52 1998
|
||||
@@ -2133,12 +2133,12 @@
|
||||
|
||||
|
||||
if test "$no_gnome_config" = "yes"; then
|
||||
- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
|
||||
-echo "configure:2138: checking for gnomeConf.sh file in $gnome_prefix" >&5
|
||||
- if test -f $gnome_prefix/gnomeConf.sh; then
|
||||
+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
|
||||
+echo "configure:2138: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
|
||||
+ if test -f $prefix/share/gnome/gnomeConf.sh; then
|
||||
echo "$ac_t""found" 1>&6
|
||||
- echo "loading gnome configuration from $gnome_prefix/gnomeConf.sh"
|
||||
- . $gnome_prefix/gnomeConf.sh
|
||||
+ echo "loading gnome configuration from $prefix/share/gnome/gnomeConf.sh"
|
||||
+ . $prefix/share/gnome/gnomeConf.sh
|
||||
gnome_found=yes
|
||||
else
|
||||
echo "$ac_t""not found" 1>&6
|
1
devel/libgtop/pkg-comment
Normal file
1
devel/libgtop/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
GNOME top library.
|
1
devel/libgtop/pkg-descr
Normal file
1
devel/libgtop/pkg-descr
Normal file
@ -0,0 +1 @@
|
||||
GNOME top library.
|
73
devel/libgtop/pkg-plist
Normal file
73
devel/libgtop/pkg-plist
Normal file
@ -0,0 +1,73 @@
|
||||
bin/libgtop_daemon
|
||||
bin/libgtop_server
|
||||
bin/libgtop-config
|
||||
etc/libgtopConf.sh
|
||||
include/glibtop_machine.h
|
||||
include/glibtop_server.h
|
||||
include/glibtop_suid.h
|
||||
include/glibtop.h
|
||||
include/glibtop/close.h
|
||||
include/glibtop/command.h
|
||||
include/glibtop/cpu.h
|
||||
include/glibtop/error.h
|
||||
include/glibtop/fsusage.h
|
||||
include/glibtop/global.h
|
||||
include/glibtop/gnuserv.h
|
||||
include/glibtop/inodedb.h
|
||||
include/glibtop/loadavg.h
|
||||
include/glibtop/mem.h
|
||||
include/glibtop/mountlist.h
|
||||
include/glibtop/msg_limits.h
|
||||
include/glibtop/open.h
|
||||
include/glibtop/parameter.h
|
||||
include/glibtop/prockernel.h
|
||||
include/glibtop/proclist.h
|
||||
include/glibtop/procmap.h
|
||||
include/glibtop/procmem.h
|
||||
include/glibtop/procsegment.h
|
||||
include/glibtop/procsignal.h
|
||||
include/glibtop/procstate.h
|
||||
include/glibtop/proctime.h
|
||||
include/glibtop/procuid.h
|
||||
include/glibtop/read.h
|
||||
include/glibtop/read_data.h
|
||||
include/glibtop/sem_limits.h
|
||||
include/glibtop/shm_limits.h
|
||||
include/glibtop/signal.h
|
||||
include/glibtop/swap.h
|
||||
include/glibtop/sysdeps.h
|
||||
include/glibtop/sysinfo.h
|
||||
include/glibtop/types.h
|
||||
include/glibtop/union.h
|
||||
include/glibtop/uptime.h
|
||||
include/glibtop/version.h
|
||||
include/glibtop/write.h
|
||||
include/glibtop/xmalloc.h
|
||||
lib/libgtop.a
|
||||
lib/libgtop.la
|
||||
lib/libgtop.so
|
||||
lib/libgtop.so.0
|
||||
lib/libgtop_common.a
|
||||
lib/libgtop_common.la
|
||||
lib/libgtop_common.so
|
||||
lib/libgtop_common.so.0
|
||||
lib/libgtop_names.a
|
||||
lib/libgtop_names.la
|
||||
lib/libgtop_names.so
|
||||
lib/libgtop_names.so.0
|
||||
lib/libgtop_suid_common.a
|
||||
lib/libgtop_suid_common.la
|
||||
lib/libgtop_suid_common.so
|
||||
lib/libgtop_suid_common.so.0
|
||||
lib/libgtop_sysdeps.a
|
||||
lib/libgtop_sysdeps.la
|
||||
lib/libgtop_sysdeps.so
|
||||
lib/libgtop_sysdeps.so.0
|
||||
lib/libgtop_sysdeps_suid.a
|
||||
lib/libgtop_sysdeps_suid.la
|
||||
lib/libgtop_sysdeps_suid.so
|
||||
lib/libgtop_sysdeps_suid.so.0
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
share/locale/fr/LC_MESSAGES/libgtop.mo
|
||||
@dirrm include/glibtop
|
24
devel/libgtop2/Makefile
Normal file
24
devel/libgtop2/Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
# New ports collection makefile for: libgtop
|
||||
# Version required: 0.26.2
|
||||
# Date Created: 26 Sep 1998
|
||||
# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
|
||||
#
|
||||
# $Id:$
|
||||
#
|
||||
|
||||
DISTNAME= libgtop-0.26.2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://ftp.home-of-linux.org/pub/libgtop/
|
||||
|
||||
MAINTAINER= vanilla@FreeBSD.ORG
|
||||
|
||||
LIB_DEPENDS= glib11.0:${PORTSDIR}/devel/glib
|
||||
|
||||
#USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
post-install:
|
||||
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/libgtop2/distinfo
Normal file
1
devel/libgtop2/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (libgtop-0.26.2.tar.gz) = 5d0636375fa2e5732732c8adbc5412e8
|
65
devel/libgtop2/files/patch-ab
Normal file
65
devel/libgtop2/files/patch-ab
Normal file
@ -0,0 +1,65 @@
|
||||
--- lib/Makefile.in.orig Sun Sep 27 22:28:31 1998
|
||||
+++ lib/Makefile.in Wed Sep 30 01:47:05 1998
|
||||
@@ -125,7 +125,7 @@
|
||||
LT_CURRENT = @LT_CURRENT@
|
||||
LT_RELEASE = @LT_RELEASE@
|
||||
LT_REVISION = @LT_REVISION@
|
||||
-LT_VERSION_INFO = @LT_VERSION_INFO@
|
||||
+LT_VERSION_INFO = --version-info 0:0:0
|
||||
MAKEINFO = @MAKEINFO@
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MSGFMT = @MSGFMT@
|
||||
--- sysdeps/common/Makefile.in.orig Sun Sep 27 22:28:06 1998
|
||||
+++ sysdeps/common/Makefile.in Wed Sep 30 01:48:11 1998
|
||||
@@ -125,7 +125,7 @@
|
||||
LT_CURRENT = @LT_CURRENT@
|
||||
LT_RELEASE = @LT_RELEASE@
|
||||
LT_REVISION = @LT_REVISION@
|
||||
-LT_VERSION_INFO = @LT_VERSION_INFO@
|
||||
+LT_VERSION_INFO = --version-info 0:0:0
|
||||
MAKEINFO = @MAKEINFO@
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MSGFMT = @MSGFMT@
|
||||
--- sysdeps/freebsd/Makefile.in.orig Sun Sep 27 22:28:24 1998
|
||||
+++ sysdeps/freebsd/Makefile.in Wed Sep 30 01:48:46 1998
|
||||
@@ -124,7 +124,7 @@
|
||||
LT_CURRENT = @LT_CURRENT@
|
||||
LT_RELEASE = @LT_RELEASE@
|
||||
LT_REVISION = @LT_REVISION@
|
||||
-LT_VERSION_INFO = @LT_VERSION_INFO@
|
||||
+LT_VERSION_INFO = --version-info 0:0:0
|
||||
MAKEINFO = @MAKEINFO@
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MSGFMT = @MSGFMT@
|
||||
--- sysdeps/names/Makefile.in.orig Sun Sep 27 22:28:15 1998
|
||||
+++ sysdeps/names/Makefile.in Wed Sep 30 01:49:10 1998
|
||||
@@ -125,7 +125,7 @@
|
||||
LT_CURRENT = @LT_CURRENT@
|
||||
LT_RELEASE = @LT_RELEASE@
|
||||
LT_REVISION = @LT_REVISION@
|
||||
-LT_VERSION_INFO = @LT_VERSION_INFO@
|
||||
+LT_VERSION_INFO = --version-info 0:0:0
|
||||
MAKEINFO = @MAKEINFO@
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MSGFMT = @MSGFMT@
|
||||
--- Makefile.in.orig Sun Sep 27 22:27:55 1998
|
||||
+++ Makefile.in Wed Sep 30 03:49:17 1998
|
||||
@@ -163,8 +163,7 @@
|
||||
@GUILE_TRUE@guile_SUBDIRS = guile
|
||||
@GUILE_FALSE@guile_SUBDIRS =
|
||||
|
||||
-SUBDIRS = po intl support macros include sysdeps lib src \
|
||||
- $(examples_SUBDIRS)
|
||||
+SUBDIRS = po intl macros include sysdeps lib src
|
||||
|
||||
DIST_SUBDIRS = po intl support macros include sysdeps src lib guile examples
|
||||
|
||||
@@ -174,7 +173,7 @@
|
||||
LIBGTOP-VERSION features.def perl/Makefile.PL.in perl/perl.awk \
|
||||
perl/MANIFEST perl/Changes libgtop-config.in RELNOTES-0.25
|
||||
|
||||
-confexecdir=$(libdir)
|
||||
+confexecdir=$(sysconfdir)
|
||||
confexec_DATA = $(top_builddir)/libgtopConf.sh
|
||||
|
||||
bin_SCRIPTS = $(top_builddir)/libgtop-config
|
20
devel/libgtop2/files/patch-ac
Normal file
20
devel/libgtop2/files/patch-ac
Normal file
@ -0,0 +1,20 @@
|
||||
--- configure.orig Sun Sep 27 21:43:04 1998
|
||||
+++ configure Wed Sep 30 01:50:52 1998
|
||||
@@ -2133,12 +2133,12 @@
|
||||
|
||||
|
||||
if test "$no_gnome_config" = "yes"; then
|
||||
- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
|
||||
-echo "configure:2138: checking for gnomeConf.sh file in $gnome_prefix" >&5
|
||||
- if test -f $gnome_prefix/gnomeConf.sh; then
|
||||
+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
|
||||
+echo "configure:2138: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
|
||||
+ if test -f $prefix/share/gnome/gnomeConf.sh; then
|
||||
echo "$ac_t""found" 1>&6
|
||||
- echo "loading gnome configuration from $gnome_prefix/gnomeConf.sh"
|
||||
- . $gnome_prefix/gnomeConf.sh
|
||||
+ echo "loading gnome configuration from $prefix/share/gnome/gnomeConf.sh"
|
||||
+ . $prefix/share/gnome/gnomeConf.sh
|
||||
gnome_found=yes
|
||||
else
|
||||
echo "$ac_t""not found" 1>&6
|
1
devel/libgtop2/pkg-comment
Normal file
1
devel/libgtop2/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
GNOME top library.
|
1
devel/libgtop2/pkg-descr
Normal file
1
devel/libgtop2/pkg-descr
Normal file
@ -0,0 +1 @@
|
||||
GNOME top library.
|
73
devel/libgtop2/pkg-plist
Normal file
73
devel/libgtop2/pkg-plist
Normal file
@ -0,0 +1,73 @@
|
||||
bin/libgtop_daemon
|
||||
bin/libgtop_server
|
||||
bin/libgtop-config
|
||||
etc/libgtopConf.sh
|
||||
include/glibtop_machine.h
|
||||
include/glibtop_server.h
|
||||
include/glibtop_suid.h
|
||||
include/glibtop.h
|
||||
include/glibtop/close.h
|
||||
include/glibtop/command.h
|
||||
include/glibtop/cpu.h
|
||||
include/glibtop/error.h
|
||||
include/glibtop/fsusage.h
|
||||
include/glibtop/global.h
|
||||
include/glibtop/gnuserv.h
|
||||
include/glibtop/inodedb.h
|
||||
include/glibtop/loadavg.h
|
||||
include/glibtop/mem.h
|
||||
include/glibtop/mountlist.h
|
||||
include/glibtop/msg_limits.h
|
||||
include/glibtop/open.h
|
||||
include/glibtop/parameter.h
|
||||
include/glibtop/prockernel.h
|
||||
include/glibtop/proclist.h
|
||||
include/glibtop/procmap.h
|
||||
include/glibtop/procmem.h
|
||||
include/glibtop/procsegment.h
|
||||
include/glibtop/procsignal.h
|
||||
include/glibtop/procstate.h
|
||||
include/glibtop/proctime.h
|
||||
include/glibtop/procuid.h
|
||||
include/glibtop/read.h
|
||||
include/glibtop/read_data.h
|
||||
include/glibtop/sem_limits.h
|
||||
include/glibtop/shm_limits.h
|
||||
include/glibtop/signal.h
|
||||
include/glibtop/swap.h
|
||||
include/glibtop/sysdeps.h
|
||||
include/glibtop/sysinfo.h
|
||||
include/glibtop/types.h
|
||||
include/glibtop/union.h
|
||||
include/glibtop/uptime.h
|
||||
include/glibtop/version.h
|
||||
include/glibtop/write.h
|
||||
include/glibtop/xmalloc.h
|
||||
lib/libgtop.a
|
||||
lib/libgtop.la
|
||||
lib/libgtop.so
|
||||
lib/libgtop.so.0
|
||||
lib/libgtop_common.a
|
||||
lib/libgtop_common.la
|
||||
lib/libgtop_common.so
|
||||
lib/libgtop_common.so.0
|
||||
lib/libgtop_names.a
|
||||
lib/libgtop_names.la
|
||||
lib/libgtop_names.so
|
||||
lib/libgtop_names.so.0
|
||||
lib/libgtop_suid_common.a
|
||||
lib/libgtop_suid_common.la
|
||||
lib/libgtop_suid_common.so
|
||||
lib/libgtop_suid_common.so.0
|
||||
lib/libgtop_sysdeps.a
|
||||
lib/libgtop_sysdeps.la
|
||||
lib/libgtop_sysdeps.so
|
||||
lib/libgtop_sysdeps.so.0
|
||||
lib/libgtop_sysdeps_suid.a
|
||||
lib/libgtop_sysdeps_suid.la
|
||||
lib/libgtop_sysdeps_suid.so
|
||||
lib/libgtop_sysdeps_suid.so.0
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
share/locale/fr/LC_MESSAGES/libgtop.mo
|
||||
@dirrm include/glibtop
|
Loading…
Reference in New Issue
Block a user