- Use correct USE_AUTOTOOLS libtool expression

- Fix build

PR:		ports/162040
Submitted by:	Laurent Berthelet <laurent@ospowa.com>
This commit is contained in:
Pawel Pekala 2011-10-28 17:49:34 +00:00
parent 17af7fcdb9
commit 8c82d344e7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=284553
3 changed files with 28 additions and 1 deletions

View File

@ -16,7 +16,7 @@ COMMENT= A useful widget set complementary to GTK+ 2.0
USE_GNOME= gtk20 gnomehack
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:22
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
LATEST_LINK= gtkextra2

View File

@ -0,0 +1,16 @@
--- gtkextra/Makefile.in.orig 2011-10-27 00:29:46.287956897 +0200
+++ gtkextra/Makefile.in 2011-10-27 00:30:31.199394384 +0200
@@ -1028,11 +1028,11 @@
$(libgtkextra_x11_2_0_la_OBJECTS) $(libgtkextra_linux_fb_2_0_la_OBJECTS) $(libgtkextra_win32_2_0_la_OBJECTS): ${gtkextra_built_public_sources} ${gtkextra_built_private_headers}
$(srcdir)/gtkextra-marshal.h: gtkextra-marshal.list
- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
+ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
&& mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
|| ( rm -f gtkextra-marshal.tmp && exit 1 )
$(srcdir)/gtkextra-marshal.c: gtkextra-marshal.h
- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
+ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
&& mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
|| ( rm -f gtkextra-marshal.tmp && exit 1 )

View File

@ -0,0 +1,11 @@
--- gtkextra/gtkcolorcombo.c.orig 2011-10-27 00:08:40.655552360 +0200
+++ gtkextra/gtkcolorcombo.c 2011-10-27 00:09:03.934648236 +0200
@@ -146,7 +146,7 @@
GTK_CLASS_TYPE(object_class),
GTK_SIGNAL_OFFSET(GtkColorComboClass,
changed),
- gtkextra_VOID__INT_BOXED,
+ gtkextra_VOID__BOXED_BOXED,
GTK_TYPE_NONE,
2, GTK_TYPE_INT, GDK_TYPE_COLOR);