o Build and install some tools in the wily tarball to make the behaviour
of `wily' closer to that of `acme'. o Freshen ${MASTER_SITE}. o Hand over maintainership to Serge Gagnon <gagnon__s@videotron.ca> PR: ports/47157 Submitted by: Serge Gagnon <gagnon__s@videotron.ca>
This commit is contained in:
parent
76a6849607
commit
8c62080ebc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=74798
@ -8,16 +8,24 @@
|
||||
PORTNAME= wily
|
||||
PORTVERSION= 0.13.41
|
||||
CATEGORIES= editors plan9
|
||||
MASTER_SITES= ftp://ftp.northsea.com/pub/plan9_unix/wily/src/ \
|
||||
ftp://ftp.cs.york.ac.uk/pub/mhw/wily/src/ \
|
||||
MASTER_SITES= ftp://ftp.cs.yorku.ca/pub/wily/src/old/ \
|
||||
ftp://ftp.math.tau.ac.il/pub/laden/wily/src/ \
|
||||
ftp://ftp.cs.su.oz.au/gary/wily/src/old/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= jkoshy@freebsd.org
|
||||
MAINTAINER= gagnon__s@videotron.ca
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/bin/rc:${PORTSDIR}/shells/rc
|
||||
|
||||
USE_XLIB= YES
|
||||
GNU_CONFIGURE= YES
|
||||
USE_GMAKE= YES
|
||||
MAN1= wgoto.1 win.1 wreplace.1 Tag.1 mktags.1 Man.1
|
||||
|
||||
# Run the configure script in the tools directory.
|
||||
post-configure:
|
||||
${RM} ${WRKSRC}/tools/win/config.cache
|
||||
cd ${WRKSRC}/tools/win; ./configure
|
||||
|
||||
WILYDOCDIR= ${PREFIX}/share/doc/wily
|
||||
WILYTUTEDIR= ${WILYDOCDIR}/tute
|
||||
@ -40,5 +48,6 @@ post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/Doc/$${f} ${WILYDOCDIR}/$${f}; \
|
||||
done
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
27
editors/wily/files/patch-Makefile
Normal file
27
editors/wily/files/patch-Makefile
Normal file
@ -0,0 +1,27 @@
|
||||
--- Makefile.in.orig Sun Jan 19 08:44:47 2003
|
||||
+++ Makefile.in Sun Jan 19 08:49:06 2003
|
||||
@@ -2,9 +2,9 @@
|
||||
srcdir=@srcdir@
|
||||
VPATH=@srcdir@
|
||||
|
||||
-SUBDIRS=libXg libframe libmsg wily
|
||||
+SUBDIRS=libXg libframe libmsg wily tools/win
|
||||
|
||||
-all: wily/wily
|
||||
+all: wily/wily win
|
||||
|
||||
wily/wily: libXg/libXg.a libframe/libframe.a libmsg/libmsg.a
|
||||
cd wily; $(MAKE) $(MFLAGS)
|
||||
@@ -14,9 +14,11 @@
|
||||
cd libframe; $(MAKE) $(MFLAGS) all
|
||||
libmsg/libmsg.a:
|
||||
cd libmsg; $(MAKE) $(MFLAGS) all
|
||||
-
|
||||
+win:
|
||||
+ cd tools/win; $(MAKE) $(MFLAGS)
|
||||
install: all
|
||||
cd wily; $(MAKE) $(MFLAGS) install
|
||||
+ cd tools/win; $(MAKE) $(MFLAGS) install
|
||||
clean:
|
||||
for i in $(SUBDIRS); do \
|
||||
(cd $$i; $(MAKE) $(MFLAGS) $@); \
|
22
editors/wily/files/patch-win::Makefile
Normal file
22
editors/wily/files/patch-win::Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
--- tools/win/Makefile.in.orig Sun Jan 19 09:03:49 2003
|
||||
+++ tools/win/Makefile.in Sun Jan 19 09:05:36 2003
|
||||
@@ -3,6 +3,7 @@
|
||||
srcdir = @srcdir@
|
||||
VPATH = @srcdir@
|
||||
|
||||
+wilydir = ../../
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = $(exec_prefix)/bin
|
||||
@@ -12,9 +13,9 @@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
|
||||
CC = @CC@
|
||||
-CFLAGS = @CFLAGS@ -I.. -I$(srcdir)/../include -I$(srcdir)/../sam/include
|
||||
+CFLAGS = @CFLAGS@ -I$(wilydir) -I$(wilydir)/include
|
||||
DEFS = @DEFS@
|
||||
-LIBS = @LIBS@ ../libmsg/libmsg.a ../sam/libXg/libXg.a
|
||||
+LIBS = $(wilydir)/libmsg/libmsg.a $(wilydir)/libXg/libXg.a
|
||||
LDFLAGS = @LDFLAGS@
|
||||
|
||||
RC = @RC@
|
10
editors/wily/files/patch-win::Man.rc
Normal file
10
editors/wily/files/patch-win::Man.rc
Normal file
@ -0,0 +1,10 @@
|
||||
--- tools/win/Man.rc.orig Sun Jan 19 08:59:21 2003
|
||||
+++ tools/win/Man.rc Sun Jan 19 08:59:41 2003
|
||||
@@ -10,6 +10,6 @@
|
||||
}
|
||||
|
||||
name = `{ echo $*($#*) }
|
||||
-man $* >[2=1] | col -bx | wreplace -c '+Man '^$name^':,'
|
||||
+man $* >[2=1] | col -bx | wreplace -c '~Man '^$name^':,'
|
||||
|
||||
exit
|
@ -3,4 +3,4 @@ text based working environment for programmers.
|
||||
|
||||
Wily works best with 3 button rodents.
|
||||
|
||||
WWW: http://www.cs.su.oz.au/~gary/wily/
|
||||
WWW: http://www.cs.yorku.ca/~oz/wily/
|
||||
|
9
editors/wily/pkg-message
Normal file
9
editors/wily/pkg-message
Normal file
@ -0,0 +1,9 @@
|
||||
The following tools have been installed along with wily:
|
||||
|
||||
wreplace win wgoto mktags Man Tag
|
||||
|
||||
Please refer to their manual pages for information on their use.
|
||||
|
||||
The wily(1) manual page has not been installed because it's out-of-date.
|
||||
|
||||
Please refer to "${PREFIX}/share/doc/wily/documentation".
|
@ -1,4 +1,10 @@
|
||||
bin/Man
|
||||
bin/Tag
|
||||
bin/mktags
|
||||
bin/wgoto
|
||||
bin/wily
|
||||
bin/win
|
||||
bin/wreplace
|
||||
share/doc/wily/index.html
|
||||
share/doc/wily/intro.html
|
||||
share/doc/wily/download.html
|
||||
|
Loading…
Reference in New Issue
Block a user