- Fix build with clang on i386.

- Remove USE_GCC.
- No PORTREVISION bump as there should be no functional change.

Submitted by:	dim
Obtained from:	multimedia/gstreamer-plugins-good/files/patch-gst_goom_mmx.h
This commit is contained in:
Juergen Lock 2013-11-28 17:14:06 +00:00
parent 65990f38b1
commit 8c2c7ef1b0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=335108
2 changed files with 18 additions and 4 deletions

View File

@ -40,8 +40,4 @@ pre-everything::
BROKEN= Does not compile on powerpc
.endif
.if ${ARCH} == "i386"
USE_GCC= any
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,18 @@
--- src/mmx.h.orig
+++ src/mmx.h
@@ -715,13 +715,13 @@ void zoom_filter_xmmx (int prevX, int pr
{ \
printf("emms()\n"); \
__asm__ __volatile__ ("emms" \
- "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)"); \
+ "st","st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)"); \
}
#else
#define emms() __asm__ __volatile__ ("emms"::: \
- "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)")
+ "st","st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)")
#endif