Upgrade from 0.8 to 1.2.
This commit is contained in:
parent
ed0b26a4c4
commit
8beadb7b9a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=5892
@ -1,17 +1,22 @@
|
||||
# New ports collection makefile for: tkinfo
|
||||
# Version required: 0.8
|
||||
# Version required: 1.2
|
||||
# Date created: 16 Jan 1995
|
||||
# Whom: thomas@ghpc8.ihf.rwth-aachen.de
|
||||
#
|
||||
# $Id: Makefile,v 1.9 1996/11/11 05:50:14 obrien Exp $
|
||||
# $Id: Makefile,v 1.10 1997/02/07 09:01:45 tg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tkinfo-0.8
|
||||
DISTNAME= tkinfo-1.2
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://emile.math.ucsb.edu:8000/
|
||||
MASTER_SITES= http://www.math.ucsb.edu/~boldt/tkinfo/ \
|
||||
http://math-www.uni-paderborn.de/~axel/tkinfo/
|
||||
|
||||
MAINTAINER= tg@freebsd.org
|
||||
|
||||
RUN_DEPENDS= wish4.1:${PORTSDIR}/x11/tk41
|
||||
NO_BUILD= yes
|
||||
|
||||
do-install:
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/tkinfo ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (tkinfo-0.8.tar.gz) = e4ed6136da71da8ca82c16eb0c4ed493
|
||||
MD5 (tkinfo-1.2.tar.gz) = bfb85b4bd129c0a107f9e1cf344d1260
|
||||
|
@ -1,16 +1,19 @@
|
||||
--- tkinfo.orig Fri Feb 7 05:34:36 1997
|
||||
+++ tkinfo Fri Feb 7 09:44:40 1997
|
||||
@@ -7,11 +7,11 @@
|
||||
# uses the same directory as where this shell script is installed.
|
||||
# You might consider installing the scripts into "/usr/local/lib/tkinfo",
|
||||
# and using LIBDIR=/usr/local/lib/tkinfo instead.
|
||||
-LIBDIR=`dirname $0`
|
||||
+LIBDIR=`dirname $0`/../share/tk/tkinfo
|
||||
#LIBDIR=/usr/local/lib/tkinfo
|
||||
--- tkinfo.orig Thu Mar 6 02:07:29 1997
|
||||
+++ tkinfo Thu Mar 6 11:41:30 1997
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/sh
|
||||
# This is a Tcl/Tk script to be interpreted by wish (Tk4.0 or better): \
|
||||
-exec wish "$0" "$@"
|
||||
+exec wish4.1 "$0" "$@"
|
||||
|
||||
# Set the name (or path) of the wish binary. Normally just ``wish''.
|
||||
-WISH=wish
|
||||
+WISH=wish4.1
|
||||
##########################################################################
|
||||
# Version of TkInfo:
|
||||
@@ -443,7 +443,7 @@
|
||||
proc tkiInit { } {
|
||||
global tki env auto_path tkiEmbed geometry
|
||||
|
||||
exec $WISH -file $LIBDIR/tkinfo.tcl -name tkinfo ${1+"$@"}
|
||||
exit 1
|
||||
- set defInfoPath [list . \
|
||||
+ set defInfoPath [list . /usr/share/info \
|
||||
/usr/info /usr/local/info /usr/local/gnu/info \
|
||||
/usr/local/emacs/info /usr/local/lib/emacs/info \
|
||||
/usr/lib/xemacs/info /usr/local/lib/xemacs/info \
|
||||
|
@ -1,6 +1 @@
|
||||
bin/tkinfo
|
||||
share/tk/tkinfo/searchbox.tcl
|
||||
share/tk/tkinfo/tkicore.tcl
|
||||
share/tk/tkinfo/tkinfo.tcl
|
||||
share/tk/tkinfo/tkiwin.tcl
|
||||
share/tk/tkinfo/topgetopt.tcl
|
||||
|
Loading…
Reference in New Issue
Block a user