Update to 0.6.1
Submitted by: marcus
This commit is contained in:
parent
5504e26b7b
commit
8bd4ca579c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=79440
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gstreamer
|
||||
PORTVERSION= 0.6.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.6.1
|
||||
CATEGORIES= multimedia audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -18,18 +17,15 @@ MAINTAINER= lioux@FreeBSD.org
|
||||
COMMENT= GStreamer written collection of plugins handling several media types
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20 \
|
||||
gconf-2.5:${PORTSDIR}/devel/gconf2 \
|
||||
gstreamer-0.6.0:${PORTSDIR}/multimedia/gstreamer \
|
||||
gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20 \
|
||||
LIB_DEPENDS= gstreamer-0.6.0:${PORTSDIR}/multimedia/gstreamer \
|
||||
popt.0:${PORTSDIR}/devel/popt \
|
||||
xml2.5:${PORTSDIR}/textproc/libxml2
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack \
|
||||
gnomehier \
|
||||
gnomeprefix
|
||||
gnomeprefix \
|
||||
gconf2
|
||||
USE_LIBTOOL= yes
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
@ -119,6 +115,8 @@ post-install:
|
||||
# hermes is required for gstreamer-player to work
|
||||
# since it is currently the only colorspace plugin available
|
||||
WITH_HERMES= yes
|
||||
# gnomevfs is required for gstreamer-player to work
|
||||
WITH_GNOMEVFS= yes
|
||||
|
||||
##
|
||||
## auto detect possible plugins
|
||||
@ -160,7 +158,7 @@ WITH_LAME=yes
|
||||
.endif
|
||||
|
||||
# gnomevfs
|
||||
.if exists(${X11BASE}/lib/libgnomevfs-2.a)
|
||||
.if ${HAVE_GNOME:Mgnomevfs2}!=""
|
||||
WITH_GNOMEVFS=yes
|
||||
.endif
|
||||
|
||||
@ -344,8 +342,7 @@ PLIST_SUB+= FREETYPE=""
|
||||
CONFIGURE_ARGS+= --disable-gnome_vfs
|
||||
PLIST_SUB+= GNOMEVFS="@comment "
|
||||
.else
|
||||
LIB_DEPENDS+= gnomevfs-2.0:${PORTSDIR}/devel/gnomevfs2
|
||||
|
||||
USE_GNOME+= gnomevfs2
|
||||
PLIST_SUB+= GNOMEVFS=""
|
||||
.endif
|
||||
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gst-plugins-0.6.0.tar.gz) = c1eadcf2486577bb36d4e89cbfa2e65f
|
||||
MD5 (gst-plugins-0.6.1.tar.gz) = 0d3cc17cafc57f145d80b880af47f99f
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- ext/a52dec/gsta52dec.c.orig Sun Apr 6 18:58:19 2003
|
||||
+++ ext/a52dec/gsta52dec.c Sun Apr 20 13:16:28 2003
|
||||
@@ -25,7 +25,7 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
|
||||
-#ifdef HAVE_STDINT_H
|
||||
+#if defined(HAVE_STDINT_H) || defined(__FreeBSD__)
|
||||
#include <stdint.h>
|
||||
#else
|
||||
/* (Ronald) hacky... can't include stdint.h because it's not available
|
@ -20,8 +20,8 @@ lib/gstreamer-%%VERSION%%/libgstaudio.so
|
||||
%%LIBAUDIOFILE%%lib/gstreamer-%%VERSION%%/libgstaudiofile.so
|
||||
lib/gstreamer-%%VERSION%%/libgstaudioscale.so
|
||||
lib/gstreamer-%%VERSION%%/libgstauparse.so
|
||||
%%AVIFILE%%lib/gstreamer-%%VERSION%%/libgstavidemux.so
|
||||
%%AVIFILE%%lib/gstreamer-%%VERSION%%/libgstavimux.so
|
||||
lib/gstreamer-%%VERSION%%/libgstavidemux.so
|
||||
lib/gstreamer-%%VERSION%%/libgstavimux.so
|
||||
lib/gstreamer-%%VERSION%%/libgstcdxaparse.so
|
||||
lib/gstreamer-%%VERSION%%/libgstchart.so
|
||||
%%HERMES%%lib/gstreamer-%%VERSION%%/libgstcolorspace.so
|
||||
@ -54,6 +54,7 @@ lib/gstreamer-%%VERSION%%/libgstlevel.so
|
||||
%%LIBMAD%%lib/gstreamer-%%VERSION%%/libgstmad.so
|
||||
lib/gstreamer-%%VERSION%%/libgstmedian.so
|
||||
%%LIBMIKMOD%%lib/gstreamer-%%VERSION%%/libgstmikmod.so
|
||||
lib/gstreamer-%%VERSION%%/libgstmodplug.so
|
||||
lib/gstreamer-%%VERSION%%/libgstmono2stereo.so
|
||||
lib/gstreamer-%%VERSION%%/libgstmonoscope.so
|
||||
lib/gstreamer-%%VERSION%%/libgstmp1videoparse.so
|
||||
@ -123,7 +124,6 @@ lib/libgstplay-%%VERSION%%.so.%%SHLIB_VERSION%%
|
||||
libdata/pkgconfig/gstreamer-gconf-%%VERSION%%.pc
|
||||
libdata/pkgconfig/gstreamer-libs-%%VERSION%%.pc
|
||||
libdata/pkgconfig/gstreamer-play-%%VERSION%%.pc
|
||||
share/aclocal/gst-element-check-%%VERSION%%.m4
|
||||
@unexec rmdir %D/lib/gstreamer-%%VERSION%% 2>/dev/null || true
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/video
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/riff
|
||||
|
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gstreamer
|
||||
PORTVERSION= 0.6.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.6.1
|
||||
CATEGORIES= multimedia audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -18,18 +17,15 @@ MAINTAINER= lioux@FreeBSD.org
|
||||
COMMENT= GStreamer written collection of plugins handling several media types
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20 \
|
||||
gconf-2.5:${PORTSDIR}/devel/gconf2 \
|
||||
gstreamer-0.6.0:${PORTSDIR}/multimedia/gstreamer \
|
||||
gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20 \
|
||||
LIB_DEPENDS= gstreamer-0.6.0:${PORTSDIR}/multimedia/gstreamer \
|
||||
popt.0:${PORTSDIR}/devel/popt \
|
||||
xml2.5:${PORTSDIR}/textproc/libxml2
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack \
|
||||
gnomehier \
|
||||
gnomeprefix
|
||||
gnomeprefix \
|
||||
gconf2
|
||||
USE_LIBTOOL= yes
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
@ -119,6 +115,8 @@ post-install:
|
||||
# hermes is required for gstreamer-player to work
|
||||
# since it is currently the only colorspace plugin available
|
||||
WITH_HERMES= yes
|
||||
# gnomevfs is required for gstreamer-player to work
|
||||
WITH_GNOMEVFS= yes
|
||||
|
||||
##
|
||||
## auto detect possible plugins
|
||||
@ -160,7 +158,7 @@ WITH_LAME=yes
|
||||
.endif
|
||||
|
||||
# gnomevfs
|
||||
.if exists(${X11BASE}/lib/libgnomevfs-2.a)
|
||||
.if ${HAVE_GNOME:Mgnomevfs2}!=""
|
||||
WITH_GNOMEVFS=yes
|
||||
.endif
|
||||
|
||||
@ -344,8 +342,7 @@ PLIST_SUB+= FREETYPE=""
|
||||
CONFIGURE_ARGS+= --disable-gnome_vfs
|
||||
PLIST_SUB+= GNOMEVFS="@comment "
|
||||
.else
|
||||
LIB_DEPENDS+= gnomevfs-2.0:${PORTSDIR}/devel/gnomevfs2
|
||||
|
||||
USE_GNOME+= gnomevfs2
|
||||
PLIST_SUB+= GNOMEVFS=""
|
||||
.endif
|
||||
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gst-plugins-0.6.0.tar.gz) = c1eadcf2486577bb36d4e89cbfa2e65f
|
||||
MD5 (gst-plugins-0.6.1.tar.gz) = 0d3cc17cafc57f145d80b880af47f99f
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- ext/a52dec/gsta52dec.c.orig Sun Apr 6 18:58:19 2003
|
||||
+++ ext/a52dec/gsta52dec.c Sun Apr 20 13:16:28 2003
|
||||
@@ -25,7 +25,7 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
|
||||
-#ifdef HAVE_STDINT_H
|
||||
+#if defined(HAVE_STDINT_H) || defined(__FreeBSD__)
|
||||
#include <stdint.h>
|
||||
#else
|
||||
/* (Ronald) hacky... can't include stdint.h because it's not available
|
@ -20,8 +20,8 @@ lib/gstreamer-%%VERSION%%/libgstaudio.so
|
||||
%%LIBAUDIOFILE%%lib/gstreamer-%%VERSION%%/libgstaudiofile.so
|
||||
lib/gstreamer-%%VERSION%%/libgstaudioscale.so
|
||||
lib/gstreamer-%%VERSION%%/libgstauparse.so
|
||||
%%AVIFILE%%lib/gstreamer-%%VERSION%%/libgstavidemux.so
|
||||
%%AVIFILE%%lib/gstreamer-%%VERSION%%/libgstavimux.so
|
||||
lib/gstreamer-%%VERSION%%/libgstavidemux.so
|
||||
lib/gstreamer-%%VERSION%%/libgstavimux.so
|
||||
lib/gstreamer-%%VERSION%%/libgstcdxaparse.so
|
||||
lib/gstreamer-%%VERSION%%/libgstchart.so
|
||||
%%HERMES%%lib/gstreamer-%%VERSION%%/libgstcolorspace.so
|
||||
@ -54,6 +54,7 @@ lib/gstreamer-%%VERSION%%/libgstlevel.so
|
||||
%%LIBMAD%%lib/gstreamer-%%VERSION%%/libgstmad.so
|
||||
lib/gstreamer-%%VERSION%%/libgstmedian.so
|
||||
%%LIBMIKMOD%%lib/gstreamer-%%VERSION%%/libgstmikmod.so
|
||||
lib/gstreamer-%%VERSION%%/libgstmodplug.so
|
||||
lib/gstreamer-%%VERSION%%/libgstmono2stereo.so
|
||||
lib/gstreamer-%%VERSION%%/libgstmonoscope.so
|
||||
lib/gstreamer-%%VERSION%%/libgstmp1videoparse.so
|
||||
@ -123,7 +124,6 @@ lib/libgstplay-%%VERSION%%.so.%%SHLIB_VERSION%%
|
||||
libdata/pkgconfig/gstreamer-gconf-%%VERSION%%.pc
|
||||
libdata/pkgconfig/gstreamer-libs-%%VERSION%%.pc
|
||||
libdata/pkgconfig/gstreamer-play-%%VERSION%%.pc
|
||||
share/aclocal/gst-element-check-%%VERSION%%.m4
|
||||
@unexec rmdir %D/lib/gstreamer-%%VERSION%% 2>/dev/null || true
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/video
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/riff
|
||||
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gstreamer
|
||||
PORTVERSION= 0.6.0
|
||||
PORTVERSION= 0.6.1
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -15,18 +15,18 @@ MAINTAINER= lioux@FreeBSD.org
|
||||
COMMENT= Development framework for creating media applications
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20 \
|
||||
popt.0:${PORTSDIR}/devel/popt \
|
||||
xml2.5:${PORTSDIR}/textproc/libxml2
|
||||
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_BISON= yes
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_REINPLACE= yes
|
||||
WANT_GNOME= yes
|
||||
USE_GNOME= gnomehack \
|
||||
gnomeprefix
|
||||
gnomeprefix \
|
||||
glib20 \
|
||||
libxml2
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-tests \
|
||||
--disable-failing-tests
|
||||
@ -54,8 +54,8 @@ post-install:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if exists(${X11BASE}/libdata/pkgconfig/libgnomeui-2.0.pc)
|
||||
LIB_DEPENDS+= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui
|
||||
.if ${HAVE_GNOME:Mlibgnomeui}!=""
|
||||
USE_GNOME+= libgnomeui
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gstreamer-0.6.0.tar.bz2) = 3d0dec37678b33bbcb23cb2e20a83fe4
|
||||
MD5 (gstreamer-0.6.1.tar.bz2) = e9db8443c7679978b72d485c744f3189
|
||||
|
@ -1,13 +1,5 @@
|
||||
--- configure.orig Wed Jan 22 09:17:40 2003
|
||||
+++ configure Wed Jan 29 14:49:56 2003
|
||||
@@ -7520,6 +7520,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
@@ -7712,7 +7713,7 @@
|
||||
if test "x$COMPILER" = "xforte"; then
|
||||
GST_ERROR=
|
||||
|
42
multimedia/gstreamer/files/patch-ltmain.sh
Normal file
42
multimedia/gstreamer/files/patch-ltmain.sh
Normal file
@ -0,0 +1,42 @@
|
||||
--- ltmain.sh.orig Fri Sep 13 15:38:11 2002
|
||||
+++ ltmain.sh Fri Oct 11 01:44:24 2002
|
||||
@@ -1073,8 +1073,16 @@
|
||||
continue
|
||||
;;
|
||||
|
||||
+ -pthread)
|
||||
+ compile_command="$compile_command -pthread"
|
||||
+ finalize_command="$finalize_command -pthread"
|
||||
+ compiler_flags="$compiler_flags -pthread"
|
||||
+ continue
|
||||
+ ;;
|
||||
+
|
||||
-module)
|
||||
module=yes
|
||||
+ build_old_libs=no
|
||||
continue
|
||||
;;
|
||||
|
||||
@@ -2502,6 +2510,9 @@
|
||||
*-*-openbsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test $build_libtool_need_lc = "yes"; then
|
||||
@@ -4286,10 +4297,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -65,12 +65,14 @@ include/gstreamer-%%VERSION%%/gst/gstxml.h
|
||||
include/gstreamer-%%VERSION%%/gst/putbits/putbits.h
|
||||
lib/gstreamer-%%VERSION%%/libgstautoplugcache.so
|
||||
lib/gstreamer-%%VERSION%%/libgstautoplugger.so
|
||||
lib/gstreamer-%%VERSION%%/libgstbasicgthreadscheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstbasicomegascheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstbasicwingoscheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstbytestream.so
|
||||
lib/gstreamer-%%VERSION%%/libgstelements.so
|
||||
lib/gstreamer-%%VERSION%%/libgstgetbits.so
|
||||
lib/gstreamer-%%VERSION%%/libgstindexers.so
|
||||
lib/gstreamer-%%VERSION%%/libgstoptgthreadscheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstoptomegascheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstoptscheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstoptwingoscheduler.so
|
||||
@ -87,6 +89,7 @@ lib/libgstreamer-%%VERSION%%.so
|
||||
lib/libgstreamer-%%VERSION%%.so.%%SHLIB_VERSION%%
|
||||
libdata/pkgconfig/gstreamer-%%VERSION%%.pc
|
||||
libdata/pkgconfig/gstreamer-control-%%VERSION%%.pc
|
||||
share/aclocal/gst-element-check-%%VERSION%%.m4
|
||||
@unexec rm %D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
|
||||
@dirrm share/gnome/cache/gstreamer-%%VERSION%%
|
||||
@unexec rmdir %D/share/gnome/cache 2>/dev/null || true
|
||||
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gstreamer
|
||||
PORTVERSION= 0.6.0
|
||||
PORTVERSION= 0.6.1
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -15,18 +15,18 @@ MAINTAINER= lioux@FreeBSD.org
|
||||
COMMENT= Development framework for creating media applications
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20 \
|
||||
popt.0:${PORTSDIR}/devel/popt \
|
||||
xml2.5:${PORTSDIR}/textproc/libxml2
|
||||
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_BISON= yes
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_REINPLACE= yes
|
||||
WANT_GNOME= yes
|
||||
USE_GNOME= gnomehack \
|
||||
gnomeprefix
|
||||
gnomeprefix \
|
||||
glib20 \
|
||||
libxml2
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-tests \
|
||||
--disable-failing-tests
|
||||
@ -54,8 +54,8 @@ post-install:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if exists(${X11BASE}/libdata/pkgconfig/libgnomeui-2.0.pc)
|
||||
LIB_DEPENDS+= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui
|
||||
.if ${HAVE_GNOME:Mlibgnomeui}!=""
|
||||
USE_GNOME+= libgnomeui
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gstreamer-0.6.0.tar.bz2) = 3d0dec37678b33bbcb23cb2e20a83fe4
|
||||
MD5 (gstreamer-0.6.1.tar.bz2) = e9db8443c7679978b72d485c744f3189
|
||||
|
@ -1,13 +1,5 @@
|
||||
--- configure.orig Wed Jan 22 09:17:40 2003
|
||||
+++ configure Wed Jan 29 14:49:56 2003
|
||||
@@ -7520,6 +7520,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
@@ -7712,7 +7713,7 @@
|
||||
if test "x$COMPILER" = "xforte"; then
|
||||
GST_ERROR=
|
||||
|
42
multimedia/gstreamer80/files/patch-ltmain.sh
Normal file
42
multimedia/gstreamer80/files/patch-ltmain.sh
Normal file
@ -0,0 +1,42 @@
|
||||
--- ltmain.sh.orig Fri Sep 13 15:38:11 2002
|
||||
+++ ltmain.sh Fri Oct 11 01:44:24 2002
|
||||
@@ -1073,8 +1073,16 @@
|
||||
continue
|
||||
;;
|
||||
|
||||
+ -pthread)
|
||||
+ compile_command="$compile_command -pthread"
|
||||
+ finalize_command="$finalize_command -pthread"
|
||||
+ compiler_flags="$compiler_flags -pthread"
|
||||
+ continue
|
||||
+ ;;
|
||||
+
|
||||
-module)
|
||||
module=yes
|
||||
+ build_old_libs=no
|
||||
continue
|
||||
;;
|
||||
|
||||
@@ -2502,6 +2510,9 @@
|
||||
*-*-openbsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test $build_libtool_need_lc = "yes"; then
|
||||
@@ -4286,10 +4297,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -65,12 +65,14 @@ include/gstreamer-%%VERSION%%/gst/gstxml.h
|
||||
include/gstreamer-%%VERSION%%/gst/putbits/putbits.h
|
||||
lib/gstreamer-%%VERSION%%/libgstautoplugcache.so
|
||||
lib/gstreamer-%%VERSION%%/libgstautoplugger.so
|
||||
lib/gstreamer-%%VERSION%%/libgstbasicgthreadscheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstbasicomegascheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstbasicwingoscheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstbytestream.so
|
||||
lib/gstreamer-%%VERSION%%/libgstelements.so
|
||||
lib/gstreamer-%%VERSION%%/libgstgetbits.so
|
||||
lib/gstreamer-%%VERSION%%/libgstindexers.so
|
||||
lib/gstreamer-%%VERSION%%/libgstoptgthreadscheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstoptomegascheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstoptscheduler.so
|
||||
lib/gstreamer-%%VERSION%%/libgstoptwingoscheduler.so
|
||||
@ -87,6 +89,7 @@ lib/libgstreamer-%%VERSION%%.so
|
||||
lib/libgstreamer-%%VERSION%%.so.%%SHLIB_VERSION%%
|
||||
libdata/pkgconfig/gstreamer-%%VERSION%%.pc
|
||||
libdata/pkgconfig/gstreamer-control-%%VERSION%%.pc
|
||||
share/aclocal/gst-element-check-%%VERSION%%.m4
|
||||
@unexec rm %D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
|
||||
@dirrm share/gnome/cache/gstreamer-%%VERSION%%
|
||||
@unexec rmdir %D/share/gnome/cache 2>/dev/null || true
|
||||
|
Loading…
Reference in New Issue
Block a user