Update to 1.1.2. Changes in this release:

* various bugfixes
 * important bugfix for 64-bit platforms
 * various portability fixes
 * autotools cleanup from Thomas Vander Stichele
 * new multiplexed Ogg stream documentation
This commit is contained in:
Christian Weisgerber 2004-10-12 14:54:22 +00:00
parent e7f4e47b2a
commit 8b83a1fcab
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=119041
6 changed files with 36 additions and 73 deletions

View File

@ -6,15 +6,15 @@
#
PORTNAME= libogg
PORTVERSION= 1.1
PORTVERSION= 1.1.2
PORTEPOCH= 3
CATEGORIES= audio
MASTER_SITES= http://www.vorbis.com/files/1.0.1/unix/
MASTER_SITES= http://downloads.xiph.org/releases/ogg/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Ogg bitstream library
USE_INC_LIBTOOL_VER= 13
USE_INC_LIBTOOL_VER= 15
USE_GNOME= gnomehack
INSTALLS_SHLIB= yes

View File

@ -1,2 +1,2 @@
MD5 (libogg-1.1.tar.gz) = 461d7097bf47864b872085a94ff94e10
SIZE (libogg-1.1.tar.gz) = 282691
MD5 (libogg-1.1.2.tar.gz) = 4d82996517bf33bb912c97e9d0b635c4
SIZE (libogg-1.1.2.tar.gz) = 419959

View File

@ -1,12 +1,14 @@
$FreeBSD$
--- Makefile.in.orig Tue Jul 17 02:36:25 2001
+++ Makefile.in Tue Jul 17 02:36:39 2001
@@ -85,7 +85,7 @@ VERSION = @VERSION@
AUTOMAKE_OPTIONS = foreign dist-zip
--- Makefile.in.orig Fri Sep 24 00:44:30 2004
+++ Makefile.in Fri Sep 24 00:44:41 2004
@@ -187,7 +187,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
AUTOMAKE_OPTIONS = foreign 1.6 dist-zip
-SUBDIRS = src include doc win32 debian
+SUBDIRS = src include $(DOC) win32 debian
m4datadir = $(datadir)/aclocal
m4datadir = $(prefix)/share/aclocal
m4data_DATA = ogg.m4
pkgconfigdir = $(prefix)/libdata/pkgconfig

View File

@ -1,12 +1,14 @@
$FreeBSD$
--- doc/Makefile.in.orig Wed Mar 21 16:33:36 2001
+++ doc/Makefile.in Wed Mar 21 16:33:44 2001
@@ -87,7 +87,7 @@ AUTOMAKE_OPTIONS = foreign
--- doc/Makefile.in.orig Fri Sep 24 00:35:47 2004
+++ doc/Makefile.in Fri Sep 24 00:36:02 2004
@@ -169,7 +169,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
SUBDIRS = ogg
-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
+docdir = $(datadir)/doc/$(PACKAGE)
doc_DATA = index.html framing.html oggstream.html white-xifish.png stream.png white-ogg.png
doc_DATA = framing.html index.html oggstream.html rfc3533.txt rfc3534.txt stream.png vorbisword2.png white-ogg.png white-xifish.png
EXTRA_DIST = $(doc_DATA)
all: all-recursive

View File

@ -1,12 +1,14 @@
$FreeBSD$
--- doc/ogg/Makefile.in.orig Wed Mar 21 16:33:54 2001
+++ doc/ogg/Makefile.in Wed Mar 21 16:34:03 2001
@@ -85,7 +85,7 @@ VERSION = @VERSION@
AUTOMAKE_OPTIONS = foreign
--- doc/ogg/Makefile.in.orig Fri Sep 24 00:35:51 2004
+++ doc/ogg/Makefile.in Fri Sep 24 00:36:19 2004
@@ -159,7 +159,7 @@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/ogg
+docdir = $(datadir)/doc/$(PACKAGE)/ogg
doc_DATA = bitpacking.html datastructures.html decoding.html encoding.html general.html index.html ogg_packet.html ogg_page.html ogg_page_bos.html ogg_page_continued.html ogg_page_eos.html ogg_page_granulepos.html ogg_page_pageno.html ogg_page_serialno.html ogg_page_version.html ogg_stream_clear.html ogg_stream_destroy.html ogg_stream_eof.html ogg_stream_eos.html ogg_stream_flush.html ogg_stream_init.html ogg_stream_packetin.html ogg_stream_packetout.html ogg_stream_pagein.html ogg_stream_pageout.html ogg_stream_reset.html ogg_stream_state.html ogg_sync_buffer.html ogg_sync_clear.html ogg_sync_destroy.html ogg_sync_init.html ogg_sync_pageout.html ogg_sync_pageseek.html ogg_sync_reset.html ogg_sync_state.html ogg_sync_wrote.html oggpack_adv.html oggpack_adv1.html oggpack_adv_huff.html oggpack_bits.html oggpack_buffer.html oggpack_bytes.html oggpack_get_buffer.html oggpack_look.html oggpack_look1.html oggpack_look_huff.html oggpack_read.html oggpack_read1.html oggpack_readinit.html oggpack_reset.html oggpack_write.html oggpack_writeclear.html oggpack_writeinit.html overview.html reference.html style.css vorbis_comment.html vorbis_info.html
doc_DATA = bitpacking.html datastructures.html decoding.html encoding.html\
general.html index.html ogg_packet.html ogg_packet_clear.html\
ogg_page.html ogg_page_bos.html ogg_page_checksum_set.html\

View File

@ -1,43 +0,0 @@
$FreeBSD$
--- src/bitwise.c.orig Mon Nov 10 14:06:08 2003
+++ src/bitwise.c Sun Dec 7 02:36:26 2003
@@ -251,7 +251,8 @@
/* Read in bits without advancing the bitptr; bits <= 32 */
long oggpackB_look(oggpack_buffer *b,int bits){
unsigned long ret;
- int m=32-bits;
+ unsigned long m=mask[bits];
+ int s=32-bits;
bits+=b->endbit;
@@ -272,7 +273,7 @@
}
}
}
- return (ret>>(m>>1))>>((m+1)>>1);
+ return ((ret>>(s>>1))>>((s+1)>>1)&m);
}
long oggpack_look1(oggpack_buffer *b){
@@ -347,7 +348,8 @@
/* bits <= 32 */
long oggpackB_read(oggpack_buffer *b,int bits){
unsigned long ret;
- long m=32-bits;
+ unsigned long m=mask[bits];
+ long s=32-bits;
bits+=b->endbit;
@@ -369,7 +371,7 @@
}
}
}
- ret=(ret>>(m>>1))>>((m+1)>>1);
+ ret=((ret>>(s>>1))>>((s+1)>>1)&m);
overflow: