Allow kicad-devel configure to find python 2.7 instead of 2.6

PR:		236335
Submitted by:	george@m5p.com
This commit is contained in:
Michael Reifenberger 2019-03-11 16:08:34 +00:00
parent 18755c8bde
commit 8b717e8366
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=495358

View File

@ -0,0 +1,22 @@
--- CMakeLists.txt.orig 2019-03-11 16:59:38.982264000 +0100
+++ CMakeLists.txt 2019-03-11 17:00:47.354215000 +0100
@@ -668,8 +668,8 @@ if( KICAD_SCRIPTING OR KICAD_SCRIPTING_MODULES )
set( PythonLibs_FIND_VERSION 3.3 )
else()
# force a python version < 3.0
- set( PythonInterp_FIND_VERSION 2.6 )
- set( PythonLibs_FIND_VERSION 2.6 )
+ set( PythonInterp_FIND_VERSION 2.7 )
+ set( PythonLibs_FIND_VERSION 2.7 )
endif()
find_package( PythonInterp )
@@ -711,7 +711,7 @@ if( KICAD_SCRIPTING OR KICAD_SCRIPTING_MODULES )
if( KICAD_SCRIPTING_PYTHON3 )
find_package( PythonLibs 3.3 REQUIRED )
else()
- find_package( PythonLibs 2.6 REQUIRED )
+ find_package( PythonLibs 2.7 REQUIRED )
endif()
if( KICAD_SCRIPTING_WXPYTHON )