Add qdvdauthor, a Qt GUI on top of dvdauthor, a DVD-Video authoring application.

PR:		ports/66515
Submitted by:	Phil Oleson <oz@nixil.net>
This commit is contained in:
Pav Lucistnik 2004-05-13 16:49:52 +00:00
parent 69579148d8
commit 8b6891bb57
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=109074
6 changed files with 58 additions and 0 deletions

View File

@ -101,6 +101,7 @@
SUBDIR += p5-Video-OpenQuicktime
SUBDIR += ppm2fli
SUBDIR += py-gstreamer
SUBDIR += qdvdauthor
SUBDIR += quark
SUBDIR += recmpeg
SUBDIR += replex

View File

@ -0,0 +1,37 @@
# New ports collection makefile for: qdvdauthor
# Date created: 05/07/04
# Whom: oz@nixil.net
#
# $FreeBSD$
#
PORTNAME= qdvdauthor
PORTVERSION= 0.0.6
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= oz@nixil.net
COMMENT= QT graphical frontend for dvdauthor
BUILD_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
mpeg2enc:${PORTSDIR}/multimedia/mjpegtools \
qmake:${PORTSDIR}/devel/qmake
LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick \
xine.9:${PORTSDIR}/multimedia/libxine
RUN_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
mpeg2enc:${PORTSDIR}/multimedia/mjpegtools
HAS_CONFIGURE= yes
USE_X_PREFIX= yes
USE_QT_VER= 3
QT_NONSTANDARD= yes
CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
CONFIGURE_ARGS= --qt-dir=${X11BASE} --with-image-magick-lib --build-qslideshow
NO_BUILD= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/qdvdauthor ${PREFIX}/bin/qdvdauthor
${INSTALL_PROGRAM} ${WRKSRC}/bin/qslideshow ${PREFIX}/bin/qslideshow
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (qdvdauthor-0.0.6.tar.gz) = b0d991e4187f18a17485de65d4ff3bad
SIZE (qdvdauthor-0.0.6.tar.gz) = 590553

View File

@ -0,0 +1,10 @@
--- qdvdauthor/qxine/qxinewidget.h.orig Mon May 10 03:14:10 2004
+++ qdvdauthor/qxine/qxinewidget.h Mon May 10 22:03:01 2004
@@ -31,6 +31,7 @@
#include <qtimer.h>
#include <qevent.h>
#include <qthread.h>
+#include <pthread.h>
#include <xine.h>

View File

@ -0,0 +1,6 @@
qdvdauthor is a graphical frontend to the dvd authoring program dvdauthor
written with the QT toolkit.
The program is alpha quality though still very useful.
WWW: http://qdvdauthor.sourceforge.net/

View File

@ -0,0 +1,2 @@
bin/qdvdauthor
bin/qslideshow