Update to 0.07.07

PR:		214899
Submitted by:	luca.pizzamiglio@gmail.com (maintainer)
Approved by:	jadawin (mentor)
Differential Revision:  https://reviews.freebsd.org/D8661
This commit is contained in:
Olivier Cochard 2016-11-28 12:47:18 +00:00
parent 4718310c22
commit 8ac826dc11
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=427302
5 changed files with 18 additions and 18 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= stress-ng
PORTVERSION= 0.07.02
PORTVERSION= 0.07.07
CATEGORIES= benchmarks
MASTER_SITES= http://kernel.ubuntu.com/~cking/tarballs/stress-ng/
@ -21,7 +21,7 @@ PLIST_FILES= bin/stress-ng man/man1/stress-ng.1.gz
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1000000
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-stress-cpu.c \
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-stress-cpu.h \
${FILESDIR}/extrapatch-Makefile
.endif

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1478684146
SHA256 (stress-ng-0.07.02.tar.gz) = 8b9cf270bd0288e23d93d2b41f76c94f9af989f5fede1432f2b1e49f9eda6f7f
SIZE (stress-ng-0.07.02.tar.gz) = 343763
TIMESTAMP = 1480323994
SHA256 (stress-ng-0.07.07.tar.gz) = 263919f026bd7d864b822d799f66ddd2406ea6e78677edc53226fcb184f674e6
SIZE (stress-ng-0.07.07.tar.gz) = 342120

View File

@ -1,6 +1,6 @@
--- Makefile.orig 2016-02-19 13:41:26.000000000 +0100
+++ Makefile 2016-02-19 16:02:35.583431776 +0100
@@ -307,7 +307,7 @@
--- Makefile.orig 2016-11-28 10:42:07.029535000 +0100
+++ Makefile 2016-11-28 10:42:33.403489000 +0100
@@ -387,7 +387,7 @@
@$(CC) $(CFLAGS) -c -o $@ $<
stress-ng: $(OBJS)

View File

@ -1,10 +0,0 @@
--- stress-cpu.c.orig 2015-09-18 14:50:12 UTC
+++ stress-cpu.c
@@ -23,6 +23,7 @@
*
*/
#define _GNU_SOURCE
+#define _DECLARE_C99_LDBL_MATH 1
#include <stdio.h>
#include <stdlib.h>

View File

@ -0,0 +1,10 @@
--- stress-ng.h.orig 2016-11-28 10:45:15.430051000 +0100
+++ stress-ng.h 2016-11-28 10:45:25.621013000 +0100
@@ -27,6 +27,7 @@
#define __STRESS_NG_H__
#define _GNU_SOURCE
+#define _DECLARE_C99_LDBL_MATH 1
#include <stdarg.h>
#include <stdint.h>