Add a port of Flacon, nice graphical audio file extractor and encoder.

WWW: http://flacon.github.io/
This commit is contained in:
Alexey Dokuchaev 2015-03-31 11:28:21 +00:00
parent 558ee020fc
commit 8a899f3976
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=382805
7 changed files with 92 additions and 1 deletions

View File

@ -49,9 +49,9 @@
SUBDIR += autozen
SUBDIR += baresip
SUBDIR += baudline
SUBDIR += bcg729
SUBDIR += beast
SUBDIR += beets
SUBDIR += bcg729
SUBDIR += blop
SUBDIR += boodler
SUBDIR += bristol
@ -152,6 +152,7 @@
SUBDIR += firefly
SUBDIR += flac
SUBDIR += flac123
SUBDIR += flacon
SUBDIR += flake
SUBDIR += flite
SUBDIR += fluidsynth

23
audio/flacon/Makefile Normal file
View File

@ -0,0 +1,23 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
PORTNAME= flacon
DISTVERSION= 1.0.1
CATEGORIES= audio
MAINTAINER= danfe@FreeBSD.org
COMMENT= Graphical audio file extractor and encoder
LICENSE= LGPL21
LIB_DEPENDS= libuchardet.so:${PORTSDIR}/textproc/uchardet
USE_GITHUB= yes
GH_TAGNAME= v${PORTVERSION}
USES= cmake pkgconfig
USE_QT4= gui network \
linguisttools_build moc_build qmake_build rcc_build uic_build
INSTALLS_ICONS= yes
.include <bsd.port.mk>

2
audio/flacon/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (flacon-flacon-1.0.1-v1.0.1_GH0.tar.gz) = 6a10ddf20d767aeb3ce0d6187f5b85c1a1cf64bfc42a0f827e0d5bd88b78977f
SIZE (flacon-flacon-1.0.1-v1.0.1_GH0.tar.gz) = 245710

View File

@ -0,0 +1,19 @@
--- CMakeLists.txt.orig 2014-08-19 17:05:30 UTC
+++ CMakeLists.txt
@@ -204,6 +204,7 @@ include(translations/translatorsinfo.cma
create_translatorsinfo_qrc(TRANSLATORS_INFO_QRC translations)
set(LIBRARIES ${LIBRARIES} ${UCHARDET_LIBRARIES})
include_directories(${UCHARDET_INCLUDE_DIRS})
+link_directories(${UCHARDET_LIBRARY_DIRS})
add_executable(${PROJECT_NAME} ${HEADERS} ${SOURCES} ${MOC_SOURCES} ${QM_FILES} ${QRC_SOURCES} ${UI_HEADERS} ${ENGINES_CPP} ${ENGINES_H} ${TRANSLATORS_INFO_QRC})
@@ -271,7 +272,7 @@ configure_file(
add_custom_command(TARGET ${PROJECT_NAME}
COMMAND gzip -c ${CMAKE_CURRENT_BINARY_DIR}/flacon.1 > ${CMAKE_CURRENT_BINARY_DIR}/flacon.1.gz
)
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/flacon.1.gz DESTINATION share/man/man1)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/flacon.1.gz DESTINATION man/man1)
# Add make dist target **************************
if(NOT CPACK_PACKAGE_VERSION)

15
audio/flacon/pkg-descr Normal file
View File

@ -0,0 +1,15 @@
Flacon extracts individual tracks from one big audio file containing the
entire album of music and saves them as separate audio files.
To do this, it uses information from the appropriate CUE file. Besides,
Flacon makes it possible to conveniently revise or specify tags both for
all tracks at once or for each tag separately. Its features are:
- Supported input formats: WAV, FLAC, APE, WavPack, True Audio (TTA)
- Supported output formats: FLAC, WAV, WavPack, AAC, OGG, or MP3
- Replay Gain analysis (album-gain and track-gain modes)
- Automatic character set detection for CUE files
- Generation of the per-track CUE file in the output directory
- Multi-threaded conversion process and graphical user interface
WWW: http://flacon.github.io/

8
audio/flacon/pkg-message Normal file
View File

@ -0,0 +1,8 @@
Flacon uses external programs to perform audio conversion. Install
them manually, depending on your needs, from the following ports:
autio/faac audio/flac
audio/lame audio/mac
audio/mp3gain audio/shntool
audio/tta audio/vorbisgain
audio/vorbis-tools audio/wavpack

23
audio/flacon/pkg-plist Normal file
View File

@ -0,0 +1,23 @@
bin/flacon
man/man1/flacon.1.gz
share/applications/flacon.desktop
share/icons/hicolor/16x16/apps/flacon.png
share/icons/hicolor/32x32/apps/flacon.png
share/icons/hicolor/48x48/apps/flacon.png
%%DATADIR%%/translations/flacon_cs.qm
%%DATADIR%%/translations/flacon_cs_CZ.qm
%%DATADIR%%/translations/flacon_de.qm
%%DATADIR%%/translations/flacon_es.qm
%%DATADIR%%/translations/flacon_es_MX.qm
%%DATADIR%%/translations/flacon_fr.qm
%%DATADIR%%/translations/flacon_gl.qm
%%DATADIR%%/translations/flacon_hu.qm
%%DATADIR%%/translations/flacon_it.qm
%%DATADIR%%/translations/flacon_pl.qm
%%DATADIR%%/translations/flacon_pl_PL.qm
%%DATADIR%%/translations/flacon_pt_BR.qm
%%DATADIR%%/translations/flacon_pt_PT.qm
%%DATADIR%%/translations/flacon_ru.qm
%%DATADIR%%/translations/flacon_uk.qm
%%DATADIR%%/translations/flacon_zh_CN.qm
%%DATADIR%%/translations/flacon_zh_TW.qm