mail/ezmlm-idx: 7.1.1 -> 7.2.2
- added mysql build fix PR: 209879 Changes: http://untroubled.org/ezmlm/archive/7.2.2/CHANGES Submitted by: Robert Schulze <rs@bytecamp.net> Reviewed by: Vladimir Krstulja <vlad-fbsd@acheronmedia.com>, pawel
This commit is contained in:
parent
fa075af20d
commit
8a7dee150b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=417979
@ -2,19 +2,14 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ezmlm-idx
|
||||
PORTVERSION= 7.1.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 7.2.2
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.ezmlm.org/archive/${PORTVERSION}/ \
|
||||
http://ezmlm.sericyb.com.au/archive/${PORTVERSION}/
|
||||
MASTER_SITES= http://untroubled.org/ezmlm/archive/${PORTVERSION}/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Improved version of the ezmlm mailing list manager
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
LICENSE= GPLv2
|
||||
LEGAL_TEXT= No license -- see http://cr.yp.to/softwarelaw.html
|
||||
|
||||
USES= qmail:run
|
||||
|
||||
@ -22,6 +17,9 @@ CONFLICTS= ezmlm-0.*
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
LEGAL_TEXT= No license -- see http://cr.yp.to/softwarelaw.html
|
||||
|
||||
OPTIONS_DEFINE= DB DOCS
|
||||
OPTIONS_SINGLE= DB
|
||||
OPTIONS_SINGLE_DB= MYSQL PGSQL SQLITE
|
||||
@ -30,13 +28,12 @@ MYSQL_DESC= Build the MySQL extension
|
||||
PGSQL_DESC= Build the PostgreSQL extension
|
||||
SQLITE_DESC= Build the SQLite3 extension
|
||||
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
ALL_TARGET= it
|
||||
|
||||
.if ${PORT_OPTIONS:MMYSQL}
|
||||
USE_MYSQL= yes
|
||||
USES+= mysql
|
||||
EXTRACT_INCLUDE+= -I${LOCALBASE}/include/mysql
|
||||
EXTRACT_LIB+= -L${LOCALBASE}/lib/mysql -lmysqlclient -lm
|
||||
ALL_TARGET+= mysql
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (ezmlm-idx-7.1.1.tar.gz) = 0d2a9d99fa410cc26c9d00c000ede4977b606ba9fd483c5a7a00b87bf8db2383
|
||||
SIZE (ezmlm-idx-7.1.1.tar.gz) = 718954
|
||||
TIMESTAMP = 1464686562
|
||||
SHA256 (ezmlm-idx-7.2.2.tar.gz) = 5d8840678ad8c2b84350564a065149c055ace3d3e21b169590ebd5abca30c2a8
|
||||
SIZE (ezmlm-idx-7.2.2.tar.gz) = 742451
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- ezmlm-manage.c.orig Wed Jul 31 16:36:20 2002
|
||||
+++ ezmlm-manage.c Wed Jul 31 17:25:37 2002
|
||||
@@ -1015,7 +1015,7 @@
|
||||
strerr_die2x(0,INFO,ERR_UNSUB_NOP);
|
||||
mod_bottom();
|
||||
if (r) { /* success to target */
|
||||
- qmail_to(&qq,target.s);
|
||||
+ if (flagnotify) qmail_to(&qq,target.s);
|
||||
if (flagverbose > 1) to_owner();
|
||||
} else /* NOP to sender = admin. Will take */
|
||||
qmail_to(&qq,sender); /* care of it. No need to tell owner */
|
11
mail/ezmlm-idx/files/patch-sub-mysql.c
Normal file
11
mail/ezmlm-idx/files/patch-sub-mysql.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- sub-mysql.c.orig 2016-07-03 16:26:00 UTC
|
||||
+++ sub-mysql.c
|
||||
@@ -6,7 +6,7 @@
|
||||
#include "subdb.h"
|
||||
#include <sys/types.h>
|
||||
#include <mysql.h>
|
||||
-#include <mysql/errmsg.h>
|
||||
+#include <errmsg.h>
|
||||
#include <mysqld_error.h>
|
||||
|
||||
static stralloc line = {0};
|
@ -17,4 +17,4 @@ ezmlm-idx adds the following features:
|
||||
- SQL support (MySQL or PostgreSQL) for centrally administered
|
||||
distributed lists
|
||||
|
||||
WWW: http://www.ezmlm.org/
|
||||
WWW: http://www.untroubled.org/ezmlm/
|
||||
|
@ -1,5 +1,6 @@
|
||||
bin/ezmlm-accept
|
||||
bin/ezmlm-archive
|
||||
bin/ezmlm-cgi
|
||||
bin/ezmlm-check
|
||||
bin/ezmlm-checksub
|
||||
bin/ezmlm-clean
|
||||
@ -10,6 +11,7 @@ bin/ezmlm-gate
|
||||
bin/ezmlm-get
|
||||
bin/ezmlm-glconf
|
||||
bin/ezmlm-idx
|
||||
bin/ezmlm-import
|
||||
bin/ezmlm-issubn
|
||||
bin/ezmlm-limit
|
||||
bin/ezmlm-list
|
||||
@ -19,6 +21,7 @@ bin/ezmlm-moderate
|
||||
bin/ezmlm-reject
|
||||
bin/ezmlm-request
|
||||
bin/ezmlm-return
|
||||
bin/ezmlm-rmtab
|
||||
bin/ezmlm-send
|
||||
bin/ezmlm-split
|
||||
bin/ezmlm-store
|
||||
@ -600,11 +603,9 @@ etc/ezmlm/sv/text/unsub-confirm
|
||||
etc/ezmlm/sv/text/unsub-nop
|
||||
etc/ezmlm/sv/text/unsub-ok
|
||||
lib/ezmlm/sub-std.so
|
||||
%%MYSQL%%lib/ezmlm/sub-mysql.so
|
||||
%%PGSQL%%lib/ezmlm/sub-pgsql.so
|
||||
%%SQLITE%%lib/ezmlm/sub-sqlite3.so
|
||||
man/man1/ezmlm-accept.1.gz
|
||||
man/man1/ezmlm-archive.1.gz
|
||||
man/man1/ezmlm-cgi.1.gz
|
||||
man/man1/ezmlm-check.1.gz
|
||||
man/man1/ezmlm-checksub.1.gz
|
||||
man/man1/ezmlm-clean.1.gz
|
||||
@ -615,6 +616,7 @@ man/man1/ezmlm-gate.1.gz
|
||||
man/man1/ezmlm-get.1.gz
|
||||
man/man1/ezmlm-glconf.1.gz
|
||||
man/man1/ezmlm-idx.1.gz
|
||||
man/man1/ezmlm-import.1.gz
|
||||
man/man1/ezmlm-issubn.1.gz
|
||||
man/man1/ezmlm-limit.1.gz
|
||||
man/man1/ezmlm-list.1.gz
|
||||
@ -624,6 +626,7 @@ man/man1/ezmlm-moderate.1.gz
|
||||
man/man1/ezmlm-reject.1.gz
|
||||
man/man1/ezmlm-request.1.gz
|
||||
man/man1/ezmlm-return.1.gz
|
||||
man/man1/ezmlm-rmtab.1.gz
|
||||
man/man1/ezmlm-send.1.gz
|
||||
man/man1/ezmlm-split.1.gz
|
||||
man/man1/ezmlm-store.1.gz
|
||||
@ -636,6 +639,8 @@ man/man5/ezmlm.5.gz
|
||||
man/man5/ezmlmglrc.5.gz
|
||||
man/man5/ezmlmrc.5.gz
|
||||
man/man5/ezmlmsubrc.5.gz
|
||||
%%MYSQL%%lib/ezmlm/sub-mysql.so
|
||||
%%PGSQL%%lib/ezmlm/sub-pgsql.so
|
||||
%%PORTDOCS%%%%DOCSDIR%%/BLURB
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
@ -649,3 +654,4 @@ man/man5/ezmlmsubrc.5.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.std
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/UPGRADE
|
||||
%%SQLITE%%lib/ezmlm/sub-sqlite3.so
|
||||
|
Loading…
Reference in New Issue
Block a user