The Pidgin-Rhythmbox plugin will automatically update your Pidgin user info and

status message with the currently playing music in Rhythmbox. If the artist and
title are known, it will also attempt to create a link to the song's lyrics by
using Google's "I'm Feeling Lucky" feature.

Author:	Jon Oberheide
WWW:	http://jon.oberheide.org/projects/pidgin-rhythmbox/

PR:		ports/114117
Submitted by:	Yuri Pankov <yuri at darklight.org.ru>
This commit is contained in:
Martin Wilke 2007-06-30 18:43:42 +00:00
parent 6d17be1237
commit 8a4e0b56f9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=194537
5 changed files with 56 additions and 0 deletions

View File

@ -99,6 +99,7 @@
SUBDIR += pidgin
SUBDIR += pidgin-guifications
SUBDIR += pidgin-hotkeys
SUBDIR += pidgin-rhythmbox
SUBDIR += pork
SUBDIR += py-msnp
SUBDIR += py-pyxmpp

View File

@ -0,0 +1,34 @@
# New ports collection makefile for: pidgin-rhythmbox
# Date created: 2007-06-28
# Whom: Yuri Pankov <yuri@darklight.org.ru>
#
# $FreeBSD$
#
PORTNAME= pidgin-rhythmbox
PORTVERSION= 2.0
CATEGORIES= net-im audio
MASTER_SITES= http://jon.oberheide.org/projects/pidgin-rhythmbox/downloads/
MAINTAINER= yuri@darklight.org.ru
COMMENT= Plugin to update your status with info from Rhythmbox
BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin \
rhythmbox:${PORTSDIR}/audio/rhythmbox
USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
PLIST_FILES= lib/pidgin/pidgin-rhythmbox.la \
lib/pidgin/pidgin-rhythmbox.so
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
-e 's#\([@(]\)PIDGIN_INSTALL\([@)]\)#\1libdir\2/pidgin#' \
-e 's#-g -g3 -O2##'
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (pidgin-rhythmbox-2.0.tar.gz) = d4c7329b6dc8311dfd7d75299537c68e
SHA256 (pidgin-rhythmbox-2.0.tar.gz) = 9fc4b43d8a353e2c4e7e219b34ae5fb23a3a0dd10b10446c4e75acab9bc5d460
SIZE (pidgin-rhythmbox-2.0.tar.gz) = 320758

View File

@ -0,0 +1,11 @@
--- ./src/pidgin-rhythmbox.c.orig 2007-06-28 14:14:13.000000000 +0400
+++ ./src/pidgin-rhythmbox.c 2007-06-28 14:14:22.000000000 +0400
@@ -26,7 +26,7 @@
#include <string.h>
#include <glib.h>
#include <dbus/dbus.h>
-#include <dbus/dbus-glib.h>
+#include <dbus/dbus-glib-lowlevel.h>
#include "gtkplugin.h"
#include "util.h"

View File

@ -0,0 +1,7 @@
The Pidgin-Rhythmbox plugin will automatically update your Pidgin user info and
status message with the currently playing music in Rhythmbox. If the artist and
title are known, it will also attempt to create a link to the song's lyrics by
using Google's "I'm Feeling Lucky" feature.
Author: Jon Oberheide
WWW: http://jon.oberheide.org/projects/pidgin-rhythmbox/