x11-wm/fvwm3: Update to 1.0.5
Also switch from PORTVERSION to preferred DISTVERSION. Changelog: https://github.com/fvwmorg/fvwm3/releases/tag/1.0.5 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36796
This commit is contained in:
parent
713d74907d
commit
89f4f3f810
@ -1,8 +1,7 @@
|
||||
PORTNAME= fvwm3
|
||||
PORTVERSION= 1.0.4
|
||||
PORTREVISION= 8
|
||||
DISTVERSION= 1.0.5
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= https://github.com/fvwmorg/fvwm3/releases/download/${PORTVERSION}/ \
|
||||
MASTER_SITES= https://github.com/fvwmorg/fvwm3/releases/download/${DISTVERSION}/ \
|
||||
http://fvwm.sourceforge.net/generated/icon_download/:icons
|
||||
|
||||
MAINTAINER= zirias@FreeBSD.org
|
||||
@ -24,7 +23,7 @@ CONFLICTS_INSTALL= fvwm
|
||||
CPE_VENDOR= fvwm
|
||||
CPE_PRODUCT= fvwm
|
||||
|
||||
PLIST_SUB= PORTVERSION=${PORTVERSION}
|
||||
PLIST_SUB= DISTVERSION=${DISTVERSION}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= ac_cv_path_PYTHON=${PYTHON_CMD}
|
||||
@ -40,7 +39,6 @@ FRIBIDI_CONFIGURE_ENABLE= bidi
|
||||
GO_DESC= Build and install modules written in Go
|
||||
GO_USES= go:no_targets
|
||||
GO_CONFIGURE_ENABLE= golang
|
||||
GO_MAKE_ARGS= GOBUILD="go build -ldflags=\"-s -w\""
|
||||
|
||||
FVWM_ICONS= fvwm_icons-20070101
|
||||
ICONS_DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${FVWM_ICONS}.tar.bz2:icons
|
||||
@ -88,7 +86,7 @@ post-install-PERL-off:
|
||||
${RM} ${STAGEDIR}${PREFIX}/bin/${script}
|
||||
.endfor
|
||||
.for script in FvwmConsoleC.pl FvwmPerl
|
||||
${RM} ${STAGEDIR}${PREFIX}/libexec/fvwm3/${PORTVERSION}/${script}
|
||||
${RM} ${STAGEDIR}${PREFIX}/libexec/fvwm3/${DISTVERSION}/${script}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,5 +1,5 @@
|
||||
TIMESTAMP = 1632559997
|
||||
SHA256 (fvwm3-1.0.4.tar.gz) = 20877e20ae5ce39266e7d0ea48b013e822d600dd94f5b269955db05a3d50a63b
|
||||
SIZE (fvwm3-1.0.4.tar.gz) = 4691719
|
||||
TIMESTAMP = 1664448220
|
||||
SHA256 (fvwm3-1.0.5.tar.gz) = c41a7eaf1cbdebcbcc7ffc773bb25cc07879fbce3429633dd0584e8ebc8b1014
|
||||
SIZE (fvwm3-1.0.5.tar.gz) = 4538262
|
||||
SHA256 (fvwm_icons-20070101.tar.bz2) = 86b0164430a3087f5cb8d55eb43a8676bbce495814b30c6844eb127f952642ab
|
||||
SIZE (fvwm_icons-20070101.tar.bz2) = 330862
|
||||
|
@ -6,46 +6,13 @@ fix.
|
||||
|
||||
Upstream issue: https://github.com/fvwmorg/fvwm3/issues/659
|
||||
|
||||
--- modules/FvwmIconMan/x.c.orig 2022-07-18 23:18:50 UTC
|
||||
--- modules/FvwmIconMan/x.c.orig 2022-09-21 21:44:02 UTC
|
||||
+++ modules/FvwmIconMan/x.c
|
||||
@@ -742,6 +742,7 @@ void X_init_manager (int man_id)
|
||||
char *scr;
|
||||
@@ -741,6 +741,7 @@ void X_init_manager (int man_id)
|
||||
if (man->geometry_str) {
|
||||
fscreen_scr_arg arg;
|
||||
arg.mouse_ev = NULL;
|
||||
+ arg.name = NULL;
|
||||
|
||||
geometry_mask = FScreenParseGeometryWithScreen(
|
||||
man->geometry_str, &man->geometry.x, &man->geometry.y,
|
||||
--- libs/FScreen.c.orig 2022-07-21 10:39:30 UTC
|
||||
+++ libs/FScreen.c
|
||||
@@ -186,6 +186,11 @@ monitor_resolve_name(const char *scr)
|
||||
{
|
||||
struct monitor *m = NULL;
|
||||
|
||||
+ if (scr == NULL)
|
||||
+ {
|
||||
+ return NULL;
|
||||
+ }
|
||||
+
|
||||
/* Assume the monitor name is a literal RandR name (such as HDMI2) and
|
||||
* look it up regardless.
|
||||
*/
|
||||
@@ -698,11 +703,14 @@ FindScreen(fscreen_scr_arg *arg, fscreen_scr_t screen)
|
||||
m = FindScreenOfXY(arg->xypos.x, arg->xypos.y);
|
||||
break;
|
||||
case FSCREEN_BY_NAME:
|
||||
- if (arg == NULL || arg->name == NULL) {
|
||||
- /* XXX: Work out what to do. */
|
||||
- break;
|
||||
+ if (arg == NULL || arg->name == NULL)
|
||||
+ {
|
||||
+ m = monitor_by_primary();
|
||||
}
|
||||
- m = monitor_resolve_name(arg->name);
|
||||
+ else
|
||||
+ {
|
||||
+ m = monitor_resolve_name(arg->name);
|
||||
+ }
|
||||
break;
|
||||
default:
|
||||
/* XXX: Possible error condition here? */
|
||||
|
@ -8,29 +8,29 @@ bin/fvwm-menu-desktop
|
||||
%%PERL%%bin/fvwm-perllib
|
||||
bin/fvwm-root
|
||||
bin/fvwm3
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmAnimate
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmAuto
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmBacker
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmButtons
|
||||
%%GO%%libexec/fvwm3/%%PORTVERSION%%/FvwmCommandS
|
||||
%%NO_GO%%libexec/fvwm3/%%PORTVERSION%%/FvwmConsole
|
||||
%%NO_GO%%libexec/fvwm3/%%PORTVERSION%%/FvwmConsoleC
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmEvent
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmForm
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmIconMan
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmIdent
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmMFL
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmPager
|
||||
%%PERL%%libexec/fvwm3/%%PORTVERSION%%/FvwmPerl
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmRearrange
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmScript
|
||||
libexec/fvwm3/%%PORTVERSION%%/FvwmTalk
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmAnimate
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmAuto
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmBacker
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmButtons
|
||||
%%GO%%libexec/fvwm3/%%DISTVERSION%%/FvwmCommandS
|
||||
%%NO_GO%%libexec/fvwm3/%%DISTVERSION%%/FvwmConsole
|
||||
%%NO_GO%%libexec/fvwm3/%%DISTVERSION%%/FvwmConsoleC
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmEvent
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmForm
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmIconMan
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmIdent
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmMFL
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmPager
|
||||
%%PERL%%libexec/fvwm3/%%DISTVERSION%%/FvwmPerl
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmRearrange
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmScript
|
||||
libexec/fvwm3/%%DISTVERSION%%/FvwmTalk
|
||||
%%MANPAGES%%man/man1/FvwmAnimate.1.gz
|
||||
%%MANPAGES%%man/man1/FvwmAuto.1.gz
|
||||
%%MANPAGES%%man/man1/FvwmBacker.1.gz
|
||||
%%MANPAGES%%man/man1/FvwmButtons.1.gz
|
||||
%%MANPAGES%%%%GO%%man/man1/FvwmCommand.1.gz
|
||||
%%MANPAGES%%man/man1/FvwmConsole.1.gz
|
||||
%%NO_GO%%%%MANPAGES%%man/man1/FvwmConsole.1.gz
|
||||
%%MANPAGES%%man/man1/FvwmEvent.1.gz
|
||||
%%MANPAGES%%man/man1/FvwmForm.1.gz
|
||||
%%MANPAGES%%man/man1/FvwmIconMan.1.gz
|
||||
@ -49,6 +49,11 @@ libexec/fvwm3/%%PORTVERSION%%/FvwmTalk
|
||||
%%MANPAGES%%man/man1/fvwm-perllib.1.gz
|
||||
%%MANPAGES%%man/man1/fvwm-root.1.gz
|
||||
%%MANPAGES%%man/man1/fvwm3.1.gz
|
||||
%%MANPAGES%%man/man1/fvwm3_manpage_source.1.gz
|
||||
%%MANPAGES%%man/man1/fvwm3all.1.gz
|
||||
%%MANPAGES%%man/man1/fvwm3commands.1.gz
|
||||
%%MANPAGES%%man/man1/fvwm3menus.1.gz
|
||||
%%MANPAGES%%man/man1/fvwm3styles.1.gz
|
||||
%%DATADIR%%/ConfigFvwmBacker
|
||||
%%DATADIR%%/ConfigFvwmButtons
|
||||
%%DATADIR%%/ConfigFvwmDefaults
|
||||
|
Loading…
Reference in New Issue
Block a user