Install the Exim info files with more useful names. Before, the command
``info exim'' would fail to descend into any of the 3 Exim info files from the dir top branch. While we're at it, add a pkg-message that 1) Points to the documentation 2) Explains how to get Exim started
This commit is contained in:
parent
7b414fa433
commit
896d5bff25
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44001
@ -182,5 +182,7 @@ pre-install:
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/exim.sh ${PREFIX}/etc/rc.d
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -57,7 +57,7 @@ This patch makes three changes to the exim_install script:
|
||||
|
||||
# Install info files if the directory is defined and the Texinfo
|
||||
# source documentation is present.
|
||||
@@ -239,19 +234,21 @@
|
||||
@@ -239,23 +234,25 @@
|
||||
echo $com Info installation directory is ${INFO_DIRECTORY}
|
||||
echo $com ""
|
||||
|
||||
@ -67,14 +67,16 @@ This patch makes three changes to the exim_install script:
|
||||
echo ${CP} exim_overview.info ${INFO_DIRECTORY}
|
||||
${real} ${CP} exim_overview.info ${INFO_DIRECTORY}
|
||||
install-info --section="Exim" \
|
||||
--entry "* Overview: (exim_overview). Overview of the Exim system" \
|
||||
- --entry "* Overview: (exim_overview). Overview of the Exim system" \
|
||||
+ --entry "* Exim Overview: (exim_overview). Overview of the Exim system" \
|
||||
${INFO_DIRECTORY}/exim_overview.info ${INFO_DIRECTORY}/dir
|
||||
- makeinfo --no-split --output exim.info ../doc/spec.texinfo
|
||||
+ makeinfo --no-validate --no-split --output exim.info ../doc/spec.texinfo
|
||||
echo ${CP} exim.info ${INFO_DIRECTORY}
|
||||
${real} ${CP} exim.info ${INFO_DIRECTORY}
|
||||
install-info --section="Exim" \
|
||||
--entry "* User guide: (exim). Exim manual" \
|
||||
- --entry "* User guide: (exim). Exim manual" \
|
||||
+ --entry "* Exim Specification: (exim). Exim manual" \
|
||||
${INFO_DIRECTORY}/exim.info ${INFO_DIRECTORY}/dir
|
||||
- makeinfo --no-split --output exim_filter.info ../doc/filter.texinfo
|
||||
+ makeinfo --no-validate --no-split --output exim_filter.info \
|
||||
@ -82,3 +84,8 @@ This patch makes three changes to the exim_install script:
|
||||
echo ${CP} exim_filter.info ${INFO_DIRECTORY}
|
||||
${real} ${CP} exim_filter.info ${INFO_DIRECTORY}
|
||||
install-info --section="Exim" \
|
||||
- --entry "* Filtering: (exim_filter). Filtering mail with Exim" \
|
||||
+ --entry "* Exim Filtering: (exim_filter). Filtering mail with Exim" \
|
||||
${INFO_DIRECTORY}/exim_filter.info ${INFO_DIRECTORY}/dir
|
||||
fi
|
||||
|
||||
|
15
mail/exim-devel/pkg-message
Normal file
15
mail/exim-devel/pkg-message
Normal file
@ -0,0 +1,15 @@
|
||||
The following documentation has been installed:
|
||||
|
||||
info 'Exim Overview' -> Overview of Exim
|
||||
info Exim -> Exim Specification (User Guide)
|
||||
info 'Exim Filtering' -> Exim Filter Specification (for end-users)
|
||||
|
||||
Postscript, PDF, HTML and plain text versions of these documents, as well
|
||||
as a comprehensive FAQ list, are available on the Exim web site:
|
||||
|
||||
http://www.exim.org/
|
||||
|
||||
To activate Exim:
|
||||
|
||||
1) Create exim/configure from exim/configure.sample .
|
||||
2) Use the rc.d/exim/sh script to start the Exim daemon .
|
@ -20,7 +20,7 @@ sbin/exiqsumm
|
||||
@unexec install-info --delete %D/info/exim_overview.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/exim.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/exim_filter.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Overview: (exim_overview). Overview of the Exim system" %D/info/exim_overview.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* User guide: (exim). Exim manual" %D/info/exim.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Filtering: (exim_filter). Filtering mail with Exim" %D/info/exim_filter.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Exim Overview: (exim_overview). Overview of the Exim system" %D/info/exim_overview.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Exim Specification: (exim). Exim manual" %D/info/exim.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Exim Filtering: (exim_filter). Filtering mail with Exim" %D/info/exim_filter.info %D/info/dir
|
||||
@dirrm etc/exim
|
||||
|
@ -182,5 +182,7 @@ pre-install:
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/exim.sh ${PREFIX}/etc/rc.d
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -57,7 +57,7 @@ This patch makes three changes to the exim_install script:
|
||||
|
||||
# Install info files if the directory is defined and the Texinfo
|
||||
# source documentation is present.
|
||||
@@ -239,19 +234,21 @@
|
||||
@@ -239,23 +234,25 @@
|
||||
echo $com Info installation directory is ${INFO_DIRECTORY}
|
||||
echo $com ""
|
||||
|
||||
@ -67,14 +67,16 @@ This patch makes three changes to the exim_install script:
|
||||
echo ${CP} exim_overview.info ${INFO_DIRECTORY}
|
||||
${real} ${CP} exim_overview.info ${INFO_DIRECTORY}
|
||||
install-info --section="Exim" \
|
||||
--entry "* Overview: (exim_overview). Overview of the Exim system" \
|
||||
- --entry "* Overview: (exim_overview). Overview of the Exim system" \
|
||||
+ --entry "* Exim Overview: (exim_overview). Overview of the Exim system" \
|
||||
${INFO_DIRECTORY}/exim_overview.info ${INFO_DIRECTORY}/dir
|
||||
- makeinfo --no-split --output exim.info ../doc/spec.texinfo
|
||||
+ makeinfo --no-validate --no-split --output exim.info ../doc/spec.texinfo
|
||||
echo ${CP} exim.info ${INFO_DIRECTORY}
|
||||
${real} ${CP} exim.info ${INFO_DIRECTORY}
|
||||
install-info --section="Exim" \
|
||||
--entry "* User guide: (exim). Exim manual" \
|
||||
- --entry "* User guide: (exim). Exim manual" \
|
||||
+ --entry "* Exim Specification: (exim). Exim manual" \
|
||||
${INFO_DIRECTORY}/exim.info ${INFO_DIRECTORY}/dir
|
||||
- makeinfo --no-split --output exim_filter.info ../doc/filter.texinfo
|
||||
+ makeinfo --no-validate --no-split --output exim_filter.info \
|
||||
@ -82,3 +84,8 @@ This patch makes three changes to the exim_install script:
|
||||
echo ${CP} exim_filter.info ${INFO_DIRECTORY}
|
||||
${real} ${CP} exim_filter.info ${INFO_DIRECTORY}
|
||||
install-info --section="Exim" \
|
||||
- --entry "* Filtering: (exim_filter). Filtering mail with Exim" \
|
||||
+ --entry "* Exim Filtering: (exim_filter). Filtering mail with Exim" \
|
||||
${INFO_DIRECTORY}/exim_filter.info ${INFO_DIRECTORY}/dir
|
||||
fi
|
||||
|
||||
|
15
mail/exim-old/pkg-message
Normal file
15
mail/exim-old/pkg-message
Normal file
@ -0,0 +1,15 @@
|
||||
The following documentation has been installed:
|
||||
|
||||
info 'Exim Overview' -> Overview of Exim
|
||||
info Exim -> Exim Specification (User Guide)
|
||||
info 'Exim Filtering' -> Exim Filter Specification (for end-users)
|
||||
|
||||
Postscript, PDF, HTML and plain text versions of these documents, as well
|
||||
as a comprehensive FAQ list, are available on the Exim web site:
|
||||
|
||||
http://www.exim.org/
|
||||
|
||||
To activate Exim:
|
||||
|
||||
1) Create exim/configure from exim/configure.sample .
|
||||
2) Use the rc.d/exim/sh script to start the Exim daemon .
|
@ -20,7 +20,7 @@ sbin/exiqsumm
|
||||
@unexec install-info --delete %D/info/exim_overview.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/exim.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/exim_filter.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Overview: (exim_overview). Overview of the Exim system" %D/info/exim_overview.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* User guide: (exim). Exim manual" %D/info/exim.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Filtering: (exim_filter). Filtering mail with Exim" %D/info/exim_filter.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Exim Overview: (exim_overview). Overview of the Exim system" %D/info/exim_overview.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Exim Specification: (exim). Exim manual" %D/info/exim.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Exim Filtering: (exim_filter). Filtering mail with Exim" %D/info/exim_filter.info %D/info/dir
|
||||
@dirrm etc/exim
|
||||
|
@ -182,5 +182,7 @@ pre-install:
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/exim.sh ${PREFIX}/etc/rc.d
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -57,7 +57,7 @@ This patch makes three changes to the exim_install script:
|
||||
|
||||
# Install info files if the directory is defined and the Texinfo
|
||||
# source documentation is present.
|
||||
@@ -239,19 +234,21 @@
|
||||
@@ -239,23 +234,25 @@
|
||||
echo $com Info installation directory is ${INFO_DIRECTORY}
|
||||
echo $com ""
|
||||
|
||||
@ -67,14 +67,16 @@ This patch makes three changes to the exim_install script:
|
||||
echo ${CP} exim_overview.info ${INFO_DIRECTORY}
|
||||
${real} ${CP} exim_overview.info ${INFO_DIRECTORY}
|
||||
install-info --section="Exim" \
|
||||
--entry "* Overview: (exim_overview). Overview of the Exim system" \
|
||||
- --entry "* Overview: (exim_overview). Overview of the Exim system" \
|
||||
+ --entry "* Exim Overview: (exim_overview). Overview of the Exim system" \
|
||||
${INFO_DIRECTORY}/exim_overview.info ${INFO_DIRECTORY}/dir
|
||||
- makeinfo --no-split --output exim.info ../doc/spec.texinfo
|
||||
+ makeinfo --no-validate --no-split --output exim.info ../doc/spec.texinfo
|
||||
echo ${CP} exim.info ${INFO_DIRECTORY}
|
||||
${real} ${CP} exim.info ${INFO_DIRECTORY}
|
||||
install-info --section="Exim" \
|
||||
--entry "* User guide: (exim). Exim manual" \
|
||||
- --entry "* User guide: (exim). Exim manual" \
|
||||
+ --entry "* Exim Specification: (exim). Exim manual" \
|
||||
${INFO_DIRECTORY}/exim.info ${INFO_DIRECTORY}/dir
|
||||
- makeinfo --no-split --output exim_filter.info ../doc/filter.texinfo
|
||||
+ makeinfo --no-validate --no-split --output exim_filter.info \
|
||||
@ -82,3 +84,8 @@ This patch makes three changes to the exim_install script:
|
||||
echo ${CP} exim_filter.info ${INFO_DIRECTORY}
|
||||
${real} ${CP} exim_filter.info ${INFO_DIRECTORY}
|
||||
install-info --section="Exim" \
|
||||
- --entry "* Filtering: (exim_filter). Filtering mail with Exim" \
|
||||
+ --entry "* Exim Filtering: (exim_filter). Filtering mail with Exim" \
|
||||
${INFO_DIRECTORY}/exim_filter.info ${INFO_DIRECTORY}/dir
|
||||
fi
|
||||
|
||||
|
15
mail/exim/pkg-message
Normal file
15
mail/exim/pkg-message
Normal file
@ -0,0 +1,15 @@
|
||||
The following documentation has been installed:
|
||||
|
||||
info 'Exim Overview' -> Overview of Exim
|
||||
info Exim -> Exim Specification (User Guide)
|
||||
info 'Exim Filtering' -> Exim Filter Specification (for end-users)
|
||||
|
||||
Postscript, PDF, HTML and plain text versions of these documents, as well
|
||||
as a comprehensive FAQ list, are available on the Exim web site:
|
||||
|
||||
http://www.exim.org/
|
||||
|
||||
To activate Exim:
|
||||
|
||||
1) Create exim/configure from exim/configure.sample .
|
||||
2) Use the rc.d/exim/sh script to start the Exim daemon .
|
@ -20,7 +20,7 @@ sbin/exiqsumm
|
||||
@unexec install-info --delete %D/info/exim_overview.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/exim.info %D/info/dir
|
||||
@unexec install-info --delete %D/info/exim_filter.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Overview: (exim_overview). Overview of the Exim system" %D/info/exim_overview.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* User guide: (exim). Exim manual" %D/info/exim.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Filtering: (exim_filter). Filtering mail with Exim" %D/info/exim_filter.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Exim Overview: (exim_overview). Overview of the Exim system" %D/info/exim_overview.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Exim Specification: (exim). Exim manual" %D/info/exim.info %D/info/dir
|
||||
@exec install-info --section="Exim" --entry "* Exim Filtering: (exim_filter). Filtering mail with Exim" %D/info/exim_filter.info %D/info/dir
|
||||
@dirrm etc/exim
|
||||
|
Loading…
Reference in New Issue
Block a user