- Update to 0.38.0

PR:		206508
Submitted by:	t@tobik.me (maintainer)
This commit is contained in:
Dmitry Marakasov 2016-01-27 17:00:30 +00:00
parent e4c7de1e31
commit 88fb36cbce
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=407367
21 changed files with 87 additions and 80 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openmw
PORTVERSION= 0.37.0
PORTVERSION= 0.38.0
DISTVERSIONPREFIX= openmw-
CATEGORIES= games

View File

@ -1,2 +1,2 @@
SHA256 (OpenMW-openmw-openmw-0.37.0_GH0.tar.gz) = a2c4dd7926cf156d993e20a3914c1708c9c43d3fb8aae4c17ccf03d50beffc27
SIZE (OpenMW-openmw-openmw-0.37.0_GH0.tar.gz) = 4118094
SHA256 (OpenMW-openmw-openmw-0.38.0_GH0.tar.gz) = c16a44ee9a787dcae61a373625d39733868d213fd6e8ccd86ab9e7ac00ecb85a
SIZE (OpenMW-openmw-openmw-0.38.0_GH0.tar.gz) = 4137263

View File

@ -1,11 +1,11 @@
--- CMakeLists.txt.orig 2015-11-22 18:54:17 UTC
--- CMakeLists.txt.orig 2016-01-12 16:11:28 UTC
+++ CMakeLists.txt
@@ -191,7 +191,7 @@ IF(BOOST_STATIC)
set(Boost_USE_STATIC_LIBS ON)
@@ -224,7 +224,7 @@ if (USE_QT)
set (OSG_QT osgQt)
endif()
-find_package(OpenSceneGraph 3.2.0 REQUIRED osgDB osgViewer osgText osgGA osgAnimation osgParticle osgQt osgUtil osgFX)
-find_package(OpenSceneGraph 3.2.0 REQUIRED osgDB osgViewer osgText osgGA osgAnimation osgParticle ${OSG_QT} osgUtil osgFX)
+find_package(OpenSceneGraph 3.2.0 REQUIRED osgDB osgViewer osgText osgGA osgAnimation osgParticle osgUtil osgFX)
include_directories(${OPENSCENEGRAPH_INCLUDE_DIRS})
if(OSG_STATIC)

View File

@ -1,6 +1,6 @@
--- apps/essimporter/converter.hpp.orig 2015-11-22 18:54:17 UTC
--- apps/essimporter/converter.hpp.orig 2016-01-12 16:11:28 UTC
+++ apps/essimporter/converter.hpp
@@ -118,7 +118,7 @@ public:
@@ -121,7 +121,7 @@ public:
{
mContext->mPlayer.mObject.mCreatureStats.mLevel = npc.mNpdt52.mLevel;
mContext->mPlayerBase = npc;

View File

@ -0,0 +1,21 @@
--- apps/essimporter/convertinventory.cpp.orig 2016-01-12 16:11:28 UTC
+++ apps/essimporter/convertinventory.cpp
@@ -1,6 +1,7 @@
#include "convertinventory.hpp"
#include <components/misc/stringops.hpp>
+#include <cstdlib>
namespace ESSImport
{
@@ -15,8 +16,8 @@ namespace ESSImport
objstate.blank();
objstate.mRef = *it;
objstate.mRef.mRefID = Misc::StringUtils::lowerCase(it->mId);
- objstate.mCount = std::abs(it->mCount); // restocking items have negative count in the savefile
- // openmw handles them differently, so no need to set any flags
+ objstate.mCount = abs(it->mCount); // restocking items have negative count in the savefile
+ // openmw handles them differently, so no need to set any flags
state.mItems.push_back(objstate);
if (it->mRelativeEquipmentSlot != -1)
// Note we should really write the absolute slot here, which we do not know about

View File

@ -1,4 +1,4 @@
--- apps/openmw/crashcatcher.cpp.orig 2015-11-24 02:42:35 UTC
--- apps/openmw/crashcatcher.cpp.orig 2016-01-12 16:11:28 UTC
+++ apps/openmw/crashcatcher.cpp
@@ -24,7 +24,7 @@
#ifndef PR_SET_PTRACER

View File

@ -1,14 +0,0 @@
--- apps/openmw/engine.cpp.orig 2015-11-24 02:42:35 UTC
+++ apps/openmw/engine.cpp
@@ -473,8 +473,9 @@ void OMW::Engine::prepareEngine (Setting
}
// find correct path to the game controller bindings
- const std::string localdefault = mCfgMgr.getLocalPath().string() + "/gamecontrollerdb.cfg";
- const std::string globaldefault = mCfgMgr.getGlobalPath().string() + "/gamecontrollerdb.cfg";
+ const std::string localdefault = mCfgMgr.getLocalPath().string() + "/gamecontrollerdb.txt";
+ const std::string globaldefault = mCfgMgr.getGlobalPath().string() + "/gamecontrollerdb.txt";
+
std::string gameControllerdb;
if (boost::filesystem::exists(localdefault))
gameControllerdb = localdefault;

View File

@ -1,6 +1,21 @@
--- apps/openmw/mwinput/inputmanagerimp.cpp.orig 2015-11-22 18:54:17 UTC
--- apps/openmw/mwinput/inputmanagerimp.cpp.orig 2016-01-12 16:11:28 UTC
+++ apps/openmw/mwinput/inputmanagerimp.cpp
@@ -374,6 +374,8 @@ namespace MWInput
@@ -119,11 +119,12 @@ namespace MWInput
SDL_ControllerDeviceEvent evt;
evt.which = i;
controllerAdded(mFakeDeviceID, evt);
- std::cout << "Detected game controller: " << SDL_GameControllerNameForIndex(i) << std::endl;
+ //Bug in FreeBSD's SDL? SDL_GameControllerNameForIndex returns NULL
+ std::cout << "Detected game controller" << std::endl;
}
else
{
- std::cout << "Detected unusable controller: " << SDL_JoystickNameForIndex(i) << std::endl;
+ //std::cout << "Detected unusable controller: " << SDL_JoystickNameForIndex(i) << std::endl;
}
}
@@ -389,6 +390,8 @@ namespace MWInput
{
float xAxis = mInputBinder->getChannel(A_MoveLeftRight)->getValue()*2.0f-1.0f;
float yAxis = mInputBinder->getChannel(A_MoveForwardBackward)->getValue()*2.0f-1.0f;
@ -9,7 +24,7 @@
float zAxis = mInputBinder->getChannel(A_LookUpDown)->getValue()*2.0f-1.0f;
const MyGUI::IntSize& viewSize = MyGUI::RenderManager::getInstance().getViewSize();
@@ -441,13 +443,13 @@ namespace MWInput
@@ -456,13 +459,13 @@ namespace MWInput
{
triedToMove = true;
mPlayer->setAutoMove (false);

View File

@ -1,8 +1,8 @@
--- apps/openmw/mwmechanics/spells.cpp.orig 2015-11-24 02:42:35 UTC
--- apps/openmw/mwmechanics/spells.cpp.orig 2016-01-19 22:26:03 UTC
+++ apps/openmw/mwmechanics/spells.cpp
@@ -29,7 +29,7 @@ namespace MWMechanics
@@ -44,7 +44,7 @@ namespace MWMechanics
{
if (mSpells.find (spell->mId)==mSpells.end())
if (mSpells.find (spell)==mSpells.end())
{
- std::map<const int, float> random;
+ std::map<int, float> random;

View File

@ -1,11 +1,11 @@
--- apps/openmw/mwmechanics/spells.hpp.orig 2015-11-24 02:42:35 UTC
--- apps/openmw/mwmechanics/spells.hpp.orig 2016-01-19 22:25:34 UTC
+++ apps/openmw/mwmechanics/spells.hpp
@@ -31,7 +31,7 @@ namespace MWMechanics
{
public:
@@ -33,7 +33,7 @@ namespace MWMechanics
- typedef std::map<std::string, std::map<const int, float> > TContainer; // ID, <effect index, normalised random magnitude>
+ typedef std::map<std::string, std::map<int, float> > TContainer; // ID, <effect index, normalised random magnitude>
typedef const ESM::Spell* SpellKey;
- typedef std::map<SpellKey, std::map<const int, float> > TContainer; // ID, <effect index, normalised random magnitude>
+ typedef std::map<SpellKey, std::map<int, float> > TContainer; // ID, <effect index, normalised random magnitude>
typedef TContainer::const_iterator TIterator;
struct CorprusStats

View File

@ -0,0 +1,10 @@
--- apps/openmw/mwworld/projectilemanager.hpp.orig 2016-01-12 16:11:28 UTC
+++ apps/openmw/mwworld/projectilemanager.hpp
@@ -3,6 +3,7 @@
#include <string>
+#include <osg/observer_ptr>
#include <osg/ref_ptr>
#include <osg/PositionAttitudeTransform>

View File

@ -1,4 +1,4 @@
--- apps/openmw/mwworld/refdata.hpp.orig 2015-11-22 18:54:17 UTC
--- apps/openmw/mwworld/refdata.hpp.orig 2016-01-12 16:11:28 UTC
+++ apps/openmw/mwworld/refdata.hpp
@@ -5,6 +5,7 @@
@ -7,4 +7,4 @@
+#include <string>
#include <osg/Vec3f>
namespace osg
namespace SceneUtil

View File

@ -1,21 +0,0 @@
--- apps/openmw/mwworld/weather.cpp.orig 2015-11-22 18:54:17 UTC
+++ apps/openmw/mwworld/weather.cpp
@@ -95,9 +95,10 @@ T TimeOfDayInterpolator<T>::getValue(con
}
-
-template class TimeOfDayInterpolator<float>;
-template class TimeOfDayInterpolator<osg::Vec4f>;
+namespace MWWorld {
+ template class TimeOfDayInterpolator<float>;
+ template class TimeOfDayInterpolator<osg::Vec4f>;
+};
Weather::Weather(const std::string& name,
const MWWorld::Fallback& fallback,
@@ -1133,4 +1134,3 @@ inline void WeatherManager::calculateTra
mResult.mAmbientLoopSoundID = other.mAmbientLoopSoundID;
}
}
-

View File

@ -1,4 +1,4 @@
--- apps/openmw/mwworld/worldimp.cpp.orig 2015-11-22 18:54:17 UTC
--- apps/openmw/mwworld/worldimp.cpp.orig 2016-01-12 16:11:28 UTC
+++ apps/openmw/mwworld/worldimp.cpp
@@ -108,7 +108,7 @@ namespace MWWorld
}

View File

@ -1,4 +1,4 @@
--- apps/wizard/CMakeLists.txt.orig 2015-11-24 02:42:35 UTC
--- apps/wizard/CMakeLists.txt.orig 2016-01-12 16:11:28 UTC
+++ apps/wizard/CMakeLists.txt
@@ -150,6 +150,7 @@ endif()

View File

@ -1,4 +1,4 @@
--- components/esm/spellstate.cpp.orig 2015-11-24 02:42:35 UTC
--- components/esm/spellstate.cpp.orig 2016-01-12 16:11:28 UTC
+++ components/esm/spellstate.cpp
@@ -12,7 +12,7 @@ namespace ESM
{

View File

@ -1,4 +1,4 @@
--- components/esm/spellstate.hpp.orig 2015-11-24 02:42:35 UTC
--- components/esm/spellstate.hpp.orig 2016-01-12 16:11:28 UTC
+++ components/esm/spellstate.hpp
@@ -28,7 +28,7 @@ namespace ESM
float mMagnitude;

View File

@ -1,14 +0,0 @@
--- components/files/configurationmanager.hpp.orig 2015-11-24 02:42:35 UTC
+++ components/files/configurationmanager.hpp
@@ -52,11 +52,7 @@ struct ConfigurationManager
typedef Files::FixedPath<> FixedPathType;
typedef const boost::filesystem::path& (FixedPathType::*path_type_f)() const;
- #if defined HAVE_UNORDERED_MAP
typedef std::unordered_map<std::string, path_type_f> TokensMappingContainer;
- #else
- typedef std::tr1::unordered_map<std::string, path_type_f> TokensMappingContainer;
- #endif
void loadConfig(const boost::filesystem::path& path,
boost::program_options::variables_map& variables,

View File

@ -0,0 +1,10 @@
--- components/resource/bulletshape.cpp.orig 2016-01-12 16:11:28 UTC
+++ components/resource/bulletshape.cpp
@@ -1,6 +1,7 @@
#include "bulletshape.hpp"
#include <stdexcept>
+#include <string>
#include <BulletCollision/CollisionShapes/btBoxShape.h>
#include <BulletCollision/CollisionShapes/btTriangleMesh.h>

View File

@ -1,4 +1,4 @@
--- components/sceneutil/lightcontroller.cpp.orig 2015-11-24 02:42:35 UTC
--- components/sceneutil/lightcontroller.cpp.orig 2016-01-12 16:11:28 UTC
+++ components/sceneutil/lightcontroller.cpp
@@ -2,6 +2,7 @@

View File

@ -1,4 +1,4 @@
--- files/gamecontrollerdb.txt.orig 2015-11-24 02:42:35 UTC
--- files/gamecontrollerdb.txt.orig 2016-01-12 16:11:28 UTC
+++ files/gamecontrollerdb.txt
@@ -99,3 +99,7 @@ ff113133000000000000504944564944,SVEN X-
05000000362800000100000002010000,OUYA Game Controller,a:b0,b:b3,dpdown:b9,dpleft:b10,dpright:b11,dpup:b8,guide:b14,leftshoulder:b4,leftstick:b6,lefttrigger:a2,leftx:a0,lefty:a1,platform:Linux,rightshoulder:b5,rightstick:b7,righttrigger:a5,rightx:a3,righty:a4,x:b1,y:b2,