MFH: r522753 devel/py-generate: Fix MASTER_SITES, Remove BROKEN [1]

While I'm here, address other ports bugs/issues [2]:

  - gmake is not required (build uses distutils/setuptools:Extension)
  - patch setup.py:version (was 2.2) to match PORTVERSION (2.8)
  - Remove unecessary DISTNAME override
  - Strip installed extension/library
  - Correctly declare USES=python:<version-spec>, limited to 2.7. Fails to
    import on Python 3:

      ImportError: ... /site-packages/generate.so: Undefined symbol "PyString_FromString

PR:		241966
Submitted by:	D'Arcy J.M. Cain <darcy druid net> [1]
Approved by:	portmgr (blanket(s): ports compliance, dependencies) [2]

Approved by:	ports-secteam ((blanket(s): build (fetch) fix, ports compliance) [1][2]
This commit is contained in:
Kubilay Kocak 2020-01-12 05:35:01 +00:00
parent 310cd5cd03
commit 88f033168f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q1/; revision=522754
3 changed files with 23 additions and 9 deletions

View File

@ -2,19 +2,18 @@
# $FreeBSD$
PORTNAME= generate
PORTVERSION= 2.6
PORTREVISION= 1
PORTVERSION= 2.8
CATEGORIES= devel python
MASTER_SITES= ftp://ftp.druid.net/pub/distrib/
MASTER_SITES= http://druid.net/darcy/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= generate-${PORTVERSION}
MAINTAINER= darcy@druid.net
COMMENT= Python module to implement generate
BROKEN= unfetchable
USES= gmake python tar:tgz
USES= python:2.7 tar:tgz
USE_PYTHON= distutils autoplist
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/generate.so
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (generate-2.6.tgz) = 609e166f66b4bb3028fb9e5486ffddff98fc7bf4f354659516c2b86a800948bd
SIZE (generate-2.6.tgz) = 29045
TIMESTAMP = 1578800105
SHA256 (generate-2.8.tgz) = 35b56d1f11fb834c0cbeca3c41c1dceee8b18d40933e0c680519daf24e9c2dd9
SIZE (generate-2.8.tgz) = 31590

View File

@ -0,0 +1,14 @@
# Correct version <> PORTVERSION
# TODO: Upstream
--- setup.py.orig 2020-01-12 03:43:46 UTC
+++ setup.py
@@ -4,7 +4,7 @@
from distutils.core import setup, Extension
setup(name="generate",
- version="2.2",
+ version="2.8",
description="Text pre-processor",
author="D'Arcy J.M. Cain",
author_email="darcy@druid.net",