- Update to 20110810

- Use PORTDATA

PR:		ports/159644
Submitted by:	Tomokatsu SAITO <saito@asir.org> (maintainer)
This commit is contained in:
Chris Rees 2011-11-03 21:12:13 +00:00
parent 1062fe66e3
commit 88e1864e50
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=285002
17 changed files with 47 additions and 1169 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= asir
PORTVERSION= 20070806
PORTREVISION= 5
PORTVERSION= 20110810
CATEGORIES= math
MASTER_SITES= ftp://ftp.jssac.org/pub/distfiles/asir/ \
ftp://ftp.asir.org/pub/asir/src/ \
@ -18,20 +17,18 @@ EXTRACT_ONLY= ${ASIR_SRC}
MAINTAINER= saito@asir.org
COMMENT= The system Risa/Asir is a general computer algebra system
BROKEN= Only builds with now-nonexistant automake15
LIB_DEPENDS= pari-gmp.2:${PORTSDIR}/math/pari
USE_XORG= x11 xaw xext xt
GNU_CONFIGURE= yes
#XXX USE_AUTOTOOLS= automake autoconf
CONFIGURE_ARGS= --enable-shared --enable-plot --enable-fep --enable-interval --with-pari
USE_AUTOTOOLS= aclocal automake autoconf
CONFIGURE_ARGS= --enable-shared --enable-plot --enable-fep --enable-interval --with-pari --with-gc7
ASIR_SRC_VERSION= ${PORTVERSION}
ASIR_DOC_VERSION= 20070718
GC_VERSION= 6.8
ASIR_DOC_VERSION= 20110808
GC_VERSION= 7.1
ASIR_SRC= asir-${ASIR_SRC_VERSION}${EXTRACT_SUFX}
ASIR_DOC= asirdoc-${ASIR_DOC_VERSION}${EXTRACT_SUFX}
GC_SRC= gc${GC_VERSION}${EXTRACT_SUFX}
GC_SRC= gc-${GC_VERSION}${EXTRACT_SUFX}
MAN1= asir.1
WRKSRC= ${WRKDIR}/asir2000
@ -41,6 +38,7 @@ LIB_DATA= alpi bfct bgk const cyclic defs.h dfff dmul dmul102 \
sturm sym weight xm
PORTDOCS= *
PORTDATA= *
.include <bsd.port.pre.mk>
@ -65,6 +63,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/asir ${DATADIR}/ox_asir
@${LN} -fs ${PREFIX}/bin/asir ${DATADIR}/ox_plot
@${LN} -fs ${PREFIX}/bin/asir ${DATADIR}/ox_launch
@${LN} -fs ${DATADIR} ${PREFIX}/lib/asir
@${INSTALL_MAN} ${WRKDIR}/asirdoc/${MAN1} ${MAN1PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}

View File

@ -1,6 +1,6 @@
SHA256 (asir-20070806.tar.gz) = 3eabdc3ec46b43a32112ebfc7a3b8aedb57add718caddf60bb4d8eca54c2af60
SIZE (asir-20070806.tar.gz) = 2488044
SHA256 (asirdoc-20070718.tar.gz) = 0c8e2714129bb6c0eb9170822b688d2d93f7f9ce67683813ee473ff3b3779fbb
SIZE (asirdoc-20070718.tar.gz) = 1396218
SHA256 (gc6.8.tar.gz) = 448f8e4c6ee8c80eac059cf1c9379d20c388bcb900fc0796cd2a44d1dcbbae69
SIZE (gc6.8.tar.gz) = 756879
SHA256 (asir-20110810.tar.gz) = 878863d33ebee13123bab7619b02459a8f769aef0803ea73a0d68e9d3a9829a4
SIZE (asir-20110810.tar.gz) = 2039536
SHA256 (asirdoc-20110808.tar.gz) = c374deaf267a658416d32e79b7e0474ef784e403855c1e0248b117fc6bfebab1
SIZE (asirdoc-20110808.tar.gz) = 1360135
SHA256 (gc-7.1.tar.gz) = e3cef6028fe3efe7de3bcf4107c880eae50b3ee79841450d885467c09bcebf30
SIZE (gc-7.1.tar.gz) = 1077714

View File

@ -1,8 +1,8 @@
--- include/version.h.orig Mon Aug 6 17:15:26 2007
+++ include/version.h Tue Aug 14 02:56:32 2007
--- include/version.h.orig 2011-08-08 14:41:05.000000000 +0900
+++ include/version.h 2011-08-08 14:41:28.000000000 +0900
@@ -48,4 +48,4 @@
* $OpenXM: OpenXM_contrib2/asir2000/include/version.h,v 1.282 2007/08/06 08:15:26 saito Exp $
* $OpenXM: OpenXM_contrib2/asir2000/include/version.h,v 1.331 2011/07/21 04:43:26 noro Exp $
*/
#define ASIR_VERSION 20070806
#define ASIR_VERSION 20110721
-#define ASIR_DISTRIBUTION "Kobe"
+#define ASIR_DISTRIBUTION "Plotting Group"

View File

@ -1,42 +0,0 @@
--- parse/glob.c.orig Thu Jan 4 00:48:08 2007
+++ parse/glob.c Wed Jul 18 12:25:46 2007
@@ -51,10 +51,11 @@
#include "al.h"
#include "parse.h"
#include "ox.h"
+#include "version.h"
#if defined(PARI)
#include "genpari.h"
#endif
-#if !defined(VISUAL) && !defined(_PA_RISC1_1) && !defined(linux) && !defined(SYSV) && !defined(__CYGWIN__) && !defined(__INTERIX)
+#if !defined(VISUAL) && !defined(_PA_RISC1_1) && !defined(linux) && !defined(SYSV) && !defined(__CYGWIN__) && !defined(__INTERIX) && !defined(__FreeBSD__)
#include <sgtty.h>
#endif
@@ -765,7 +766,7 @@
char *get_pariversion()
{
#if PARI
-#if 0
+#if 1
return PARIVERSION", Copyright (C) 2000-2005 The PARI Group.\n";
#else
return "PARI 2.0.17, copyright 1989-1999, C. Batut, K. Belabas, D. Bernardi,\n H. Cohen and M. Olivier.\n";
@@ -785,7 +786,7 @@
void copyright()
{
- char *format = "This is Risa/Asir%s, Version %d (%s Distribution).\nCopyright (C) 1994-2000, all rights reserved, FUJITSU LABORATORIES LIMITED.\nCopyright 2000-2007, Risa/Asir committers, http://www.openxm.org/.\nGC 6.5 Copyright 1988-2005, H-J. Boehm, A. J. Demers, Xerox, SGI, HP.\n%s";
+ char *format = "This is Risa/Asir%s, Version %d (%s Distribution).\nCopyright (C) 1994-2000, all rights reserved, FUJITSU LABORATORIES LIMITED.\nCopyright 2000-2007, Risa/Asir committers, http://www.openxm.org/.\nGC 6.8 Copyright 1988-2005, H-J. Boehm, A. J. Demers, Xerox, SGI, HP.\n%s";
printf(format, get_intervalversion(), get_asir_version(), get_asir_distribution(), get_pariversion());
}
@@ -794,7 +795,7 @@
static char *notice;
char *s1, *s2, *s3;
int d, len;
- char *format = "This is Risa/Asir%s, Version %d (%s Distribution).\nCopyright (C) 1994-2000, all rights reserved, FUJITSU LABORATORIES LIMITED.\nCopyright 2000-2007, Risa/Asir committers, http://www.openxm.org/.\nGC 6.5 copyright 1988-2005, H-J. Boehm, A. J. Demers, Xerox, SGI, HP.\n%s";
+ char *format = "This is Risa/Asir%s, Version %d (%s Distribution).\nCopyright (C) 1994-2000, all rights reserved, FUJITSU LABORATORIES LIMITED.\nCopyright 2000-2007, Risa/Asir committers, http://www.openxm.org/.\nGC 6.8 copyright 1988-2005, H-J. Boehm, A. J. Demers, Xerox, SGI, HP.\n%s";
if (!notice) {
s1 = get_intervalversion();
s2 = get_asir_distribution();

View File

@ -1,5 +1,5 @@
--- Makefile.am.orig Mon Aug 6 16:59:49 2007
+++ Makefile.am Mon Aug 6 17:07:45 2007
--- Makefile.am.orig 2009-03-04 18:15:36.000000000 +0900
+++ Makefile.am 2011-08-08 15:35:03.000000000 +0900
@@ -9,7 +9,8 @@
SUBDIRS = asm builtin engine fft include io lib parse ${PLOTDIR}
@ -9,17 +9,8 @@
+asirdir = ${bindir}
asir_PROGRAMS = asir
asir_SOURCES = parse/main.c
asir_LDADD = libasir.a libasir-gc.a
@@ -17,7 +18,7 @@
GC = gc6.8
GC_TAR_GZ = ${GC}.tar.gz
-GC_PATCH = gc6.5-risa.diff
+GC_PATCH = gc6.8-risa.diff
GC_DISTDIR = @GC_DISTDIR@
GC_MASTER_SITE=ftp://ftp.math.kobe-u.ac.jp/pub/OpenXM/misc/
OX_FETCH = ${bindir}/oxfetch.sh
@@ -104,33 +105,33 @@
asir_LDADD = libasir.a @ASIR_GCLIB@
@@ -90,33 +91,34 @@
${INSTALL_DATA} libasir-gc.a ${DESTDIR}${libdir}/libasir-gc.a
install-openxm: asir${EXEEXT} install-libasir install-libasir-gc
@ -38,6 +29,7 @@
- ${LN_S} asir${EXEEXT} ox_plot${EXEEXT})
- (cd ${top_srcdir}/include; ${MAKE} install)
- (cd ${top_srcdir}/parse; ${MAKE} install)
+ ${INSTALL_PROGRAM} ${asir_PROGRAMS} /usr/local/bin
+# -mkdir -p ${DESTDIR}${bindir}
+# ${INSTALL_PROGRAM} asir /usr/local/bin
+# -mkdir -p ${DESTDIR}${asirdir}

View File

@ -1,7 +1,7 @@
--- asm/Makefile.am.orig Fri May 2 02:18:28 2003
+++ asm/Makefile.am Fri May 2 02:18:50 2003
--- asm/Makefile.am.orig 2009-02-13 22:21:19.000000000 +0900
+++ asm/Makefile.am 2011-08-08 14:23:31.000000000 +0900
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/asm/Makefile.am,v 1.3 2003/03/20 07:34:08 ohara Exp $
## $OpenXM: OpenXM_contrib2/asir2000/asm/Makefile.am,v 1.4 2009/02/13 13:21:19 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir

View File

@ -1,7 +1,7 @@
--- builtin/Makefile.am.orig Mon Dec 20 16:12:28 2004
+++ builtin/Makefile.am Mon Dec 20 16:12:46 2004
--- builtin/Makefile.am.orig 2011-08-08 14:24:27.000000000 +0900
+++ builtin/Makefile.am 2011-08-08 14:24:41.000000000 +0900
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/builtin/Makefile.am,v 1.8 2004/12/19 17:06:23 ohara Exp $
## $OpenXM: OpenXM_contrib2/asir2000/builtin/Makefile.am,v 1.9 2009/02/13 13:21:19 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir

View File

@ -1,7 +1,7 @@
--- engine/Makefile.am.orig Fri May 2 02:20:57 2003
+++ engine/Makefile.am Fri May 2 02:21:10 2003
--- engine/Makefile.am.orig 2011-08-08 14:25:27.000000000 +0900
+++ engine/Makefile.am 2011-08-08 14:25:38.000000000 +0900
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/engine/Makefile.am,v 1.3 2003/03/20 07:34:09 ohara Exp $
## $OpenXM: OpenXM_contrib2/asir2000/engine/Makefile.am,v 1.9 2009/02/13 13:21:19 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir

View File

@ -1,7 +1,7 @@
--- fft/Makefile.am.orig Fri May 2 02:22:14 2003
+++ fft/Makefile.am Fri May 2 02:22:25 2003
--- fft/Makefile.am.orig 2011-08-08 14:26:18.000000000 +0900
+++ fft/Makefile.am 2011-08-08 14:26:27.000000000 +0900
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/fft/Makefile.am,v 1.3 2003/03/20 07:34:10 ohara Exp $
## $OpenXM: OpenXM_contrib2/asir2000/fft/Makefile.am,v 1.4 2009/02/13 13:21:19 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir

View File

@ -1,7 +1,7 @@
--- io/Makefile.am.orig Fri May 2 02:23:04 2003
+++ io/Makefile.am Fri May 2 02:23:28 2003
--- io/Makefile.am.orig 2011-08-08 14:26:59.000000000 +0900
+++ io/Makefile.am 2011-08-08 14:27:11.000000000 +0900
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/io/Makefile.am,v 1.3 2003/03/20 07:34:11 ohara Exp $
## $OpenXM: OpenXM_contrib2/asir2000/io/Makefile.am,v 1.4 2009/02/13 13:21:20 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir

View File

@ -1,11 +0,0 @@
--- parse/Makefile.am.orig Sun Feb 18 17:46:47 2007
+++ parse/Makefile.am Wed Jul 18 11:39:43 2007
@@ -4,7 +4,7 @@
inc_HEADERS = comp.h cpp.h parse.h w_stdio.h
GC = gc6.8
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir
DEFS = @DEFS@ -DASIR_LIBDIR=\"${asirdir}\"
INCLUDES = -I${top_srcdir}/include -I${top_srcdir}/parse -I${top_srcdir}/io \
-I${top_srcdir}/${GC}/include \

View File

@ -1,7 +1,7 @@
--- plot/Makefile.am.orig Fri May 2 02:24:53 2003
+++ plot/Makefile.am Fri May 2 02:25:03 2003
--- plot/Makefile.am.orig 2009-02-13 22:21:20.000000000 +0900
+++ plot/Makefile.am 2011-08-08 14:21:28.000000000 +0900
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/plot/Makefile.am,v 1.3 2003/03/20 07:34:13 ohara Exp $
## $OpenXM: OpenXM_contrib2/asir2000/plot/Makefile.am,v 1.4 2009/02/13 13:21:20 ohara Exp $
-asirdir = ${prefix}/lib/asir
+asirdir = ${prefix}/share/asir

View File

@ -1,11 +0,0 @@
--- configure.in.orig Fri May 2 02:12:44 2003
+++ configure.in Fri May 2 02:15:11 2003
@@ -2,7 +2,7 @@
AC_INIT([LICENSE])
AC_PREREQ(2.53)
-AM_INIT_AUTOMAKE(asir, 20030307)
+AM_INIT_AUTOMAKE(asir, 20030825)
AM_MAINTAINER_MODE
AC_CANONICAL_SYSTEM

View File

@ -1,7 +1,7 @@
--- lib/Makefile.am.orig Fri May 2 02:30:42 2003
+++ lib/Makefile.am Tue Jan 27 14:57:47 2004
--- lib/Makefile.am.orig 2011-08-08 14:38:10.000000000 +0900
+++ lib/Makefile.am 2011-08-08 14:38:35.000000000 +0900
@@ -1,6 +1,6 @@
## $OpenXM: OpenXM_contrib2/asir2000/lib/Makefile.am,v 1.10 2003/12/12 08:03:12 noro Exp $
## $OpenXM: OpenXM_contrib2/asir2000/lib/Makefile.am,v 1.12 2009/02/22 16:51:36 ohara Exp $
-asirdir = ${libdir}/asir
+asirdir = ${datadir}/asir

View File

@ -1,20 +0,0 @@
--- builtin/parif.c.orig Sat Feb 15 07:29:07 2003
+++ builtin/parif.c Fri Jan 7 01:38:45 2005
@@ -95,7 +95,7 @@
{ GEN _pt1_,_pt2_,_pt3_; CALLPARI2(pf,ARG0(ar),ARG1(ar),MKPREC(ar,3,ARG2(ar)),rp); }
#if defined(INTERVAL)
-#define PREC_CONV pariK1
+#define PREC_CONV (0.103810253/(BYTES_IN_LONG/4)) /* log(10)/(SL*log(2)) */
#else
#if defined(LONG_IS_32BIT)
#define PREC_CONV 0.103810253
@@ -243,7 +243,7 @@
GEN p1,p2,p3;
ritopa_i(a,1,&p1); ritopa_i(b,1,&p2);
- p3 = mppgcd(p1,p2);
+ p3 = gcdii(p1,p2);
patori_i(p3,r); asir_cgiv(p3); asir_cgiv(p2); asir_cgiv(p1);
}

View File

@ -1,9 +0,0 @@
--- include/ca.h.orig Tue Aug 2 16:16:42 2005
+++ include/ca.h Fri Nov 10 01:35:17 2006
@@ -2607,3 +2607,6 @@
void bcopy(const void *,void *,int);
char *index(char *,int);
#endif
+
+/* pari-2.2.16-beta change rename 'prec' -> 'precreal' [ from paripriv.h ] */
+#define prec precreal

File diff suppressed because it is too large Load Diff