MFH: r468566 r469635

lang/python27: Fix build with LibreSSL 2.7

PR:		226883
Submitted by:	Charlie Li <ml+freebsd vishwin info>
Approved by:	python (koobs)
Differential Revision:	https://reviews.freebsd.org/D14837

- Update to 2.7.15(include security fix)

PR:		228028
Submitted by:	wen@(myself)
Exp-run by:	antoine@
This commit is contained in:
Mark Felder 2018-05-25 17:46:41 +00:00
parent 2485e68d8e
commit 88bb20582e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q2/; revision=470858
6 changed files with 16 additions and 145 deletions

View File

@ -1,12 +1,12 @@
TIMESTAMP = 1522419984
SHA256 (python/python-2.7.14-docs-html.tar.bz2) = 624ef76fd4c94631f2c5ebf890dd44930f2fbcae4176c4879f457d5abfe3d483
SIZE (python/python-2.7.14-docs-html.tar.bz2) = 4604956
SHA256 (python/python-2.7.14-docs-pdf-a4.tar.bz2) = fa4f4a437242e479cc210fd74a9e9f7a28a4420e1d8267f108a8b20198bb14db
SIZE (python/python-2.7.14-docs-pdf-a4.tar.bz2) = 10810797
SHA256 (python/python-2.7.14-docs-pdf-letter.tar.bz2) = 9e7c4db5a9c35a8b9c67b5d5c83fe41382e6e87a0cbc7ed0e1bc5fcd5e3834d9
SIZE (python/python-2.7.14-docs-pdf-letter.tar.bz2) = 10809931
SHA256 (python/python-2.7.14-docs-text.tar.bz2) = dec89643056f682f27c0f0af2b42e5eb9977ef04d9d91bc20eb229219dbcdf1b
SIZE (python/python-2.7.14-docs-text.tar.bz2) = 1614171
TIMESTAMP = 1525595232
SHA256 (python/python-2.7.15-docs-html.tar.bz2) = 5582aa8f59c2d5457ae87e266000f9ef75ed041a02fa72bd988a5169aae8ebde
SIZE (python/python-2.7.15-docs-html.tar.bz2) = 4627519
SHA256 (python/python-2.7.15-docs-pdf-a4.tar.bz2) = f747ca034cae426876017c37dfac0648ae535ad0b95d1e3a27385feee602d956
SIZE (python/python-2.7.15-docs-pdf-a4.tar.bz2) = 9429818
SHA256 (python/python-2.7.15-docs-pdf-letter.tar.bz2) = 698413a74cfa5453a95a12ec34f6cc82e19e4ef53ebad4d736fe608d64f14267
SIZE (python/python-2.7.15-docs-pdf-letter.tar.bz2) = 9429554
SHA256 (python/python-2.7.15-docs-text.tar.bz2) = 92b32e57182b1b7110f71db43a8c49aaaf9833186d7ea1021fe3b166e7164535
SIZE (python/python-2.7.15-docs-text.tar.bz2) = 1617467
SHA256 (python/python-3.4.8-docs-html.tar.bz2) = 62e810fba6cbb757216e556421c84142d51148b5bf7dc54c2b07478fc4e5661f
SIZE (python/python-3.4.8-docs-html.tar.bz2) = 5495911
SHA256 (python/python-3.4.8-docs-pdf-a4.tar.bz2) = 5af92fe2cc242a2ff3e441fe33b9d68bb2eccc661e0fe3ea111edc68371480da

View File

@ -2,7 +2,6 @@
PORTNAME= python
PORTVERSION= ${PYTHON_PORTVERSION}
PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
PKGNAMESUFFIX= 27

View File

@ -1,4 +1,4 @@
# Mk/Uses/python.mk includes this file, don't remove it!
# $FreeBSD$
PYTHON_PORTVERSION= 2.7.14
PYTHON_PORTVERSION= 2.7.15

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1505677472
SHA256 (python/Python-2.7.14.tar.xz) = 71ffb26e09e78650e424929b2b457b9c912ac216576e6bd9e7d204ed03296a66
SIZE (python/Python-2.7.14.tar.xz) = 12576112
TIMESTAMP = 1525598061
SHA256 (python/Python-2.7.15.tar.xz) = 22d9b1ac5b26135ad2b8c2901a9413537e08749a753356ee913c84dbd2df5574
SIZE (python/Python-2.7.15.tar.xz) = 12642436

View File

@ -1,128 +0,0 @@
From b2d096bd2a5ff86e53c25d00ee5fa097b36bf1d8 Mon Sep 17 00:00:00 2001
From: Melvyn Sopacua <melvyn-sopacua@users.noreply.github.com>
Date: Mon, 4 Sep 2017 23:35:15 +0200
Subject: [PATCH] bpo-30622: Change NPN detection: (#2079)
* Change NPN detection:
Version breakdown, support disabled (pre-patch/post-patch):
- pre-1.0.1: OPENSSL_NPN_NEGOTIATED will not be defined -> False/False
- 1.0.1 and 1.0.2: OPENSSL_NPN_NEGOTIATED will not be defined ->
False/False
- 1.1.0+: OPENSSL_NPN_NEGOTIATED will be defined and
OPENSSL_NO_NEXTPROTONEG will be defined -> True/False
Version breakdown support enabled (pre-patch/post-patch):
- pre-1.0.1: OPENSSL_NPN_NEGOTIATED will not be defined -> False/False
- 1.0.1 and 1.0.2: OPENSSL_NPN_NEGOTIATED will be defined and
OPENSSL_NO_NEXTPROTONEG will not be defined -> True/True
- 1.1.0+: OPENSSL_NPN_NEGOTIATED will be defined and
OPENSSL_NO_NEXTPROTONEG will not be defined -> True/True
* Refine NPN guard:
- If NPN is disabled, but ALPN is available we need our callback
- Make clinic's ssl behave the same way
This created a working ssl module for me, with NPN disabled and ALPN
enabled for OpenSSL 1.1.0f.
Concerns to address:
The initial commit for NPN support into OpenSSL [1], had the
OPENSSL_NPN_* variables defined inside the OPENSSL_NO_NEXTPROTONEG
guard. The question is if that ever made it into a release.
This would need an ugly hack, something like:
#if defined(OPENSSL_NO_NEXTPROTONEG) && \
!defined(OPENSSL_NPN_NEGOTIATED)
# define OPENSSL_NPN_UNSUPPORTED 0
# define OPENSSL_NPN_NEGOTIATED 1
# define OPENSSL_NPN_NO_OVERLAP 2
#endif
[1] https://github.com/openssl/openssl/commit/68b33cc5c7
--- Modules/_ssl.c.orig 2017-09-16 17:38:35 UTC
+++ Modules/_ssl.c
@@ -280,7 +280,7 @@ static unsigned int _ssl_locks_count = 0
typedef struct {
PyObject_HEAD
SSL_CTX *ctx;
-#ifdef OPENSSL_NPN_NEGOTIATED
+#if defined(OPENSSL_NPN_NEGOTIATED) && !defined(OPENSSL_NO_NEXTPROTONEG)
unsigned char *npn_protocols;
int npn_protocols_len;
#endif
@@ -1502,7 +1502,7 @@ static PyObject *PySSL_version(PySSLSock
return PyUnicode_FromString(version);
}
-#ifdef OPENSSL_NPN_NEGOTIATED
+#if defined(OPENSSL_NPN_NEGOTIATED) && !defined(OPENSSL_NO_NEXTPROTONEG)
static PyObject *PySSL_selected_npn_protocol(PySSLSocket *self) {
const unsigned char *out;
unsigned int outlen;
@@ -2030,7 +2030,7 @@ static PyMethodDef PySSLMethods[] = {
PySSL_peercert_doc},
{"cipher", (PyCFunction)PySSL_cipher, METH_NOARGS},
{"version", (PyCFunction)PySSL_version, METH_NOARGS},
-#ifdef OPENSSL_NPN_NEGOTIATED
+#if defined(OPENSSL_NPN_NEGOTIATED) && !defined(OPENSSL_NO_NEXTPROTONEG)
{"selected_npn_protocol", (PyCFunction)PySSL_selected_npn_protocol, METH_NOARGS},
#endif
#ifdef HAVE_ALPN
@@ -2140,7 +2140,7 @@ context_new(PyTypeObject *type, PyObject
return NULL;
}
self->ctx = ctx;
-#ifdef OPENSSL_NPN_NEGOTIATED
+#if defined(OPENSSL_NPN_NEGOTIATED) && !defined(OPENSSL_NO_NEXTPROTONEG)
self->npn_protocols = NULL;
#endif
#ifdef HAVE_ALPN
@@ -2216,7 +2216,7 @@ context_dealloc(PySSLContext *self)
{
context_clear(self);
SSL_CTX_free(self->ctx);
-#ifdef OPENSSL_NPN_NEGOTIATED
+#if defined(OPENSSL_NPN_NEGOTIATED) && !defined(OPENSSL_NO_NEXTPROTONEG)
PyMem_FREE(self->npn_protocols);
#endif
#ifdef HAVE_ALPN
@@ -2246,7 +2246,7 @@ set_ciphers(PySSLContext *self, PyObject
Py_RETURN_NONE;
}
-#ifdef OPENSSL_NPN_NEGOTIATED
+#if defined(OPENSSL_NPN_NEGOTIATED) && !defined(OPENSSL_NO_NEXTPROTONEG) || defined(HAVE_ALPN)
static int
do_protocol_selection(int alpn, unsigned char **out, unsigned char *outlen,
const unsigned char *server_protocols, unsigned int server_protocols_len,
@@ -2270,7 +2270,9 @@ do_protocol_selection(int alpn, unsigned
return SSL_TLSEXT_ERR_OK;
}
+#endif
+#if defined(OPENSSL_NPN_NEGOTIATED) && !defined(OPENSSL_NO_NEXTPROTONEG)
/* this callback gets passed to SSL_CTX_set_next_protos_advertise_cb */
static int
_advertiseNPN_cb(SSL *s,
@@ -2305,7 +2307,7 @@ _selectNPN_cb(SSL *s,
static PyObject *
_set_npn_protocols(PySSLContext *self, PyObject *args)
{
-#ifdef OPENSSL_NPN_NEGOTIATED
+#if defined(OPENSSL_NPN_NEGOTIATED) && !defined(OPENSSL_NO_NEXTPROTONEG)
Py_buffer protos;
if (!PyArg_ParseTuple(args, "s*:set_npn_protocols", &protos))
@@ -4303,7 +4305,7 @@ init_ssl(void)
Py_INCREF(r);
PyModule_AddObject(m, "HAS_ECDH", r);
-#ifdef OPENSSL_NPN_NEGOTIATED
+#if defined(OPENSSL_NPN_NEGOTIATED) && !defined(OPENSSL_NO_NEXTPROTONEG)
r = Py_True;
#else
r = Py_False;

View File

@ -1436,8 +1436,8 @@ lib/python2.7/ensurepip/__init__.pyo
lib/python2.7/ensurepip/__main__.py
lib/python2.7/ensurepip/__main__.pyc
lib/python2.7/ensurepip/__main__.pyo
lib/python2.7/ensurepip/_bundled/pip-9.0.1-py2.py3-none-any.whl
lib/python2.7/ensurepip/_bundled/setuptools-28.8.0-py2.py3-none-any.whl
lib/python2.7/ensurepip/_bundled/pip-9.0.3-py2.py3-none-any.whl
lib/python2.7/ensurepip/_bundled/setuptools-39.0.1-py2.py3-none-any.whl
lib/python2.7/ensurepip/_uninstall.py
lib/python2.7/ensurepip/_uninstall.pyc
lib/python2.7/ensurepip/_uninstall.pyo
@ -3038,7 +3038,6 @@ lib/python2.7/test/seq_tests.py
lib/python2.7/test/seq_tests.pyc
lib/python2.7/test/seq_tests.pyo
lib/python2.7/test/sgml_input.html
lib/python2.7/test/sha256.pem
lib/python2.7/test/sortperf.py
lib/python2.7/test/sortperf.pyc
lib/python2.7/test/sortperf.pyo
@ -4322,6 +4321,7 @@ lib/python2.7/test/win_console_handler.py
lib/python2.7/test/win_console_handler.pyc
lib/python2.7/test/win_console_handler.pyo
lib/python2.7/test/wrongcert.pem
lib/python2.7/test/xmltestdata/expat224_utf8_bug.xml
lib/python2.7/test/xmltestdata/simple-ns.xml
lib/python2.7/test/xmltestdata/simple.xml
lib/python2.7/test/xmltestdata/test.xml