Add powerdns-recursor 3.1.4, an advanced DNS recursor.
PR: 105526 Submitted by: sten at blinkenlights.nl
This commit is contained in:
parent
311cb2199d
commit
88ba353662
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=177369
@ -91,6 +91,7 @@
|
||||
SUBDIR += posadis
|
||||
SUBDIR += poweradmin
|
||||
SUBDIR += powerdns
|
||||
SUBDIR += powerdns-recursor
|
||||
SUBDIR += py-adns
|
||||
SUBDIR += py-dns
|
||||
SUBDIR += py-dnspython
|
||||
|
59
dns/powerdns-recursor/Makefile
Normal file
59
dns/powerdns-recursor/Makefile
Normal file
@ -0,0 +1,59 @@
|
||||
# New ports collection makefile for: powerdns-recursor
|
||||
# Date Created: 14.Nov 2006
|
||||
# Whom: sten@blinkenlights.nl
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= powerdns-recursor
|
||||
PORTVERSION= 3.1.4
|
||||
CATEGORIES= dns ipv6
|
||||
MASTER_SITES= http://downloads.powerdns.com/releases/ \
|
||||
http://mirrors.evolva.ro/powerdns.com/releases/
|
||||
DISTNAME= pdns-recursor-${PORTVERSION}
|
||||
|
||||
MAINTAINER= sten@blinkenlights.nl
|
||||
COMMENT= An advanced DNS recursor
|
||||
|
||||
BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
CXXFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
MAKE_ENV+= CXX="${CXX}" CC="${CC}"
|
||||
|
||||
MAN8= rec_control.8 pdns_recursor.8
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
USE_RC_SUBR+= pdns-recursor
|
||||
|
||||
.if exists(/usr/include/ucontext.h) && ${OSVERSION} >= 500000
|
||||
UCONTEXT!= ${AWK} '/setcontext/ { print "YES" }' \
|
||||
/usr/include/ucontext.h
|
||||
.if ${UCONTEXT} == ""
|
||||
BROKEN= requires setcontext()
|
||||
.endif
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's;SBINDIR=/usr/sbin/;SBINDIR=${PREFIX}/sbin/;' \
|
||||
-e 's;BINDIR=/usr/bin/;BINDIR=${PREFIX}/bin/;' \
|
||||
-e 's;CONFIGDIR="/etc/powerdns/";CONFIGDIR=${PREFIX}/etc/pdns/;' \
|
||||
${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} -e 's;"/etc/powerdns/";"${PREFIX}/etc/powerdns/";' \
|
||||
${WRKSRC}/config.h
|
||||
|
||||
post-install:
|
||||
.if !exists(${PREFIX}/etc/pdns/recursor.conf)
|
||||
${INSTALL_DATA} ${PREFIX}/etc/pdns/recursor.conf-dist \
|
||||
${PREFIX}/etc/pdns/recursor.conf
|
||||
.endif
|
||||
@${INSTALL_MAN} ${WRKSRC}/*.8 ${PREFIX}/man/man8/
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
dns/powerdns-recursor/distinfo
Normal file
3
dns/powerdns-recursor/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
MD5 (pdns-recursor-3.1.4.tar.bz2) = 439a10639f53def0ba47c0851e4a2671
|
||||
SHA256 (pdns-recursor-3.1.4.tar.bz2) = 9975ec73e311bda4c22f302f18f4ed4fe701d63bce3155f300ccc561d5b0cc39
|
||||
SIZE (pdns-recursor-3.1.4.tar.bz2) = 139191
|
29
dns/powerdns-recursor/files/patch-makefile
Normal file
29
dns/powerdns-recursor/files/patch-makefile
Normal file
@ -0,0 +1,29 @@
|
||||
--- Makefile.orig Tue Nov 14 13:26:24 2006
|
||||
+++ Makefile Tue Nov 14 13:26:51 2006
|
||||
@@ -2,7 +2,6 @@
|
||||
SBINDIR=/usr/sbin/
|
||||
BINDIR=/usr/bin/
|
||||
CONFIGDIR="/etc/powerdns/"
|
||||
-OPTFLAGS?=-O3
|
||||
CXXFLAGS:= $(CXXFLAGS) -Wall $(OPTFLAGS) $(PROFILEFLAGS)
|
||||
CFLAGS:=$(CFLAGS) -Wall $(OPTFLAGS) $(PROFILEFLAGS)
|
||||
LINKCC=$(CXX)
|
||||
@@ -52,16 +52,14 @@
|
||||
fi
|
||||
|
||||
install: all
|
||||
- -mkdir -p $(DESTDIR)/$(SBINDIR)
|
||||
mv pdns_recursor $(DESTDIR)/$(SBINDIR)
|
||||
strip $(DESTDIR)/$(SBINDIR)/pdns_recursor
|
||||
- mkdir -p $(DESTDIR)/$(BINDIR)
|
||||
mv rec_control $(DESTDIR)/$(BINDIR)
|
||||
strip $(DESTDIR)/$(BINDIR)/rec_control
|
||||
-mkdir -p $(DESTDIR)/$(CONFIGDIR)
|
||||
$(DESTDIR)/$(SBINDIR)/pdns_recursor --config > $(DESTDIR)/$(CONFIGDIR)/recursor.conf-dist
|
||||
- -mkdir -p $(DESTDIR)/usr/share/man/man1
|
||||
- cp pdns_recursor.1 rec_control.1 $(DESTDIR)/usr/share/man/man1
|
||||
+ mv pdns_recursor.1 pdns_recursor.8
|
||||
+ mv rec_control.1 rec_control.8
|
||||
$(OS_SPECIFIC_INSTALL)
|
||||
|
||||
clean:
|
58
dns/powerdns-recursor/files/patch-manpages
Normal file
58
dns/powerdns-recursor/files/patch-manpages
Normal file
@ -0,0 +1,58 @@
|
||||
--- rec_control.1.orig Tue Nov 14 13:47:26 2006
|
||||
+++ rec_control.1 Tue Nov 14 13:47:55 2006
|
||||
@@ -17,7 +17,7 @@
|
||||
.el .ne 3
|
||||
.IP "\\$1" \\$2
|
||||
..
|
||||
-.TH "REC_CONTROL" 1 "" "" ""
|
||||
+.TH "REC_CONTROL" 8 "" "" ""
|
||||
.SH NAME
|
||||
rec_control \- control pdns_recursor
|
||||
.SH "SYNOPSIS"
|
||||
@@ -28,7 +28,7 @@
|
||||
.SH "DESCRIPTION"
|
||||
|
||||
|
||||
-rec_control(1) allows the operator to control a running instance of the pdns_recursor\&.
|
||||
+rec_control(8) allows the operator to control a running instance of the pdns_recursor\&.
|
||||
|
||||
|
||||
The commands that can be passed to the recursor are described on http://doc\&.powerdns\&.com/rec\-control\&.html
|
||||
@@ -111,7 +111,7 @@
|
||||
.SH "SEE ALSO"
|
||||
|
||||
|
||||
-pdns_recursor(1)
|
||||
+pdns_recursor(8)
|
||||
|
||||
.SH "COPYING"
|
||||
|
||||
--- pdns_recursor.1.orig Tue Nov 14 13:48:13 2006
|
||||
+++ pdns_recursor.1 Tue Nov 14 13:48:44 2006
|
||||
@@ -17,7 +17,7 @@
|
||||
.el .ne 3
|
||||
.IP "\\$1" \\$2
|
||||
..
|
||||
-.TH "PDNS_RECURSOR" 1 "" "" ""
|
||||
+.TH "PDNS_RECURSOR" 8 "" "" ""
|
||||
.SH NAME
|
||||
pdns_recursor \- high-performance, simple and secure recursing nameserver
|
||||
.SH "SYNOPSIS"
|
||||
@@ -28,7 +28,7 @@
|
||||
.SH "DESCRIPTION"
|
||||
|
||||
|
||||
-pdns_recursor(1) is a high performance, simple and secure recursing nameserver\&. It currently powers over two million internet connections\&.
|
||||
+pdns_recursor(8) is a high performance, simple and secure recursing nameserver\&. It currently powers over two million internet connections\&.
|
||||
|
||||
|
||||
The recursor is configured via a configuration file, but each item in that file can be overridden on the command line\&.
|
||||
@@ -211,7 +211,7 @@
|
||||
.SH "SEE ALSO"
|
||||
|
||||
|
||||
-rec_control(1)
|
||||
+rec_control(8)
|
||||
|
||||
.SH "COPYING"
|
||||
|
35
dns/powerdns-recursor/files/pdns-recursor.in
Normal file
35
dns/powerdns-recursor/files/pdns-recursor.in
Normal file
@ -0,0 +1,35 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# $$
|
||||
#
|
||||
|
||||
# PROVIDE: pdns_recursor
|
||||
# REQUIRE: DAEMON
|
||||
# KEYWORD: shutdown
|
||||
|
||||
#
|
||||
# Add the following lines to /etc/rc.conf to enable pdns_recursor:
|
||||
#
|
||||
#pdns_recursor_enable="YES"
|
||||
#
|
||||
# See pdns_recursor(8) for flags.
|
||||
#
|
||||
|
||||
. %%RC_SUBR%%
|
||||
|
||||
name=pdns_recursor
|
||||
rcvar=`set_rcvar`
|
||||
|
||||
command=%%PREFIX%%/sbin/pdns_recursor
|
||||
|
||||
# set defaults
|
||||
|
||||
pdns_recursor_enable=${pdns_recursor_enable:-"NO"}
|
||||
pdns_recursor_conf=${pdns_recursor_conf:-"%%PREFIX%%/etc/pdns/recursor.conf"}
|
||||
pdns_recursor_flags=${pdns_recursor_flags:-""}
|
||||
|
||||
load_rc_config ${name}
|
||||
|
||||
required_files=${pdns_recursor_conf}
|
||||
|
||||
run_rc_command "$1"
|
11
dns/powerdns-recursor/files/pkg-message.in
Normal file
11
dns/powerdns-recursor/files/pkg-message.in
Normal file
@ -0,0 +1,11 @@
|
||||
|
||||
*******************************************************************
|
||||
If you want to use the powerdns recursor,
|
||||
you need the following line in /etc/rc.conf(.local)
|
||||
|
||||
pdns_recursor_enable="YES"
|
||||
|
||||
Configuration templates are available in %%PREFIX%%/etc/pdns
|
||||
as recursor.conf-dist.
|
||||
*******************************************************************
|
||||
|
4
dns/powerdns-recursor/pkg-descr
Normal file
4
dns/powerdns-recursor/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
powerdns recursor is a high performance, simple and secure recursing
|
||||
nameserver. It currently powers over two million internet connections.
|
||||
|
||||
WWW: http://www.powerdns.com
|
6
dns/powerdns-recursor/pkg-plist
Normal file
6
dns/powerdns-recursor/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
@unexec if cmp -s %D/etc/pdns/recursor.conf %D/etc/pdns/recursor.conf-dist; then rm -f %D/etc/pdns/recursor.conf; fi
|
||||
etc/pdns/recursor.conf-dist
|
||||
@exec [ -f %B/recursor.conf ] || cp %B/%f %B/recursor.conf
|
||||
bin/rec_control
|
||||
sbin/pdns_recursor
|
||||
@dirrmtry etc/pdns
|
Loading…
Reference in New Issue
Block a user