- Update to r5917

PR:		113998
Submitted by:	Thomas-Martin Seck <tmseck@netcologne.de> (maintainer)
This commit is contained in:
Martin Wilke 2007-06-24 20:35:48 +00:00
parent 814e72ce80
commit 889ee9df91
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=194202
5 changed files with 49 additions and 10 deletions

View File

@ -19,10 +19,11 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
Xft.2:${PORTSDIR}/x11-fonts/libXft
SNAPSHOT= r5857
SNAPSHOT= r5917
OPTIONS= FLTK_THREADS "Install with threads support" on \
FLTK_CAIRO "Use cairo as graphics backend" off
FLTK_CAIRO "Use cairo as graphics backend" off \
FLTK_EXAMPLES "Build and install example programs" on
LATEST_LINK= fltk2
@ -67,6 +68,22 @@ BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
CONFIGURE_ARGS+= --disable-cairo
.endif
.if defined(WITH_FLTK_EXAMPLES) && !defined (NOPORTEXAMPLES)
example_apps= ansiwidget arc bitmap boxtype browser button buttons cairo \
checkers clock color_chooser cube CubeView cursor curve \
demo doublebuffer drawing drawtiming editor exception \
file_chooser fonts fractals fullscreen gl_overlay glpuzzle \
hello image inactive input keyboard label line_style list \
list_visuals mandelbrot menu message monitors navigation \
output pack pixmap progress qubix resizable resizealign \
scroll shape sizes symbols tabs threads tile timer \
utf wizard
example_img= images/ulon.bmp
PORTEXAMPLES= *
.else
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile
.endif
post-patch:
${REINPLACE_CMD} -e 's:%%CXX%%:${CXX}:g' \
${WRKSRC}/fltk2-config.in \
@ -78,5 +95,14 @@ post-install:
cd ${WRKSRC}/documentation && ${INSTALL_DATA} *.html *.gif ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README_fltk1_to_fltk2.txt ${DOCSDIR}
.endif
.if defined(WITH_FLTK_EXAMPLES) && !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}/images
for f in ${example_apps} ; do \
${INSTALL_PROGRAM} ${WRKSRC}/test/$${f} ${EXAMPLESDIR} ; \
done
for f in ${example_img} ; do \
${INSTALL_DATA} ${WRKSRC}/test/$${f} ${EXAMPLESDIR}/images ; \
done
.endif
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (fltk-2.0.x-r5857.tar.bz2) = 1e0c80d6bc6bdf4b182f83a7307d2ab9
SHA256 (fltk-2.0.x-r5857.tar.bz2) = 9d195c6efeb75d7f8980df27fbd70099b233cac2bde0c721dccf6f83b5b5cde7
SIZE (fltk-2.0.x-r5857.tar.bz2) = 2582230
MD5 (fltk-2.0.x-r5917.tar.bz2) = 68673190339a76aa193f01a701d28f90
SHA256 (fltk-2.0.x-r5917.tar.bz2) = ce98a5c657208cf6874ad64f8325d33d265c16f5eb2495385a5c204464bef82d
SIZE (fltk-2.0.x-r5917.tar.bz2) = 2586836

View File

@ -0,0 +1,11 @@
--- Makefile.orig Sun Jun 24 17:30:12 2007
+++ Makefile Sun Jun 24 17:30:19 2007
@@ -25,7 +25,7 @@
include makeinclude
-DIRS = src $(LOCALIMAGES) images OpenGL fluid glut test
+DIRS = src $(LOCALIMAGES) images OpenGL fluid glut
all: makeinclude
for dir in $(DIRS); do\

View File

@ -1,9 +1,10 @@
--- src/Makefile.orig Fri May 12 00:09:39 2006
+++ src/Makefile Mon Jun 5 14:44:17 2006
@@ -251,36 +251,27 @@
mkdir $(DESTDIR); \
fi \
--- src/Makefile.orig Sun Jun 24 17:08:53 2007
+++ src/Makefile Sun Jun 24 17:10:34 2007
@@ -251,37 +251,27 @@
mkdir $(DESTDIR); \
fi \
fi
-
- $(RMDIR) $(DESTDIR)$(includedir)/fltk
$(MKDIR) $(DESTDIR)$(includedir)/fltk
- $(CP) ../fltk/*.h ../fltk/*.r $(DESTDIR)$(includedir)/fltk

View File

@ -193,4 +193,5 @@ include/fltk/xpmImage.h
@dirrm include/fltk
lib/libfltk2.a
lib/libfltk2_gl.a
lib/libfltk2_glut.a
lib/libfltk2_images.a