math/{,py-}spot: Minor improvements

* Allow to test the Python binding from math/spot
* Remove unnecessary patch
* Correct C++ standard level
This commit is contained in:
Yuri Victorovich 2022-10-10 06:41:44 -08:00
parent c1e0a52d1a
commit 889aaf2671
3 changed files with 7 additions and 11 deletions

View File

@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libspot.so:math/spot
USES= compiler:c++14-lang gmake libtool python:3.4+
USES= compiler:c++17-lang gmake libtool python:3.4+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-python --disable-static
@ -35,4 +35,6 @@ post-configure:
post-install:
@${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} -name "*.so" | ${XARGS} ${STRIP_CMD}
# to test: cd ../spot && make test WITH_PYTHON=yes
.include <bsd.port.mk>

View File

@ -14,7 +14,11 @@ USES= charsetfix compiler:c++17-lang gmake libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
.if !defined(WITH_PYTHON) # math/py-spot is a separate port but tests don't work there. To test run: make test WITH_PYTHON=yes
CONFIGURE_ARGS= --disable-python --disable-static
.else
CONFIGURE_ARGS= --disable-static
.endif
INSTALL_TARGET= install-strip

View File

@ -1,10 +0,0 @@
--- spot/misc/tmpfile.cc.orig 2022-10-08 19:11:32 UTC
+++ spot/misc/tmpfile.cc
@@ -23,6 +23,7 @@
#include <stdlib.h>
#include <unistd.h>
#include <string.h>
+#include <stdlib.h>
using namespace std::string_literals;