* Use external libintl, don't build included one.
* Remove version number from docs directory. Approved by: petef
This commit is contained in:
parent
bb13b768ef
commit
8861f64b57
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=76877
@ -7,12 +7,14 @@
|
||||
|
||||
PORTNAME= dopewars
|
||||
PORTVERSION= 1.5.8
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
http://bellatrix.pcl.ox.ac.uk/~ben/dopewars/
|
||||
MASTER_SITE_SUBDIR= dopewars
|
||||
|
||||
MAINTAINER= petef@FreeBSD.org
|
||||
COMMENT= A UNIX rewrite of a game originally based on "Drug Wars"
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
@ -21,14 +23,14 @@ USE_GNOME= gtk12
|
||||
USE_X_PREFIX= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
CONFIGURE_ARGS+= --enable-nls --enable-networking --disable-plugins
|
||||
CONFIGURE_ARGS= --enable-networking --disable-plugins
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.if defined(NOPORTDOCS)
|
||||
MAKE_ENV+= NOPORTDOCS=yes
|
||||
.endif
|
||||
|
||||
PLIST_SUB= DOPEWARS=${PKGNAME}
|
||||
|
||||
MAN6= dopewars.6
|
||||
|
||||
post-patch:
|
||||
|
@ -1,6 +1,18 @@
|
||||
--- doc/Makefile.in.orig Sat Mar 2 15:25:02 2002
|
||||
+++ doc/Makefile.in Mon Mar 25 09:33:45 2002
|
||||
@@ -246,10 +246,12 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- doc/Makefile.in.orig Mon Oct 21 13:09:21 2002
|
||||
+++ doc/Makefile.in Tue Mar 4 19:35:58 2003
|
||||
@@ -132,7 +132,7 @@
|
||||
install_sh = @install_sh@
|
||||
localedir = @localedir@
|
||||
plugindir = @plugindir@
|
||||
-DOCPATH = ${DESTDIR}${datadir}/doc/${PACKAGE}-${VERSION}/
|
||||
+DOCPATH = ${DESTDIR}${datadir}/doc/${PACKAGE}/
|
||||
DOCS = aiplayer.html configfile.html index.html i18n.html \
|
||||
server.html clientplay.html credits.html example-cfg \
|
||||
installation.html servercommands.html commandline.html \
|
||||
@@ -449,10 +449,12 @@
|
||||
|
||||
|
||||
install-data-local:
|
||||
@ -11,5 +23,5 @@
|
||||
done
|
||||
+endif
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
uninstall-local:
|
||||
for doc in ${DOCS}; do \
|
||||
|
14
games/dopewars/files/patch-doc::help::Makefile.in
Normal file
14
games/dopewars/files/patch-doc::help::Makefile.in
Normal file
@ -0,0 +1,14 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- doc/help/Makefile.in.orig Tue Mar 4 19:36:07 2003
|
||||
+++ doc/help/Makefile.in Tue Mar 4 19:36:19 2003
|
||||
@@ -132,7 +132,7 @@
|
||||
install_sh = @install_sh@
|
||||
localedir = @localedir@
|
||||
plugindir = @plugindir@
|
||||
-DOCPATH = ${DESTDIR}${datadir}/doc/${PACKAGE}-${VERSION}/help
|
||||
+DOCPATH = ${DESTDIR}${datadir}/doc/${PACKAGE}/help
|
||||
DOCS = cops.html general.html locations.html sounds.html \
|
||||
drugs.html guns.html server.html
|
||||
|
@ -1 +0,0 @@
|
||||
A UNIX rewrite of a game originally based on "Drug Wars"
|
@ -1,29 +1,29 @@
|
||||
@comment $FreeBSD$
|
||||
bin/dopewars
|
||||
lib/charset.alias
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/LICENCE
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/aiplayer.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/clientplay.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/commandline.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/configfile.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/contribute.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/credits.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/developer.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/example-cfg
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/help/cops.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/help/drugs.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/help/general.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/help/guns.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/help/locations.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/help/server.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/help/sounds.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/i18n.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/index.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/installation.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/metaserver.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/protocol.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/server.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/servercommands.html
|
||||
%%PORTDOCS%%share/doc/%%DOPEWARS%%/windows.html
|
||||
%%PORTDOCS%%share/doc/dopewars/LICENCE
|
||||
%%PORTDOCS%%share/doc/dopewars/aiplayer.html
|
||||
%%PORTDOCS%%share/doc/dopewars/clientplay.html
|
||||
%%PORTDOCS%%share/doc/dopewars/commandline.html
|
||||
%%PORTDOCS%%share/doc/dopewars/configfile.html
|
||||
%%PORTDOCS%%share/doc/dopewars/contribute.html
|
||||
%%PORTDOCS%%share/doc/dopewars/credits.html
|
||||
%%PORTDOCS%%share/doc/dopewars/developer.html
|
||||
%%PORTDOCS%%share/doc/dopewars/example-cfg
|
||||
%%PORTDOCS%%share/doc/dopewars/help/cops.html
|
||||
%%PORTDOCS%%share/doc/dopewars/help/drugs.html
|
||||
%%PORTDOCS%%share/doc/dopewars/help/general.html
|
||||
%%PORTDOCS%%share/doc/dopewars/help/guns.html
|
||||
%%PORTDOCS%%share/doc/dopewars/help/locations.html
|
||||
%%PORTDOCS%%share/doc/dopewars/help/server.html
|
||||
%%PORTDOCS%%share/doc/dopewars/help/sounds.html
|
||||
%%PORTDOCS%%share/doc/dopewars/i18n.html
|
||||
%%PORTDOCS%%share/doc/dopewars/index.html
|
||||
%%PORTDOCS%%share/doc/dopewars/installation.html
|
||||
%%PORTDOCS%%share/doc/dopewars/metaserver.html
|
||||
%%PORTDOCS%%share/doc/dopewars/protocol.html
|
||||
%%PORTDOCS%%share/doc/dopewars/server.html
|
||||
%%PORTDOCS%%share/doc/dopewars/servercommands.html
|
||||
%%PORTDOCS%%share/doc/dopewars/windows.html
|
||||
share/dopewars/dopewars.sco
|
||||
share/dopewars/bye.wav
|
||||
share/dopewars/colt.wav
|
||||
@ -44,7 +44,6 @@ share/dopewars/pixmaps/dopewars-weed.png
|
||||
share/locale/de/LC_MESSAGES/dopewars.mo
|
||||
share/locale/es/LC_MESSAGES/dopewars.mo
|
||||
share/locale/fr/LC_MESSAGES/dopewars.mo
|
||||
share/locale/locale.alias
|
||||
share/locale/nn/LC_MESSAGES/dopewars.mo
|
||||
share/locale/pl/LC_MESSAGES/dopewars.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/dopewars.mo
|
||||
@ -54,5 +53,5 @@ share/gnome/apps/Games/dopewars.desktop
|
||||
@unexec rmdir %D/share/gnome 2>/dev/null || true
|
||||
@dirrm share/dopewars/pixmaps
|
||||
@dirrm share/dopewars
|
||||
%%PORTDOCS%%@dirrm share/doc/%%DOPEWARS%%/help
|
||||
%%PORTDOCS%%@dirrm share/doc/%%DOPEWARS%%
|
||||
%%PORTDOCS%%@dirrm share/doc/dopewars/help
|
||||
%%PORTDOCS%%@dirrm share/doc/dopewars
|
||||
|
Loading…
Reference in New Issue
Block a user