Fix master sites, un-deprecate and update biology/recombine to 1.41.

This commit is contained in:
Vasil Dimov 2007-01-25 12:22:50 +00:00
parent 35aff202d5
commit 885510efe1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=183251
4 changed files with 19 additions and 86 deletions

View File

@ -6,28 +6,26 @@
#
PORTNAME= recombine
PORTVERSION= 1.40
PORTVERSION= 1.41
CATEGORIES= biology
MASTER_SITES= ftp://evolution.genetics.washington.edu/pub/lamarc/recombine/
DISTNAME= ${PORTNAME}${PORTVERSION}
MASTER_SITES= http://evolution.gs.washington.edu/lamarc/recombine/
DISTNAME= ${PORTNAME}${PORTVERSION}.src.doc
MAINTAINER= ports@FreeBSD.org
COMMENT= A program to fit population models across sites
DEPRECATED= distfile disappeared from homepage
EXPIRATION_DATE= 2007-01-07
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
NO_WRKSUBDIR= yes
ALL_TARGET= ${PORTNAME}
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
@ ${INSTALL_SCRIPT} ${WRKSRC}/filetran ${PREFIX}/bin/
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKSRC}/filetran ${PREFIX}/bin/
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
@ ${INSTALL_DATA} ${WRKSRC}/*.doc ${DOCSDIR}/
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/recombine.txt ${DOCSDIR}/
.endif
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (recombine1.40.tar.gz) = 78f308f69c35610fbd31a091b8d17e2f
SHA256 (recombine1.40.tar.gz) = 9601f94d1fd41233fa8470a03d53fb48bcb3f2e7358b756eebbde278114f1c35
SIZE (recombine1.40.tar.gz) = 140331
MD5 (recombine1.41.src.doc.tar.gz) = c833be133188d2482c846a596ae35cb8
SHA256 (recombine1.41.src.doc.tar.gz) = e247810ef31414f500f9c118b6462b549c761562140519f7c57f305fcb284643
SIZE (recombine1.41.src.doc.tar.gz) = 149129

View File

@ -1,6 +1,6 @@
--- Makefile.orig Wed Oct 25 23:39:34 2000
+++ Makefile Mon Aug 6 16:13:02 2001
@@ -1,105 +1,37 @@
--- Makefile.orig Thu Jan 25 13:59:21 2007
+++ Makefile Thu Jan 25 14:02:58 2007
@@ -1,11 +1,6 @@
LIBS = -lm
BINDIR = ./bin
-#CFLAGS = -Wall -Wshadow -g
@ -13,12 +13,7 @@
DCC = gcc -g -Wall -DDMALLOC_FUNC_CHECK -ansi -pedantic
PLUSCC = g++ $(CFLAGS)
LIBS = -lm -L/usr/local/lib
DLIBS = -lm -L/usr/local/lib -ldmalloc
CGCC = checkergcc -g -Wall
CGLIBS = -lm
-# -O
PROGS = recombine
@@ -18,29 +13,29 @@
# The big banana
recombine : recombine.o jdrop.o rec_modellike.o jworld.o getdata.o \
traitlike.o getmsatdata.o
@ -52,66 +47,7 @@
traitlike.o : traitlike.c
- $(CC) -c traitlike.c
-
-rectreedna : rectreedna.c
- $(CC) -o rectreedna rectreedna.c $(LIBS)
-
-hapdna : hapdna.c
- $(CC) -o hapdna hapdna.c $(LIBS)
-
-mhapdna : mhapdna.c
- $(CC) -o mhapdna mhapdna.c $(LIBS)
-
-drecombine.o : recombine.c
- $(CC) -o drecombine.o -c recombine.c
-
-djdrop.o : jdrop.c
- $(CC) -o djdrop.o -c jdrop.c
-
-drec_modellike.o : rec_modellike.c
- $(CC) -o drec_modellike.o -c rec_modellike.c
-
-djworld.o : jworld.c
- $(CC) -o djworld.o -c jworld.c
-
-dgetdata.o : getdata.c
- $(CC) -o dgetdata.o -c getdata.c
-
-dgetmsatdata.o : getmsatdata.c
- $(CC) -o dgetmsatdata.o -c getmsatdata.c
-
-drecombine: drecombine.o djdrop.o drec_modellike.o djworld.o dgetdata.o memdebug.o memalpha.o memfree.o \
- dgetmsatdata.o
- $(CC) drecombine.o djdrop.o drec_modellike.o djworld.o dgetdata.o memdebug.o memalpha.o memfree.o \
- dgetmsatdata.o $(LIBS) -o drecombine
-
-dclean:
- rm drecombine.o djdrop.o drec_modellike.o djworld.o dgetdata.o dgetmsatdata.o
-
-clean :
- rm -f *.o
-
-gentrees.o : gentrees.c
- $(CC) -c gentrees.c
-
-segtre_mig.o : segtre_mig.c
- $(CC) -c segtre_mig.c
-
-rectree : gentrees.o segtre_mig.o
- $(CC) gentrees.o segtre_mig.o $(LIBS) -o rectree
-
-jrectree : simrectree.c
- $(CC) simrectree.c $(LIBS) -o jrectree
-
-snp : snp.c
- $(CC) snp.c $(LIBS) -o snp
-
-panelmaker : panelmaker.c
- $(CC) panelmaker.c $(LIBS) -o panelmaker
-
-variance : variance.c
- $(CC) variance.c $(LIBS) -o variance
-
-distree : distree.c
- $(CC) distree.c $(LIBS) -o distree
+ $(CC) $(CFLAGS) -c traitlike.c
rectreedna : rectreedna.c
$(CC) -o rectreedna rectreedna.c $(LIBS)

View File

@ -1,5 +1,4 @@
bin/filetran
bin/recombine
%%PORTDOCS%%%%DOCSDIR%%/rec_errors.doc
%%PORTDOCS%%%%DOCSDIR%%/recombine.doc
%%PORTDOCS%%%%DOCSDIR%%/recombine.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%