Use USE_LOCALE instead

This commit is contained in:
Sunpoet Po-Chuan Hsieh 2020-08-23 19:36:44 +00:00
parent 65e40e9915
commit 881be6c3fb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=545862
2 changed files with 1 additions and 19 deletions

View File

@ -21,6 +21,7 @@ USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
USE_LOCALE= en_US.UTF-8
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test

View File

@ -1,19 +0,0 @@
--- setup.py.orig 2020-02-09 10:45:34 UTC
+++ setup.py
@@ -1,5 +1,7 @@
#!/usr/bin/env python
+from io import open
+
# Using setuptools rather than distutils to get the `develop` command
from setuptools import setup
@@ -8,7 +10,7 @@ NAME = 'feedgenerator'
PACKAGES = ['feedgenerator', 'feedgenerator.django',
'feedgenerator.django.utils']
DESCRIPTION = 'Standalone version of django.utils.feedgenerator'
-LONG_DESCRIPTION = open('README.rst').read()
+LONG_DESCRIPTION = open('README.rst', encoding='UTF-8').read()
URL = "https://github.com/getpelican/feedgenerator"