- Fix build on 5.x
PR: ports/59613 Submitted by: Ports Fury
This commit is contained in:
parent
9fb35023ed
commit
881afb1532
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=95210
@ -23,22 +23,17 @@ LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
|
||||
gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
|
||||
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
|
||||
|
||||
USE_MESA= yes
|
||||
USE_GNOME= gtk12
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
USE_GL= yes
|
||||
USE_GNOME= gnometarget gtk12
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
CONFIGURE_ARGS= --enable-gtk --enable-threads --with-mesa --with-netcdf \
|
||||
CONFIGURE_ARGS= --enable-gtk --enable-threads --with-netcdf \
|
||||
--with-mixkit=${LOCALBASE}/lib/libmix.a --with-x
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_FLAGS}
|
||||
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
|
||||
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
CFLAGS+= -DMIX_ANSI_IOSTREAMS -fpermissive
|
||||
|
||||
.if ${OSVERSION} >= 500113
|
||||
BROKEN= "Does not compile (bad C++ code)"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- configure.orig Wed Nov 7 20:54:00 2001
|
||||
+++ configure Sun Sep 15 08:57:22 2002
|
||||
@@ -6903,6 +6903,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
25
science/vis5d+/files/patch-ltmain.sh
Normal file
25
science/vis5d+/files/patch-ltmain.sh
Normal file
@ -0,0 +1,25 @@
|
||||
--- ltmain.sh.orig Wed Nov 7 20:53:47 2001
|
||||
+++ ltmain.sh Sun Nov 23 11:20:58 2003
|
||||
@@ -2408,6 +2408,9 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test $build_libtool_need_lc = "yes"; then
|
||||
@@ -4175,10 +4178,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
22
science/vis5d+/files/patch-util::main.c
Normal file
22
science/vis5d+/files/patch-util::main.c
Normal file
@ -0,0 +1,22 @@
|
||||
--- util/main.c.orig Wed Oct 24 19:46:49 2001
|
||||
+++ util/main.c Sun Nov 23 12:15:53 2003
|
||||
@@ -34,9 +34,6 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
||||
-#ifdef HAVE_SYS_LOCK_H
|
||||
-# include <sys/lock.h>
|
||||
-#endif
|
||||
#include <errno.h>
|
||||
#include <signal.h>
|
||||
#include <unistd.h>
|
||||
@@ -44,6 +41,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/resource.h>
|
||||
#include <sys/stat.h>
|
||||
+#ifdef HAVE_SYS_LOCK_H
|
||||
+# include <sys/lock.h>
|
||||
+#endif
|
||||
|
||||
char cc[1000];
|
||||
int Argc;
|
Loading…
Reference in New Issue
Block a user