Remove always-true RUBY_VER check

- Pet portlint: fix diff header of patch files
- Convert to options target helper

With hat:	ruby
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2017-01-13 14:44:55 +00:00
parent 2b626bef0f
commit 8806dfc690
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=431392
8 changed files with 18 additions and 18 deletions

View File

@ -57,10 +57,6 @@ SHEBANG_FILES= examples/record.rb \
.include <bsd.port.pre.mk>
.if ${RUBY_VER} >= 2.1
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bdbxml2-bdbxml.h
.endif
.if ${RUBY_VER} == 2.1
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-common.c-21
.endif
@ -76,9 +72,13 @@ post-patch:
post-install:
${STRIP_CMD} ${STAGEDIR}${RUBY_SITEARCHLIBDIR}/bdb.so
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/doc
(cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
(cd ${WRKSRC}/docs/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/doc)
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR} "! -empty")

View File

@ -1,5 +1,5 @@
--- ./bdbxml1/bdbxml.cc.orig 2011-04-06 19:35:39.000000000 +0000
+++ ./bdbxml1/bdbxml.cc 2014-01-03 01:47:58.535201285 +0000
--- bdbxml1/bdbxml.cc.orig 2011-04-06 19:35:39 UTC
+++ bdbxml1/bdbxml.cc
@@ -2340,18 +2340,16 @@
major = NUM2INT(rb_const_get(xb_mDb, rb_intern("VERSION_MAJOR")));
minor = NUM2INT(rb_const_get(xb_mDb, rb_intern("VERSION_MINOR")));

View File

@ -1,5 +1,5 @@
--- bdbxml2/bdbxml.h.orig 2011-04-06 19:35:39.000000000 +0000
+++ bdbxml2/bdbxml.h 2015-01-22 17:03:07.000000000 +0000
--- bdbxml2/bdbxml.h.orig 2011-04-06 19:35:39 UTC
+++ bdbxml2/bdbxml.h
@@ -377,7 +377,7 @@
static inline void
rset_obj(VALUE obj)

View File

@ -1,5 +1,5 @@
--- ./bdbxml2/bdbxml.cc.orig 2011-04-06 19:35:39.000000000 +0000
+++ ./bdbxml2/bdbxml.cc 2014-01-03 01:49:02.080197786 +0000
--- bdbxml2/bdbxml.cc.orig 2011-04-06 19:35:39 UTC
+++ bdbxml2/bdbxml.cc
@@ -5536,18 +5536,16 @@
major = NUM2INT(rb_const_get(xb_mDb, rb_intern("VERSION_MAJOR")));
minor = NUM2INT(rb_const_get(xb_mDb, rb_intern("VERSION_MINOR")));

View File

@ -1,5 +1,5 @@
--- extconf.rb.orig 2011-04-06 19:35:39.000000000 +0000
+++ extconf.rb 2015-01-22 14:56:21.000000000 +0000
--- extconf.rb.orig 2011-04-06 19:35:39 UTC
+++ extconf.rb
@@ -50,7 +50,7 @@
rdoc: docs/doc/index.html

View File

@ -1,5 +1,5 @@
--- src/extconf.rb.orig 2015-01-22 16:09:31.000000000 +0000
+++ src/extconf.rb 2015-01-22 16:09:34.000000000 +0000
--- src/extconf.rb.orig 2015-01-22 16:09:31 UTC
+++ src/extconf.rb
@@ -36,16 +36,16 @@
if unknown = enable_config("unknown")

View File

@ -1,5 +1,5 @@
--- src/features.rb.orig 2011-04-06 19:35:39.000000000 +0000
+++ src/features.rb 2015-01-22 16:40:53.000000000 +0000
--- src/features.rb.orig 2011-04-06 19:35:39 UTC
+++ src/features.rb
@@ -813,7 +813,6 @@
begin
conftest = CONFTEST_C.dup

View File

@ -1,5 +1,5 @@
--- ./src/bdb.c.orig 2011-04-06 19:35:39.000000000 +0000
+++ ./src/bdb.c 2014-01-03 01:45:56.336210315 +0000
--- src/bdb.c.orig 2011-04-06 19:35:39 UTC
+++ src/bdb.c
@@ -166,11 +166,10 @@
rb_raise(rb_eNameError, "module already defined");
}