Finish migration of java/jakarta-commons-beanutils to apache-commons-beanutils.
- Update to version 1.9.4 - Pet portlint - Bump PORTREVISION for related dependencies PR: 243719 Submitted by: pfg Security: CESA-2020:0194
This commit is contained in:
parent
dd543c0f76
commit
880396f84b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=524655
1
MOVED
1
MOVED
@ -14003,3 +14003,4 @@ x11-wm/plwm||2020-01-27|Has expired: Unmaintained, uses EOLed python27
|
||||
games/vegastrike-data||2020-01-27|Removed
|
||||
textproc/gnome-doc-utils||2020-01-27|Abandoned upstream, Python 2.7 only
|
||||
java/jakarta-commons-discovery|java/apache-commons-discovery|2020-01-29|Renamed upstream
|
||||
java/jakarta-commons-commons-beanutils|apache-commons-beanutils|2020-01-30|Renamed upstream
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= jasperreports
|
||||
PORTVERSION= 5.5.2
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= databases print java
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/JasperReports%20${PORTVERSION}
|
||||
DISTFILES= ${PORTNAME}-${PORTVERSION}.jar ${PORTNAME}-applet-${PORTVERSION}.jar
|
||||
@ -17,7 +17,7 @@ RUN_DEPENDS= ${JAVALIBDIR}/itext.jar:devel/itext \
|
||||
${JAVALIBDIR}/poi.jar:textproc/apache-poi \
|
||||
${JAVALIBDIR}/jfreechart.jar:java/jfreechart \
|
||||
${LOCALBASE}/share/java/batik/lib/batik-all.jar:graphics/batik \
|
||||
${JAVALIBDIR}/commons-beanutils.jar:java/jakarta-commons-beanutils\
|
||||
${JAVALIBDIR}/commons-beanutils.jar:java/apache-commons-beanutils\
|
||||
${JAVALIBDIR}/commons-digester.jar:textproc/apache-commons-digester
|
||||
|
||||
OPTIONS_DEFINE= MYSQL PGSQL HSQLDB
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= commons-configuration
|
||||
PORTVERSION= 1.10
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel java
|
||||
MASTER_SITES= APACHE_COMMONS_BINARIES
|
||||
PKGNAMEPREFIX= apache-
|
||||
@ -13,7 +14,7 @@ COMMENT= Java package for the reading of configuration/preferences files
|
||||
|
||||
LICENSE= APACHE20
|
||||
|
||||
RUN_DEPENDS= ${JAVALIBDIR}/commons-beanutils.jar:java/jakarta-commons-beanutils \
|
||||
RUN_DEPENDS= ${JAVALIBDIR}/commons-beanutils.jar:java/apache-commons-beanutils \
|
||||
${JAVALIBDIR}/commons-lang.jar:java/apache-commons-lang \
|
||||
${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
|
||||
|
||||
|
@ -4,6 +4,7 @@
|
||||
COMMENT = Java language support
|
||||
|
||||
SUBDIR += apache-bcel
|
||||
SUBDIR += apache-commons-beanutils
|
||||
SUBDIR += apache-commons-cli
|
||||
SUBDIR += apache-commons-codec
|
||||
SUBDIR += apache-commons-collections
|
||||
@ -47,7 +48,6 @@
|
||||
SUBDIR += intellij-ultimate
|
||||
SUBDIR += jad
|
||||
SUBDIR += jai
|
||||
SUBDIR += jakarta-commons-beanutils
|
||||
SUBDIR += jakarta-oro
|
||||
SUBDIR += jakarta-regexp
|
||||
SUBDIR += jasmin
|
||||
|
@ -2,11 +2,10 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= commons-beanutils
|
||||
PORTVERSION= 1.9.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.9.4
|
||||
CATEGORIES= java devel
|
||||
MASTER_SITES= APACHE_COMMONS_SOURCE
|
||||
PKGNAMEPREFIX= jakarta-
|
||||
PKGNAMEPREFIX= apache-
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
||||
|
||||
MAINTAINER= olgeni@FreeBSD.org
|
||||
@ -28,7 +27,7 @@ MAKE_ARGS+= -Dcommons-collections.jar=${JAVALIBDIR}/commons-collections.jar \
|
||||
-Dcommons-logging.jar=${JAVALIBDIR}/commons-logging.jar
|
||||
|
||||
JARFILE= ${PORTNAME}.jar
|
||||
PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
|
||||
PLIST_FILES= ${JAVAJARDIR}/${JARFILE}
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
@ -40,6 +39,9 @@ OTHERDOCS= LICENSE.txt NOTICE.txt RELEASE-NOTES.txt
|
||||
PORTDOCS= ${APIDOCS} ${OTHERDOCS}
|
||||
.endif
|
||||
|
||||
pre-build:
|
||||
@${REINPLACE_CMD} -e 's!1.9.3-SNAPSHOT!${PORTVERSION}!g;' \
|
||||
${WRKSRC}/build.xml
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}-${PORTVERSION}.jar ${STAGEDIR}${JAVALIBDIR}/${JARFILE}
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (commons-beanutils-1.9.2-src.tar.gz) = 91fccad3b65f278bad98df1aa8467f2d3df6095f41b2db39d2c12863fb2c0049
|
||||
SIZE (commons-beanutils-1.9.2-src.tar.gz) = 396910
|
||||
TIMESTAMP = 1580359877
|
||||
SHA256 (commons-beanutils-1.9.4-src.tar.gz) = 2d46a5ac37000cad57ed338dbc5a0ae08cb924471afb5b3d4cff084afa0c728e
|
||||
SIZE (commons-beanutils-1.9.4-src.tar.gz) = 412606
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- build.xml.orig
|
||||
+++ build.xml
|
||||
@@ -212,8 +212,6 @@
|
||||
todir="${dist.home}"/>
|
||||
<copy file="RELEASE-NOTES.txt"
|
||||
todir="${dist.home}"/>
|
||||
- <copy file="README.txt"
|
||||
- todir="${dist.home}"/>
|
||||
<antcall target="jar"/>
|
||||
</target>
|
||||
|
@ -1,5 +1,7 @@
|
||||
Commons BeanUtils
|
||||
|
||||
JavaBeans utility library. It provides wrappers around getters
|
||||
and setters for a property in an object for classes that conform
|
||||
to the JavaBeans naming standard.
|
||||
|
||||
WWW: http://jakarta.apache.org/commons/beanutils/
|
||||
WWW: http://commons.apache.org/proper/commons-beanutils/
|
||||
|
@ -1,52 +0,0 @@
|
||||
# Created by: Ernst de Haan <znerd@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= commons-beanutils
|
||||
PORTVERSION= 1.9.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= java devel
|
||||
MASTER_SITES= APACHE_COMMONS_SOURCE
|
||||
PKGNAMEPREFIX= jakarta-
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
||||
|
||||
MAINTAINER= olgeni@FreeBSD.org
|
||||
COMMENT= JavaBeans utility library
|
||||
|
||||
LICENSE= APACHE20
|
||||
|
||||
BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
|
||||
${JAVALIBDIR}/commons-collections.jar:java/apache-commons-collections
|
||||
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
|
||||
${JAVALIBDIR}/commons-collections.jar:java/apache-commons-collections
|
||||
|
||||
USES= dos2unix
|
||||
USE_JAVA= yes
|
||||
USE_ANT= yes
|
||||
DOS2UNIX_FILES= build.xml
|
||||
ALL_TARGET= dist
|
||||
MAKE_ARGS+= -Dcommons-collections.jar=${JAVALIBDIR}/commons-collections.jar \
|
||||
-Dcommons-logging.jar=${JAVALIBDIR}/commons-logging.jar
|
||||
|
||||
JARFILE= ${PORTNAME}.jar
|
||||
PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
APIDOCS= api
|
||||
OTHERDOCS= LICENSE.txt NOTICE.txt RELEASE-NOTES.txt
|
||||
PORTDOCS= ${APIDOCS} ${OTHERDOCS}
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}-${PORTVERSION}.jar ${STAGEDIR}${JAVALIBDIR}/${JARFILE}
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
cd ${WRKSRC}/dist/docs \
|
||||
&& ${FIND} ${APIDOCS} -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/{} \; \
|
||||
&& ${FIND} ${APIDOCS} -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
|
||||
${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (commons-beanutils-1.9.2-src.tar.gz) = 91fccad3b65f278bad98df1aa8467f2d3df6095f41b2db39d2c12863fb2c0049
|
||||
SIZE (commons-beanutils-1.9.2-src.tar.gz) = 396910
|
@ -1,11 +0,0 @@
|
||||
--- build.xml.orig
|
||||
+++ build.xml
|
||||
@@ -212,8 +212,6 @@
|
||||
todir="${dist.home}"/>
|
||||
<copy file="RELEASE-NOTES.txt"
|
||||
todir="${dist.home}"/>
|
||||
- <copy file="README.txt"
|
||||
- todir="${dist.home}"/>
|
||||
<antcall target="jar"/>
|
||||
</target>
|
||||
|
@ -1,5 +0,0 @@
|
||||
JavaBeans utility library. It provides wrappers around getters
|
||||
and setters for a property in an object for classes that conform
|
||||
to the JavaBeans naming standard.
|
||||
|
||||
WWW: http://jakarta.apache.org/commons/beanutils/
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= scilab
|
||||
PORTVERSION= 5.5.2
|
||||
PORTREVISION= 23
|
||||
PORTREVISION= 24
|
||||
CATEGORIES= math cad java
|
||||
MASTER_SITES= https://www.scilab.org/download/${PORTVERSION}/
|
||||
DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX}
|
||||
@ -82,7 +82,7 @@ _GUI_DEPENDS+= ${LOCALBASE}/share/java/fop/build/fop.jar:textproc/fop \
|
||||
${JAVALIBDIR}/commons-io.jar:devel/apache-commons-io \
|
||||
${JAVALIBDIR}/xmlgraphics-commons.jar:graphics/xmlgraphics-commons
|
||||
# Code quality:
|
||||
_GUI_DEPENDS+= ${JAVALIBDIR}/commons-beanutils.jar:java/jakarta-commons-beanutils \
|
||||
_GUI_DEPENDS+= ${JAVALIBDIR}/commons-beanutils.jar:java/apache-commons-beanutils \
|
||||
${JAVALIBDIR}/antlr.jar:devel/antlr \
|
||||
${JAVALIBDIR}/junit4.jar:java/junit \
|
||||
${LOCALBASE}/bin/splint:devel/splint
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= commons-digester
|
||||
PORTVERSION= 2.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= textproc java devel
|
||||
MASTER_SITES= APACHE_COMMONS_BINARIES
|
||||
PKGNAMEPREFIX= apache-
|
||||
@ -24,7 +24,7 @@ NO_ARCH= yes
|
||||
USE_JAVA= yes
|
||||
|
||||
JARFILE= ${PORTNAME}.jar
|
||||
PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
|
||||
PLIST_FILES= ${JAVAJARDIR}/${JARFILE}
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
@ -33,7 +33,7 @@ PORTDOCS= *
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
JAR_DEPENDS= ${JAVALIBDIR}/commons-beanutils.jar:java/jakarta-commons-beanutils \
|
||||
JAR_DEPENDS= ${JAVALIBDIR}/commons-beanutils.jar:java/apache-commons-beanutils \
|
||||
${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
|
||||
${JAVALIBDIR}/commons-collections.jar:java/apache-commons-collections \
|
||||
${JAVALIBDIR}/xercesImpl.jar:textproc/xerces-j
|
||||
|
Loading…
Reference in New Issue
Block a user