Add ace+tao ,

The ADAPTIVE Communication Environment (ACE) is an
object-oriented (OO) toolkit that implements fundamental design
patterns for communication software.  ACE provides a rich set
of reusable C++ wrappers and frameworks that perform common
communication software tasks across a range of OS platforms.

TAO is a freely available, open-source implementation of a
CORBA 2.x-compliant ORB that supports real-time extensions.

WWW: http://www.cs.wustl.edu/~schmidt/ACE.html
WWW: http://www.cs.wustl.edu/~schmidt/TAO.html

PR:		60634
Submitted by:	Sergey Matveychuk <sem@ciam.ru>
This commit is contained in:
Kirill Ponomarev 2003-12-27 23:47:14 +00:00
parent c9f4bc9773
commit 87f43fa80f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=96710
14 changed files with 6032 additions and 0 deletions

View File

@ -9,6 +9,7 @@
SUBDIR += a2dev
SUBDIR += aap
SUBDIR += ac-archive
SUBDIR += ace+tao
SUBDIR += acpicatools
SUBDIR += activitymail
SUBDIR += adabindx

182
devel/ace+tao/Makefile Normal file
View File

@ -0,0 +1,182 @@
# Ports collection makefile for: ace+tao
# Date created: 26 November 2003
# Whom: Sergey Matveychuk <sem@ciam.ru>
#
# $FreeBSD$
#
PORTNAME= ace+tao
PORTVERSION= ${ACE_VERSION}+${TAO_VERSION}
CATEGORIES= devel
# The distfile does not have version numbers, so try my mirror first
MASTER_SITES= http://deuce.doc.wustl.edu/ \
http://www.ciam.ru/~sem/FreeBSD/ \
http://www.navicon.dk/mirrors/ace/deuce.doc.wustl.edu/
DISTNAME= ${PORTNAME:U}
MAINTAINER= sem@ciam.ru
COMMENT= The Adaptive Communication Environment (ACE) with The ACE ORB (TAO)
ACE_VERSION= 5.3.6
TAO_VERSION= 1.3.6
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
TESTS= "@comment "
.if defined(WITH_TESTS)
USE_PERL5= yes
ACE_TESTS_COOKIE= ${WRKDIR}/.ace_tests_done
TAO_TESTS_COOKIE= ${WRKDIR}/.tao_tests_done
TESTS= ""
.endif
WRKSRC= ${WRKDIR}/ACE_wrappers
ACE_ROOT= ${WRKSRC}
TAO_ROOT= ${ACE_ROOT}/TAO
PLIST_SUB+= TAO=${TAO} TESTS=${TESTS}
.if defined(WITHOUT_TAO)
TAO= "@comment "
PKGNAMESUFFIX= -notao
.endif
.include <bsd.port.pre.mk>
post-patch:
@${SED} -e "s#%%CFLAGS%%#${CFLAGS}#;s#%%PREFIX%%#${PREFIX}#; \
s#%%PTHREAD_CFLAGS%%#${PTHREAD_CFLAGS}#; \
s#%%PTHREAD_LIBS%%#${PTHREAD_LIBS}#" \
${FILESDIR}/platform_macros.GNU > \
${ACE_ROOT}/include/makeinclude/platform_macros.GNU; \
${CP} ${FILESDIR}/config.h ${ACE_ROOT}/ace; \
cd ${TAO_ROOT}/orbsvcs; \
${CHMOD} a-x default.bld; \
${CHMOD} a-x FTRT_Event_Service/Event_Service/*; \
${CHMOD} a-x FTRT_Event_Service/Factory_Service/*; \
${CHMOD} a-x FTRT_Event_Service/Gateway_Service/*; \
${CHMOD} a-x Logging_Service/Event_Logging_Service/*; \
${CHMOD} a-x Logging_Service/Notify_Logging_Service/*; \
${CHMOD} a-x Logging_Service/RTEvent_Logging_Service/*; \
${CHMOD} a-x orbsvcs/*.idl orbsvcs/*.mpc orbsvcs/*.mpb; \
${CHMOD} a-x orbsvcs/FaultTolerance/* orbsvcs/FtRtEvent/ClientORB/*; \
${CHMOD} a-x orbsvcs/FtRtEvent/EventChannel/*; \
${CHMOD} a-x orbsvcs/FtRtEvent/Utils/*
.if !defined(WITH_TESTS)
@${REINPLACE_CMD} -e "21d" ${ACE_ROOT}/Makefile
@${REINPLACE_CMD} -e "24d" ${TAO_ROOT}/Makefile
@${REINPLACE_CMD} -e "48d" ${TAO_ROOT}/orbsvcs/Makefile
.endif
pre-build:
@${ECHO_MSG} "============================================================================"
@${ECHO_MSG} "Use WITHOUT_TAO=yes to build ACE only. It decreases build time for a few hours."
@${ECHO_MSG} "Use WITH_TESTS=yes to build ACE+TAO tests. (You need \`make clean' first)."
@${ECHO_MSG} " You'll able \`make WITH_TESTS=yes test' then."
@${ECHO_MSG} "============================================================================"
do-build:
@${ECHO_MSG} "===> Building ACE"; \
${GMAKE} -C ${ACE_ROOT} ACE_ROOT=${ACE_ROOT}
.if defined(WITH_TESTS)
@${TOUCH} ${TOUCH_FLAGS} ${ACE_TESTS_COOKIE}
.endif
.if !defined(WITHOUT_TAO)
@${ECHO_MSG} "===> Building TAO"; \
${GMAKE} -C ${TAO_ROOT} ACE_ROOT=${ACE_ROOT} TAO_ROOT=${TAO_ROOT}
.if defined(WITH_TESTS)
@${TOUCH} ${TOUCH_FLAGS} ${TAO_TESTS_COOKIE}
.endif
.endif
@${ECHO_MSG} ""
@${ECHO_MSG} "===> Build done."
.if defined(WITH_TESTS)
@${ECHO_MSG} " You can run tests now with \`make WITH_TESTS=yes test'"
.endif
@${ECHO_MSG} ""
test:
.if defined(WITH_TESTS)
.if ${OSVERSION} >= 500036
/sbin/kldload aio || ${TRUE}
.endif
@if [ -f ${ACE_TESTS_COOKIE} ]; then \
${ECHO_MSG} "===> Running tests."; \
${ECHO_MSG} "===> ACE tests:"; \
cd ${ACE_ROOT}/tests; ./run_test.pl; \
if [ -f ${TAO_TESTS_COOKIE} ]; then \
${ECHO_MSG} "===> TAO tests:"; \
${ECHO_MSG} " NOT IMPLEMENTED YET. Run them with:"; \
${ECHO_MSG} "cd ${TAO_ROOT}/tests"; \
${ECHO_MSG} "${FIND} . -name run_test.pl -execdir run_test.pl \;"; \
${ECHO_MSG} "===>TAO/orbsvcs tests:"; \
${ECHO_MSG} " NOT IMPLEMENTED YET. Run them with:"; \
${ECHO_MSG} "cd ${TAO_ROOT}/orbsvcs/tests"; \
${ECHO_MSG} "${FIND} . -name run_test.pl -execdir run_test.pl \;"; \
fi; \
${ECHO_MSG} "===> Tests done."; \
else \
${ECHO_MSG} "===> Tests was not build"; \
${ECHO_MSG} " To build tests use \`make WITH_TESTS=yes clean build'"; \
${ECHO_MSG} ""; \
fi
.else
@${ECHO_MSG} ""; \
${ECHO_MSG} "Run tests with \`make WITH_TESTS=yes test'"; \
${ECHO_MSG} ""
.endif
do-install:
@${ECHO_MSG} "Installing ACE headers into ${PREFIX}/include/ace"; \
${MKDIR} ${PREFIX}/include/ace || ${TRUE}; cd ${ACE_ROOT}; \
${FIND} ace -type f \( -name "*.h" -o -name "*.i" -o -name "*.inl" \
-o -name "*.cpp" \) -not -name "config-*.h" -exec \
${INSTALL_DATA} \{\} ${PREFIX}/include/ace/ \;
.if !defined(WITHOUT_TAO)
@${ECHO_MSG} "Installing TAO headers into ${PREFIX}/include/tao"; \
${MKDIR} ${PREFIX}/include/tao || ${TRUE}; cd ${TAO_ROOT}; \
${FIND} tao -type f \( -name "*.h" -o -name "*.i" -o -name "*.inl" \
-o -name "*.idl" -o -name "*.pidl" -o -name "*.cpp" \) -exec \
${INSTALL_DATA} \{\} ${PREFIX}/include/tao \;
@${MKDIR} ${PREFIX}/include/orbsvcs || ${TRUE}; \
cd ${TAO_ROOT}/orbsvcs; \
${FIND} orbsvcs -type f \( -name "*.h" -o -name "*.i" -o -name "*.inl" \
-o -name "*.idl" -o -name "*.pidl" -o -name "*.cpp" \) -exec \
${INSTALL_DATA} \{\} ${PREFIX}/include/orbsvcs \;
.endif
@${ECHO_MSG} "Installing libraries into ${PREFIX}/lib"; \
cd ${ACE_ROOT}/ace; \
${FIND} . -maxdepth 1 -name "lib*.so" -not -name "*Test*" \
-exec ${INSTALL_DATA} \{\} ${PREFIX}/lib \;
@${ECHO_MSG} "Installing executables into ${PREFIX}/bin"; \
${INSTALL_PROGRAM} ${ACE_ROOT}/bin/gperf ${PREFIX}/bin
.if !defined(WITHOUT_TAO)
@cd ${TAO_ROOT}; \
for f in `${FIND} orbsvcs -type f -perm +a+x -not -name "lib*" | \
${GREP} -v test | ${GREP} -v FTRT_Event_Service`; do \
${INSTALL_PROGRAM} $${f} ${PREFIX}/bin; \
done; \
for f in `find utils -type f -perm +a+x`; do \
${INSTALL_PROGRAM} $${f} ${PREFIX}/bin; \
done; \
for f in `${FIND} orbsvcs/FTRT_Event_Service -type f -perm +a+x`; do \
${INSTALL_SCRIPT} $${f} ${PREFIX}/bin; \
done; \
${INSTALL_PROGRAM} TAO_IDL/tao_idl ${PREFIX}/bin
.endif
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "Installing documentation into ${DOCSDIR}"; \
${MKDIR} ${DOCSDIR}/ACE; \
cd ${ACE_ROOT}/docs; ${TAR} cf - . | ${TAR} xUCf ${DOCSDIR}/ACE -
.if !defined(WITHOUT_TAO)
@${MKDIR} ${DOCSDIR}/TAO; \
cd ${TAO_ROOT}/docs; ${TAR} cf - . | ${TAR} xUCf ${DOCSDIR}/TAO -
.endif
.endif
.include <bsd.port.post.mk>

1
devel/ace+tao/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (ACE+TAO.tar.bz2) = d57ccf34fb5185f25518bea531dace08

View File

@ -0,0 +1,231 @@
/* -*- C++ -*- */
// config-freebsd.h,v 4.48 2003/08/09 04:43:51 dhinton Exp
// The following configuration file is designed to work for FreeBSD
#ifndef ACE_CONFIG_H
#define ACE_CONFIG_H
#include /**/ "ace/pre.h"
#if !defined (ACE_MT_SAFE)
# define ACE_MT_SAFE 1
#endif
#if ACE_MT_SAFE
// Yes, we do have threads.
# define ACE_HAS_THREADS 1
#else
// Set to 0 since that's what config-posix.h checks for.
# define ACE_HAS_THREADS 0
#endif /* ACE_MT_SAFE */
#include "ace/config-posix.h"
#include <osreldate.h>
// Make sure we source in the OS version.
#if ! defined (__ACE_INLINE__)
#define __ACE_INLINE__
#endif /* ! __ACE_INLINE__ */
#define ACE_SIZEOF_LONG_DOUBLE 12
#if defined (__GNUG__)
# include "ace/config-g++-common.h"
#endif /* __GNUG__ */
#if defined (ACE_HAS_PENTIUM)
# undef ACE_HAS_PENTIUM
#endif /* ACE_HAS_PENTIUM */
// Platform specific directives
// gcc defines __FreeBSD__ automatically for us.
#ifdef ACE_HAS_THREADS
#if !defined (_THREAD_SAFE)
#define _THREAD_SAFE
#endif /* _THREAD_SAFE */
#endif
#define ACE_HAS_GPERF
#define ACE_HAS_ALT_CUSERID
#define ACE_HAS_RECURSIVE_THR_EXIT_SEMANTICS
#define ACE_HAS_SIG_MACROS
// Optimize ACE_Handle_Set for select().
#define ACE_HAS_HANDLE_SET_OPTIMIZED_FOR_SELECT
#define ACE_HAS_NONCONST_SELECT_TIMEVAL
#define ACE_HAS_CHARPTR_DL
#define ACE_NEEDS_SCHED_H
// Use of <malloc.h> is deprecated.
#define ACE_LACKS_MALLOC_H
// This won't be necessary after it is fixed in the system include headers.
extern "C" { char * cuserid (char *s); }
// Platform supports POSIX timers via struct timespec.
#define ACE_HAS_POSIX_TIME
#define ACE_HAS_UALARM
// Platform defines struct timespec but not timespec_t
#define ACE_LACKS_TIMESPEC_T
#define ACE_LACKS_SYSTIME_H
#if (__FreeBSD_version < 501000)
#define ACE_LACKS_STDINT_H
#endif
#define ACE_LACKS_STRRECVFD
#define ACE_HAS_SIN_LEN
// Platform supports System V IPC (most versions of UNIX, but not Win32)
#define ACE_HAS_SYSV_IPC
// Compiler/platform contains the <sys/syscall.h> file.
#define ACE_HAS_SYSCALL_H
#define ACE_HAS_SIGINFO_T
#define ACE_HAS_REENTRANT_FUNCTIONS
#define ACE_LACKS_NETDB_REENTRANT_FUNCTIONS
#define ACE_HAS_2_PARAM_ASCTIME_R_AND_CTIME_R
#if (__FreeBSD_version < 501000)
#define ACE_LACKS_PWD_REENTRANT_FUNCTIONS
#endif
#define ACE_HAS_CONSISTENT_SIGNAL_PROTOTYPES
#define ACE_LACKS_SIGINFO_H
#define ACE_LACKS_SI_ADDR
// Compiler/platform supports SVR4 signal typedef
#define ACE_HAS_SVR4_SIGNAL_T
// Compiler/platform supports alloca().
// Although ACE does have alloca() on this compiler/platform combination, it is
// disabled by default since it can be dangerous. Uncomment the following line
// if you ACE to use it.
//#define ACE_HAS_ALLOCA
// Compiler/platform supports SVR4 dynamic linking semantics..
#define ACE_HAS_SVR4_DYNAMIC_LINKING
// Compiler/platform correctly calls init()/fini() for shared libraries.
#define ACE_HAS_AUTOMATIC_INIT_FINI
// Explicit dynamic linking permits "lazy" symbol resolution
#define ACE_HAS_RTLD_LAZY_V
// platform supports POSIX O_NONBLOCK semantics
#define ACE_HAS_POSIX_NONBLOCK
// platform supports IP multicast
#define ACE_HAS_IP_MULTICAST
// Lacks perfect filtering, must bind group address.
#if !defined ACE_LACKS_PERFECT_MULTICAST_FILTERING
# define ACE_LACKS_PERFECT_MULTICAST_FILTERING 1
#endif /* ACE_LACKS_PERFECT_MULTICAST_FILTERING */
// Compiler/platform has <alloca.h>
//#define ACE_HAS_ALLOCA_H
// Compiler/platform has the getrusage() system call.
#define ACE_HAS_GETRUSAGE
// Compiler/platform defines the sig_atomic_t typedef.
#define ACE_HAS_SIG_ATOMIC_T
// Compiler/platform supports sys_siglist array.
// *** This refers to (_sys_siglist) instead of (sys_siglist)
// #define ACE_HAS_SYS_SIGLIST
// Compiler/platform defines a union semun for SysV shared memory.
#define ACE_HAS_SEMUN
// Compiler supports the ssize_t typedef.
#define ACE_HAS_SSIZE_T
// Compiler/platform supports strerror ().
#define ACE_HAS_STRERROR
// Compiler/platform provides the sockio.h file.
#define ACE_HAS_SOCKIO_H
// Defines the page size of the system.
#define ACE_PAGE_SIZE 4096
// Platform provides <sys/filio.h> header.
#define ACE_HAS_SYS_FILIO_H
// Compiler/platform supports SVR4 gettimeofday() prototype
#define ACE_HAS_SUNOS4_GETTIMEOFDAY
// #define ACE_HAS_TIMEZONE_GETTIMEOFDAY
// Turns off the tracing feature.
#if !defined (ACE_NTRACE)
#define ACE_NTRACE 1
#endif /* ACE_NTRACE */
#define ACE_HAS_MSG
#define ACE_HAS_4_4BSD_SENDMSG_RECVMSG
#if (__FreeBSD_version < 500100)
# define ACE_HAS_NONCONST_MSGSND
#endif
// Thread specific settings
// Yes, we do have threads.
#ifdef ACE_HAS_THREADS
#if !defined (ACE_MT_SAFE)
# define ACE_MT_SAFE 1
#endif /* ! ACE_MT_SAFE */
#endif /* ACE_HAS_THREADS */
#define ACE_LACKS_THREAD_PROCESS_SCOPING
#define ACE_LACKS_CONDATTR_PSHARED
#define ACE_LACKS_MUTEXATTR_PSHARED
#define ACE_HAS_THREAD_SPECIFIC_STORAGE
#define ACE_HAS_DIRENT
#define ACE_HAS_SIGWAIT
#define ACE_HAS_TERM_IOCTLS
#define ACE_USES_NEW_TERMIOS_STRUCT
#define TCGETS TIOCGETA
#define TCSETS TIOCSETA
#define ACE_HAS_UCONTEXT_T
#define ACE_HAS_SOCKLEN_T
#define ACE_HAS_GETIFADDRS
#define ACE_HAS_PTHREADS_UNIX98_EXT
#ifndef ACE_HAS_SNPRINTF
#define ACE_HAS_SNPRINTF
#endif
// Note, on FreeBSD 5, POSIX aio is now an optional kernel module which
// must be loaded.
// Read the aio(4) man page for what to do, otherwise any aio_* call
// will coredump.
// By default use Proactor which does not use POSIX Real-time Signals
#ifdef ACE_HAS_AIO_CALLS
#ifndef ACE_POSIX_AIOCB_PROACTOR
#define ACE_POSIX_AIOCB_PROACTOR
#endif /* ACE_POSIX_AIOCB_PROACTOR */
#endif /* ACE_HAS_AIO_CALLS */
/* FreeBSD does not define sigval_t */
#include <sys/signal.h>
typedef union sigval sigval_t;
#define ACE_LACKS_STROPTS_H
#include /**/ "ace/post.h"
#endif /* ACE_CONFIG_H */

View File

@ -0,0 +1,19 @@
--- TAO/orbsvcs/Concurrency_Service/Makefile.orig Thu Nov 20 05:16:49 2003
+++ TAO/orbsvcs/Concurrency_Service/Makefile Wed Dec 24 20:46:35 2003
@@ -17,6 +17,8 @@
BIN2 = Concurrency_Service
+include $(ACE_ROOT)/include/makeinclude/wrapper_macros.GNU
+
#### If the TAO orbsvcs library wasn't built with sufficient components,
#### don't try to build here.
TAO_ORBSVCS := $(shell sh $(ACE_ROOT)/bin/ace_components --orbsvcs)
@@ -30,7 +32,6 @@
# Include macros and targets
#----------------------------------------------------------------------------
-include $(ACE_ROOT)/include/makeinclude/wrapper_macros.GNU
include $(ACE_ROOT)/include/makeinclude/macros.GNU
include $(TAO_ROOT)/rules.tao.GNU
include $(ACE_ROOT)/include/makeinclude/rules.common.GNU

View File

@ -0,0 +1,11 @@
--- TAO/orbsvcs/Scheduling_Service/Makefile.orig Wed Dec 24 18:22:37 2003
+++ TAO/orbsvcs/Scheduling_Service/Makefile Wed Dec 24 18:23:02 2003
@@ -15,7 +15,7 @@
#### If the TAO orbsvcs library wasn't built with sufficient components,
#### don't try to build here.
TAO_ORBSVCS := $(shell sh $(ACE_ROOT)/bin/ace_components --orbsvcs)
-ifeq (RtSched,$(findstring RTSched,$(TAO_ORBSVCS)))
+ifeq (RTSched,$(findstring RTSched,$(TAO_ORBSVCS)))
BIN = $(BIN2)
endif # Sched

View File

@ -0,0 +1,19 @@
--- TAO/orbsvcs/Time_Service/Makefile.orig Thu Nov 20 05:16:49 2003
+++ TAO/orbsvcs/Time_Service/Makefile Wed Dec 24 20:47:48 2003
@@ -30,6 +30,8 @@
BIN2 = Time_Service_Server \
Time_Service_Clerk
+include $(ACE_ROOT)/include/makeinclude/wrapper_macros.GNU
+
#### If the TAO orbsvcs library wasn't built with sufficient components,
#### don't try to build here.
TAO_ORBSVCS := $(shell sh $(ACE_ROOT)/bin/ace_components --orbsvcs)
@@ -43,7 +45,6 @@
# Include macros and targets
#----------------------------------------------------------------------------
-include $(ACE_ROOT)/include/makeinclude/wrapper_macros.GNU
include $(ACE_ROOT)/include/makeinclude/macros.GNU
include $(TAO_ROOT)/rules.tao.GNU
include $(ACE_ROOT)/include/makeinclude/rules.common.GNU

View File

@ -0,0 +1,11 @@
--- Makefile.orig Tue Dec 2 10:18:36 2003
+++ Makefile Tue Dec 2 10:18:52 2003
@@ -20,8 +20,6 @@
netsvcs \
tests \
apps \
- examples \
- performance-tests \
websvcs \
Kokyu

View File

@ -0,0 +1,14 @@
--- TAO/Makefile.orig Fri Jun 13 22:12:42 2003
+++ TAO/Makefile Fri Dec 5 10:34:27 2003
@@ -23,10 +23,7 @@
TAO_IDL \
tests \
orbsvcs \
- examples \
- performance-tests \
- utils \
- docs/tutorials/Quoter
+ utils
CLONE = Makefile \
tao \

View File

@ -0,0 +1,16 @@
--- TAO/orbsvcs/Makefile.orig Sat Dec 6 10:13:59 2003
+++ TAO/orbsvcs/Makefile Sat Dec 6 10:14:28 2003
@@ -43,10 +43,9 @@
Trading_Service \
LoadBalancer \
TAO_Service \
- PSS \
- tests \
- performance-tests \
- examples
+ PSS
+
+DIRS += tests
ifeq ($(minimum_corba),0)
ifneq (Compilers 4.2,$(findstring Compilers 4.2,$(CC_VERSION)))

View File

@ -0,0 +1,100 @@
--- tests/run_test.pl.orig Tue Dec 2 08:49:53 2003
+++ tests/run_test.pl Tue Dec 2 10:05:36 2003
@@ -100,7 +100,7 @@
my $program = shift;
unlink <log/$program*.log>;
- unlink "core";
+ unlink "$program.core";
my $P = new PerlACE::Process ($program);
@@ -121,9 +121,11 @@
print STDERR "Error: $program FAILED (time out)\n";
$P->Kill ();
$P->TimedWait (1);
+ $failed_tests{$program}++;
}
elsif ($status != 0) {
print STDERR "Error: $program FAILED with exit status $status\n";
+ $failed_tests{$program}++;
}
check_log ($program);
@@ -179,13 +181,15 @@
local $log = "log/".$program.".log";
- if (-e "core") {
+ if (-e "$program.core") {
print STDERR "Error: $program dumped core\n";
- unlink "core";
+ unlink "$program.core";
+ $failed_tests{$program}++;
}
if (! -e $log ) {
print STDERR "Error: No log file ($log) is present\n";
+ $failed_tests{$program}++;
}
else {
if (open (LOG, "<".$log) == 0) {
@@ -222,11 +226,13 @@
if ($starting_matched == 0) {
print STDERR "Error ($log): no line with 'starting'\n";
$print_log = 1;
+ $failed_tests{$program}++;
}
if ($ending_matched == 0) {
print STDERR "Error ($log): no line with 'Ending'\n";
$print_log = 1;
+ $failed_tests{$program}++;
}
if ($print_log == 1) {
@@ -240,6 +246,7 @@
close (LOG);
}
print STDERR "======= End Log File \n";
+ $failed_tests{$program}++;
}
# Now check for any sub-logs. If either the main log or a
@@ -278,6 +285,7 @@
close (LOG);
}
print STDERR "======= End Sublog File \n";
+ $failed_tests{$program}++;
}
}
}
@@ -379,6 +387,9 @@
"# % ./run_tests.check log/*.log\n\n";
}
+%failed_tests=();
+$total=0;
+
foreach $test (@tests) {
if (defined $opt_d) {
print "Would run test $test now\n";
@@ -391,9 +402,18 @@
}
else {
run_program ($test);
+ $total++;
}
}
check_resources ($oh) if (!defined $opt_d);
delete_temp_files ();
+
+print "=====================================================================\n";
+print "Total test runned: $total\n";
+print "Successed: ", $total-scalar (keys %failed_tests), "\n";
+print "Failed: ", scalar (keys %failed_tests), " :\n";
+foreach (sort keys %failed_tests) {
+ print " $_\n";
+}

View File

@ -0,0 +1,59 @@
# platform_freebsd.GNU,v 4.21 2003/08/09 04:43:51 dhinton Exp
# platform_freebsd.GNU
VERSION := $(shell uname -r | sed -e "s/`uname -r | sed -e 's/.//'`//")
ifeq ($(VERSION),2)
versioned_so = 1
endif
ifndef exceptions
exceptions = 1
endif
ifeq (,$(threads))
threads = 1
endif
ifeq (,$(debug))
debug = 0
endif
ifeq (,$(optimize))
optimize = 1
endif
ssl=1
interface_repo=1
corba_messaging=1
CC = gcc
CXX = g++
CFLAGS += %%CFLAGS%%
DCFLAGS += -g
ifneq ($(VERSION),3)
LDFLAGS += -Wl,-rpath $(ACE_ROOT)/ace
endif
DLD = $(CXX)
LD = $(CXX)
PIC = -fpic
AR = ar
ARFLAGS = ruv
RANLIB = ranlib
SOFLAGS += $(CPPFLAGS) -shared
SOBUILD = $(COMPILE.cc) $(PIC) -o $(VSHDIR)$*.so $<
PRELIB = @echo
ifeq ($(threads),1)
LDFLAGS += %%PTHREAD_LIBS%%
CFLAGS += %%PTHREAD_CFLAGS%%
endif # threads
# Test for template instantiation, add to SOFLAGS if SONAME set,
# add -E to LDFLAGS if using GNU ld
#
include $(ACE_ROOT)/include/makeinclude/platform_g++_common.GNU
CCFLAGS += $(CFLAGS) $(TEMPLATES_FLAG)

11
devel/ace+tao/pkg-descr Normal file
View File

@ -0,0 +1,11 @@
The ADAPTIVE Communication Environment (ACE) is an object-oriented
(OO) toolkit that implements fundamental design patterns for
communication software. ACE provides a rich set of reusable C++
wrappers and frameworks that perform common communication software
tasks across a range of OS platforms.
TAO is a freely available, open-source implementation of a
CORBA 2.x-compliant ORB that supports real-time extensions.
WWW: http://www.cs.wustl.edu/~schmidt/ACE.html
WWW: http://www.cs.wustl.edu/~schmidt/TAO.html

5357
devel/ace+tao/pkg-plist Normal file

File diff suppressed because it is too large Load Diff