add jigdo 0.6.8

An utility used to retrieve very large files over the Internet

PR:		40954
Submitted by:	Attila Nagy <bra@fsn.hu>
This commit is contained in:
Ying-Chieh Liao 2002-09-19 20:17:59 +00:00
parent 15b541c6d5
commit 87e94e4631
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=66741
15 changed files with 349 additions and 0 deletions

View File

@ -26,6 +26,7 @@
SUBDIR += gtm
SUBDIR += hsftp
SUBDIR += jftpgw
SUBDIR += jigdo
SUBDIR += jmirror
SUBDIR += junglemonkey
SUBDIR += kbear

47
ftp/jigdo/Makefile Normal file
View File

@ -0,0 +1,47 @@
# ports collection makefile for: jigdo
# Date created: 23 July 2002
# Whom: Attila Nagy <bra@fsn.hu>
#
# $FreeBSD$
#
PORTNAME= jigdo
PORTVERSION= 0.6.8
CATEGORIES= ftp
MASTER_SITES= http://home.in.tum.de/~atterer/jigdo/
MAINTAINER= bra@fsn.hu
#BUILD_DEPENDS= libwww-config:${PORTSDIR}/www/libwww
RUN_DEPENDS= ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget
MAN1= jigdo-file.1 jigdo-lite.1 jigdo-mirror.1
USE_BZIP2= yes
#USE_REINPLACE= yes
USE_SUBMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-libdb --disable-nls --without-gui
USE_GMAKE= yes
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
MKDIR="${MKDIR}" \
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.jigdo
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
#post-patch:
# @${REINPLACE_CMD} -e "s/gtk-config/${GTK_CONFIG}/g" ${WRKSRC}/configure
post-install:
@${STRIP_CMD} ${PREFIX}/bin/jigdo-file
post-clean:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
.include <bsd.port.mk>

1
ftp/jigdo/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (jigdo-0.6.8.tar.bz2) = 9f9614fa7e01be98e79445f07179c675

View File

@ -0,0 +1,13 @@
--- src/scan.cc.orig Fri Sep 20 03:21:08 2002
+++ src/scan.cc Fri Sep 20 03:21:36 2002
@@ -174,8 +174,8 @@
}
}
#else
-JigdoCache::JigdoCache(const string&, size_t, size_t bufLen = 128*1024,
- ProgressReporter& pr = noReport)
+JigdoCache::JigdoCache(const string&, size_t, size_t bufLen,
+ ProgressReporter& pr)
: blockLength(0), md5BlockLength(0), files(), nrOfFiles(0),
locationPaths(), readAmount(bufLen), buffer(), reporter(pr) { }
#endif

1
ftp/jigdo/pkg-comment Normal file
View File

@ -0,0 +1 @@
An utility used to retrieve very large files over the Internet

24
ftp/jigdo/pkg-descr Normal file
View File

@ -0,0 +1,24 @@
This is a port of Jigsaw Download (AKA jigdo) which is a tool designed to
ease the distribution of very large files over the Internet, for example
CD or DVD images.
Main features:
- The large images does not need to be stored on the server, instead only
the small files contained in the images (works with CD, DVD images,
uncompressed zip files, tar archives...)
- In spite of the above, jigdo creates a bit-exact copy of the image on the
user's machine (to achieve this, the directory data, boot block, etc. of
the image is stored in a special .template file which is distributes
alongside the .jigdo file)
- There is full control over where jigdo-lite will download the individual
parts. It is possible to define mirrors, so users can choose the nearest
one.
- jigdo relies on standard HTTP/FTP, no special protocols needed.
- jigdo-lite supports resuming aborted downloads, or continuing the
download with another mirror if the current one is slow.
- It is possible to "upgrade" the CD image, only the changed data will be
downloaded.
WWW: http://www.atterer.net/jigdo/
Attila Nagy <bra@fsn.hu>

16
ftp/jigdo/pkg-plist Normal file
View File

@ -0,0 +1,16 @@
bin/jigdo-file
bin/jigdo-lite
bin/jigdo-mirror
%%SUB_GUI%%bin/jigdo
share/jigdo/debian-mirrors.jigdo
@dirrm share/jigdo
%%SUB_GUI%%share/jigdo/pixmaps/button-cross.xpm
%%SUB_GUI%%share/jigdo/pixmaps/button-pause.xpm
%%SUB_GUI%%share/jigdo/pixmaps/button-play.xpm
%%SUB_GUI%%share/jigdo/pixmaps/jigdo-logo.xpm
%%SUB_GUI%%share/jigdo/pixmaps/new.xpm
%%SUB_GUI%%share/jigdo/pixmaps/preferences.xpm
%%SUB_GUI%%share/jigdo/pixmaps/progress051.xpm
%%SUB_GUI%%share/jigdo/pixmaps/quit.xpm
%%SUB_GUI%%share/jigdo/COPYING
%%SUB_GUI%%@dirrm share/jigdo/pixmaps

View File

@ -0,0 +1,72 @@
#!/bin/sh
# $FreeBSD$
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"DB3\"
else
/usr/bin/dialog --title "Jigsaw Download configuration options" \
--clear --checklist "\n\
Please select desired options:" -1 -1 16 \
GUI "Graphical User Interface (experimental)" OFF \
DB3 "Berkeley DB3 (used for jigdo-file's cache)" ON \
NLS "Native Language Support (no language files yet)" OFF \
2> $tempfile
retval=$?
if [ -s $tempfile ]; then
set `cat $tempfile`
fi
rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then
echo "Nothing selected"
fi
;;
1) echo "Cancel pressed."
exit 1
;;
esac
fi
${MKDIR} ${WRKDIRPREFIX}${CURDIR}
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
echo "PREFIX= ${PREFIX}"
SUB_GUI="@comment "
while [ "$1" ]; do
case $1 in
\"GUI\")
echo "CONFIGURE_ARGS+= --with-gui"
echo "BUILD_DEPENDS+= gtk12-config:\${PORTSDIR}/x11-toolkits/gtk12"
SUB_GUI=""
;;
\"DB3\")
echo "CONFIGURE_ARGS+= --with-libdb=-ldb3"
echo "CONFIGURE_ENV+= \
CPPFLAGS=\"-I\${LOCALBASE}/include/db3\" \
LIBS=\"-L\${LOCALBASE}/lib\" LDFLAGS=\"-ldb3\""
echo "LIB_DEPENDS= db3:\${PORTSDIR}/databases/db3"
;;
\"NLS\")
echo "CONFIGURE_ARGS+= --enable-nls=/usr/local/include"
;;
*)
echo "Invalid option(s): $*" > /dev/stderr
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
;;
esac
shift
done
echo "PLIST_SUB+= SUB_GUI=\"${SUB_GUI}\""

47
net-p2p/jigdo/Makefile Normal file
View File

@ -0,0 +1,47 @@
# ports collection makefile for: jigdo
# Date created: 23 July 2002
# Whom: Attila Nagy <bra@fsn.hu>
#
# $FreeBSD$
#
PORTNAME= jigdo
PORTVERSION= 0.6.8
CATEGORIES= ftp
MASTER_SITES= http://home.in.tum.de/~atterer/jigdo/
MAINTAINER= bra@fsn.hu
#BUILD_DEPENDS= libwww-config:${PORTSDIR}/www/libwww
RUN_DEPENDS= ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget
MAN1= jigdo-file.1 jigdo-lite.1 jigdo-mirror.1
USE_BZIP2= yes
#USE_REINPLACE= yes
USE_SUBMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-libdb --disable-nls --without-gui
USE_GMAKE= yes
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
MKDIR="${MKDIR}" \
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.jigdo
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
#post-patch:
# @${REINPLACE_CMD} -e "s/gtk-config/${GTK_CONFIG}/g" ${WRKSRC}/configure
post-install:
@${STRIP_CMD} ${PREFIX}/bin/jigdo-file
post-clean:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
.include <bsd.port.mk>

1
net-p2p/jigdo/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (jigdo-0.6.8.tar.bz2) = 9f9614fa7e01be98e79445f07179c675

View File

@ -0,0 +1,13 @@
--- src/scan.cc.orig Fri Sep 20 03:21:08 2002
+++ src/scan.cc Fri Sep 20 03:21:36 2002
@@ -174,8 +174,8 @@
}
}
#else
-JigdoCache::JigdoCache(const string&, size_t, size_t bufLen = 128*1024,
- ProgressReporter& pr = noReport)
+JigdoCache::JigdoCache(const string&, size_t, size_t bufLen,
+ ProgressReporter& pr)
: blockLength(0), md5BlockLength(0), files(), nrOfFiles(0),
locationPaths(), readAmount(bufLen), buffer(), reporter(pr) { }
#endif

View File

@ -0,0 +1 @@
An utility used to retrieve very large files over the Internet

24
net-p2p/jigdo/pkg-descr Normal file
View File

@ -0,0 +1,24 @@
This is a port of Jigsaw Download (AKA jigdo) which is a tool designed to
ease the distribution of very large files over the Internet, for example
CD or DVD images.
Main features:
- The large images does not need to be stored on the server, instead only
the small files contained in the images (works with CD, DVD images,
uncompressed zip files, tar archives...)
- In spite of the above, jigdo creates a bit-exact copy of the image on the
user's machine (to achieve this, the directory data, boot block, etc. of
the image is stored in a special .template file which is distributes
alongside the .jigdo file)
- There is full control over where jigdo-lite will download the individual
parts. It is possible to define mirrors, so users can choose the nearest
one.
- jigdo relies on standard HTTP/FTP, no special protocols needed.
- jigdo-lite supports resuming aborted downloads, or continuing the
download with another mirror if the current one is slow.
- It is possible to "upgrade" the CD image, only the changed data will be
downloaded.
WWW: http://www.atterer.net/jigdo/
Attila Nagy <bra@fsn.hu>

16
net-p2p/jigdo/pkg-plist Normal file
View File

@ -0,0 +1,16 @@
bin/jigdo-file
bin/jigdo-lite
bin/jigdo-mirror
%%SUB_GUI%%bin/jigdo
share/jigdo/debian-mirrors.jigdo
@dirrm share/jigdo
%%SUB_GUI%%share/jigdo/pixmaps/button-cross.xpm
%%SUB_GUI%%share/jigdo/pixmaps/button-pause.xpm
%%SUB_GUI%%share/jigdo/pixmaps/button-play.xpm
%%SUB_GUI%%share/jigdo/pixmaps/jigdo-logo.xpm
%%SUB_GUI%%share/jigdo/pixmaps/new.xpm
%%SUB_GUI%%share/jigdo/pixmaps/preferences.xpm
%%SUB_GUI%%share/jigdo/pixmaps/progress051.xpm
%%SUB_GUI%%share/jigdo/pixmaps/quit.xpm
%%SUB_GUI%%share/jigdo/COPYING
%%SUB_GUI%%@dirrm share/jigdo/pixmaps

View File

@ -0,0 +1,72 @@
#!/bin/sh
# $FreeBSD$
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"DB3\"
else
/usr/bin/dialog --title "Jigsaw Download configuration options" \
--clear --checklist "\n\
Please select desired options:" -1 -1 16 \
GUI "Graphical User Interface (experimental)" OFF \
DB3 "Berkeley DB3 (used for jigdo-file's cache)" ON \
NLS "Native Language Support (no language files yet)" OFF \
2> $tempfile
retval=$?
if [ -s $tempfile ]; then
set `cat $tempfile`
fi
rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then
echo "Nothing selected"
fi
;;
1) echo "Cancel pressed."
exit 1
;;
esac
fi
${MKDIR} ${WRKDIRPREFIX}${CURDIR}
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
echo "PREFIX= ${PREFIX}"
SUB_GUI="@comment "
while [ "$1" ]; do
case $1 in
\"GUI\")
echo "CONFIGURE_ARGS+= --with-gui"
echo "BUILD_DEPENDS+= gtk12-config:\${PORTSDIR}/x11-toolkits/gtk12"
SUB_GUI=""
;;
\"DB3\")
echo "CONFIGURE_ARGS+= --with-libdb=-ldb3"
echo "CONFIGURE_ENV+= \
CPPFLAGS=\"-I\${LOCALBASE}/include/db3\" \
LIBS=\"-L\${LOCALBASE}/lib\" LDFLAGS=\"-ldb3\""
echo "LIB_DEPENDS= db3:\${PORTSDIR}/databases/db3"
;;
\"NLS\")
echo "CONFIGURE_ARGS+= --enable-nls=/usr/local/include"
;;
*)
echo "Invalid option(s): $*" > /dev/stderr
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
;;
esac
shift
done
echo "PLIST_SUB+= SUB_GUI=\"${SUB_GUI}\""