- Correct variable name to fix shared library links

- Bump PORTREVISION for package change
- While I'm here, convert to new LIB_DEPENDS format and support STAGEDIR

PR:		ports/181637
Submitted by:	Gasol Wu <gasol.wu@gmail.com> (maintainer)
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2014-01-06 15:08:43 +00:00
parent f9bdfd8c7c
commit 87dca801f4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=338891
2 changed files with 8 additions and 9 deletions

View File

@ -3,6 +3,7 @@
PORTNAME= inotify
PORTVERSION= 0.1.6
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@ -14,7 +15,7 @@ COMMENT= This extension allows to use inotify functions in a PHP scripts
LICENSE= PHP301
LIB_DEPENDS= inotify:${PORTSDIR}/devel/libinotify
LIB_DEPENDS= libinotify.so:${PORTSDIR}/devel/libinotify
USE_PHP= yes
USE_PHP_BUILD= yes
@ -22,5 +23,4 @@ USE_PHPIZE= yes
USE_PHPEXT= yes
IGNORE_WITH_PHP=4
NO_STAGE= yes
.include <bsd.port.mk>

View File

@ -1,6 +1,6 @@
--- ./config.m4.orig 2012-05-04 17:51:20.000000000 +0800
+++ ./config.m4 2012-06-27 12:05:19.620198000 +0800
@@ -1,22 +1,52 @@
+++ ./config.m4 2013-08-29 12:49:00.000000000 +0800
@@ -1,22 +1,51 @@
dnl $Id: config.m4 262896 2008-07-17 19:11:16Z lbarnaud $
dnl config.m4 for extension inotify
@ -44,8 +44,6 @@
+ AC_MSG_ERROR([Cannot find libevent headers])
+ fi
+
+ PHP_ADD_INCLUDE($LIBINOTIFY_DIR/include)
+
+ LIBNAME=inotify
+ LIBSYMBOL=inotify_init
+
@ -55,13 +53,14 @@
+
+ PHP_CHECK_LIBRARY($LIBNAME,$LIBSYMBOL,
+ [
+ PHP_ADD_LIBRARY_WITH_PATH($LIBNAME, $LIBINOTIFY_DIR/$PHP_LIBDIR, LIBINOTIFY_SHARED_LIBADD)
+ PHP_ADD_INCLUDE($LIBINOTIFY_DIR/include)
+ PHP_ADD_LIBRARY_WITH_PATH($LIBNAME, $LIBINOTIFY_DIR/$PHP_LIBDIR, INOTIFY_SHARED_LIBADD)
+ ],[
+ AC_MSG_ERROR([Your system does not support inotify])
+ ],[
+ -L$LIBINOTIFY_DIR/$PHP_LIBDIR
+ -L$LIBINOTIFY_DIR/$PHP_LIBDIR
])
+ PHP_SUBST(LIBINOTIFY_SHARED_LIBADD)
+ PHP_SUBST(INOTIFY_SHARED_LIBADD)
PHP_NEW_EXTENSION(inotify, inotify.c, $ext_shared)
fi