Upgrade to 0.13.beta.j

This commit is contained in:
Stefan Eßer 2002-02-14 21:47:49 +00:00
parent f4bd1992ed
commit 87ca257abb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54712
8 changed files with 67 additions and 49 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= jftpgw
PORTVERSION= 0.0.13g
PORTVERSION= 0.13.beta.j
CATEGORIES= ftp
MASTER_SITES= http://www.mcknight.de/jftpgw/

View File

@ -1,2 +1,2 @@
MD5 (jftpgw-0.0.13g.tar.gz) = d7ebf061328eac9e4fc557b45a4b0d60
SIZE (jftpgw-0.0.13g.tar.gz) = 207369
MD5 (jftpgw-0.13.beta.j.tar.gz) = c638d6cae6de541ddda6fbc8fdae6246
SIZE (jftpgw-0.13.beta.j.tar.gz) = 220094

View File

@ -1,46 +0,0 @@
--- secsftp_cmds.h~ Thu Apr 26 11:11:56 2001
+++ secsftp_cmds.h Sun Jul 15 13:14:23 2001
@@ -22,25 +22,25 @@
int do_cancel(void);
/* this function is used from the standard command set */
-int std_user(char*, struct conn_info_st*);
+int std_user(const char*, struct conn_info_st*);
-int secsftp_user(char*, struct conn_info_st*);
-int secsftp_pass(char*, struct conn_info_st*);
-int secsftp_quit(char*, struct conn_info_st*);
-int secsftp_noop(char*, struct conn_info_st*);
-int secsftp_pwd (char*, struct conn_info_st*);
-int secsftp_cwd (char*, struct conn_info_st*);
-int secsftp_mkd (char*, struct conn_info_st*);
-int secsftp_rmd (char*, struct conn_info_st*);
-int secsftp_syst(char*, struct conn_info_st*);
-int secsftp_cdup(char*, struct conn_info_st*);
-int secsftp_pasv(char*, struct conn_info_st*);
-int secsftp_port(char*, struct conn_info_st*);
-int secsftp_retr(char*, struct conn_info_st*);
-int secsftp_stor(char*, struct conn_info_st*);
-int secsftp_type(char*, struct conn_info_st*);
-int secsftp_size_mdtm(char*, struct conn_info_st*);
-int secsftp_abor(char*, struct conn_info_st*);
+int secsftp_user(const char*, struct conn_info_st*);
+int secsftp_pass(const char*, struct conn_info_st*);
+int secsftp_quit(const char*, struct conn_info_st*);
+int secsftp_noop(const char*, struct conn_info_st*);
+int secsftp_pwd (const char*, struct conn_info_st*);
+int secsftp_cwd (const char*, struct conn_info_st*);
+int secsftp_mkd (const char*, struct conn_info_st*);
+int secsftp_rmd (const char*, struct conn_info_st*);
+int secsftp_syst(const char*, struct conn_info_st*);
+int secsftp_cdup(const char*, struct conn_info_st*);
+int secsftp_pasv(const char*, struct conn_info_st*);
+int secsftp_port(const char*, struct conn_info_st*);
+int secsftp_retr(const char*, struct conn_info_st*);
+int secsftp_stor(const char*, struct conn_info_st*);
+int secsftp_type(const char*, struct conn_info_st*);
+int secsftp_size_mdtm(const char*, struct conn_info_st*);
+int secsftp_abor(const char*, struct conn_info_st*);
struct cmdhandlerstruct secsftp_cmdhandler[] = {

View File

@ -0,0 +1,12 @@
--- config.h.in~ Thu Feb 14 22:40:52 2002
+++ config.h.in Thu Feb 14 22:42:17 2002
@@ -100,6 +100,9 @@
/* Define if you have the strdup function. */
#undef HAVE_STRDUP
+/* Define if you have the strcasestr function. */
+#undef HAVE_STRCASESTR
+
/* Define if you have the strerror function. */
#undef HAVE_STRERROR

View File

@ -0,0 +1,11 @@
--- configure~ Sun Feb 3 12:20:16 2002
+++ configure Thu Feb 14 22:27:32 2002
@@ -1861,7 +1861,7 @@
fi
-for ac_func in getcwd strdup seteuid setegid
+for ac_func in getcwd strdup strcasestr seteuid setegid
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
echo "configure:1868: checking for $ac_func" >&5

View File

@ -0,0 +1,11 @@
--- configure.in~ Sun Feb 3 01:25:28 2002
+++ configure.in Thu Feb 14 22:21:33 2002
@@ -49,7 +49,7 @@
dnl Checks for library functions.
AC_FUNC_WAIT3
-AC_CHECK_FUNCS(getcwd strdup seteuid setegid)
+AC_CHECK_FUNCS(getcwd strdup strcasestr seteuid setegid)
dnl From icecast
AC_MSG_CHECKING([for unix98 socklen_t])

View File

@ -0,0 +1,12 @@
--- jftpgw.h~ Sat Feb 2 19:11:30 2002
+++ jftpgw.h Thu Feb 14 22:29:34 2002
@@ -360,7 +360,9 @@
char* char_append(const char*, const char*);
char* char_enclose(const char*, const char*, const char*);
char* strnulldup(const char*);
+#ifndef HAVE_STRCASESTR
const char* strcasestr(const char* haystack, const char* needle);
+#endif
/* from config.c */
int config_read_options(FILE*);

View File

@ -0,0 +1,18 @@
--- util.c~ Sun Feb 3 10:10:54 2002
+++ util.c Thu Feb 14 22:30:36 2002
@@ -91,6 +91,7 @@
}
+#ifndef HAVE_STRCASESTR
const char* strcasestr(const char* haystack, const char* needle) {
char* nhay = strdup(haystack);
char* nneed = strdup(needle);
@@ -121,6 +122,7 @@
return match;
}
+#endif
/* writes a char* to an fd and checks the return value */