Update to 0.5.25

- Allow concurrent installation (USE_PYTHON=concurrent)

Changes:	https://github.com/kayhayen/Nuitka/blob/develop/Changelog.rst
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2017-01-28 20:52:50 +00:00
parent 82e153ad98
commit 879c0141b2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=432664
3 changed files with 11 additions and 13 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nuitka
PORTVERSION= 0.5.24.4
PORTVERSION= 0.5.25
CATEGORIES= devel python
MASTER_SITES= http://nuitka.net/releases/
DISTNAME= Nuitka-${PORTVERSION}
@ -14,6 +14,6 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= python tar:bzip2
USE_PYTHON= autoplist distutils
USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1482515433
SHA256 (Nuitka-0.5.24.4.tar.bz2) = ebeda4fe6efab02ac330222caaad7cfdd56b596e850c8e6dcaec292256c2c277
SIZE (Nuitka-0.5.24.4.tar.bz2) = 1224571
TIMESTAMP = 1485609147
SHA256 (Nuitka-0.5.25.tar.bz2) = e1c0944e9941aa43804441f9b024bf2a308be399d6c7882577a8ce966f31ffb9
SIZE (Nuitka-0.5.25.tar.bz2) = 1234400

View File

@ -1,20 +1,18 @@
--- nuitka/build/SingleExe.scons.orig 2016-12-10 11:05:24 UTC
--- nuitka/build/SingleExe.scons.orig 2017-01-24 05:15:25 UTC
+++ nuitka/build/SingleExe.scons
@@ -108,9 +108,11 @@ uninstalled_python = getBoolOption("unin
@@ -109,9 +109,9 @@ uninstalled_python = getBoolOption("unin
# Unstriped mode: Do not remove debug symbols.
unstripped_mode = getBoolOption("unstripped_mode", False)
-# Clang compiler mode, default on MacOS X and FreeBSD, optional on Linux.
+# Clang compiler mode, default on MacOS X and FreeBSD (unless PowerPC),
+# optional on Linux.
-# Clang compiler mode, forced on MacOS X and FreeBSD, optional on Linux.
+# Clang compiler mode, forced on MacOS X and FreeBSD (unless PowerPC), optional on Linux.
clang_mode = getBoolOption("clang_mode", False)
-if sys.platform == "darwin" or "freebsd" in sys.platform:
+if sys.platform == "darwin" or ("freebsd" in sys.platform and
+ platform.machine() != "powerpc"):
+if sys.platform == "darwin" or ("freebsd" in sys.platform and platform.machine() != "powerpc"):
clang_mode = True
# MinGW compiler mode, optional and interesting to Windows only.
@@ -618,11 +620,11 @@ if gcc_mode and "clang" not in the_compi
@@ -624,11 +624,11 @@ if gcc_mode and "clang" not in the_compi
# binary if it's not high enough. This is esp. useful under Debian which
# allows all compiler to exist next to each other and where g++ might not be
# good enough, but g++-4.5 would be.