Remove acorn, acron-media, uclient. code is now unmaintained and broken for
long time. PR: ports/39150 Submitted by: maintainer
This commit is contained in:
parent
b7c60f7ebf
commit
878fb0cd66
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62067
@ -12,8 +12,6 @@
|
||||
SUBDIR += abuse
|
||||
SUBDIR += abuse_sdl
|
||||
SUBDIR += acm
|
||||
SUBDIR += acorn
|
||||
SUBDIR += acorn-media
|
||||
SUBDIR += actx
|
||||
SUBDIR += adgali
|
||||
SUBDIR += adom
|
||||
@ -286,7 +284,6 @@
|
||||
SUBDIR += tuxtype
|
||||
SUBDIR += tvp
|
||||
SUBDIR += twitch
|
||||
SUBDIR += uclient
|
||||
SUBDIR += uox3
|
||||
SUBDIR += utserver
|
||||
SUBDIR += utserver-asu
|
||||
|
@ -1,26 +0,0 @@
|
||||
# New ports collection makefile for: acorn-media
|
||||
# Date created: 29 March 2001
|
||||
# Whom: Oliver Lehmann <lehmann@ans-netz.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= acorn-media
|
||||
PORTVERSION= 0.3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ftp://ftp.ecs.soton.ac.uk/pub/worldforge/acorn/0.3/media/ \
|
||||
http://65.100.132.89/wf/downloads/acorn/0.3/media/ \
|
||||
ftp://two.woovis.com/pub/worldforge/acorn/0.3/media/ \
|
||||
http://dreadnought.res.cmu.edu/worldforge/acorn/0.3/media/
|
||||
DISTNAME= acorn_media2d-0.3
|
||||
|
||||
MAINTAINER= lehmann@ans-netz.de
|
||||
|
||||
NO_BUILD= YES
|
||||
WRKSRC= ${WRKDIR}/media
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/share/forge
|
||||
${CP} -r ${WRKSRC} ${PREFIX}/share/forge
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1 +0,0 @@
|
||||
MD5 (acorn_media2d-0.3.tar.gz) = 7e28e8073c8931f36e8c9a7c2a293e42
|
@ -1 +0,0 @@
|
||||
Libraries needed by games/acorn
|
@ -1,3 +0,0 @@
|
||||
The libraries needed by games/acorn.
|
||||
|
||||
WWW: http://www.worldforge.org/
|
File diff suppressed because it is too large
Load Diff
@ -1,27 +0,0 @@
|
||||
# New ports collection makefile for: acorn
|
||||
# Date created: 29 March 2001
|
||||
# Whom: Oliver Lehmann <lehmann@ans-netz.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= acorn
|
||||
PORTVERSION= 0.3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= # empty
|
||||
DISTFILES= # empty
|
||||
|
||||
MAINTAINER= lehmann@ans-netz.de
|
||||
|
||||
RUN_DEPENDS= ${PREFIX}/include/Atlas:${PORTSDIR}/devel/atlas \
|
||||
${PREFIX}/include/uta:${PORTSDIR}/devel/libuta \
|
||||
${PREFIX}/include/varconf:${PORTSDIR}/devel/varconf \
|
||||
${PREFIX}/share/forge/media:${PORTSDIR}/games/acorn-media \
|
||||
${PREFIX}/bin/uclient:${PORTSDIR}/games/uclient
|
||||
|
||||
EXTRACT_ONLY= # empty
|
||||
NO_BUILD= yes
|
||||
|
||||
do-install: # empty
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1 +0,0 @@
|
||||
A meta-port for the Worldforge Client uclient
|
@ -1,4 +0,0 @@
|
||||
The WorldForge Project is developing a complete system for massively
|
||||
multiplayer online roleplaying games.
|
||||
|
||||
This meta-port installs all required ports.
|
@ -1 +0,0 @@
|
||||
@comment this plist intentionally left empty
|
@ -1,48 +0,0 @@
|
||||
# New ports collection makefile for: uclient
|
||||
# Date created: 29 March 2001
|
||||
# Whom: Oliver Lehmann <lehmann@ans-netz.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= uclient
|
||||
PORTVERSION= 0.10.0
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ftp://ftp.ecs.soton.ac.uk/pub/worldforge/clients/uclient/ \
|
||||
ftp://ftp.ecs.soton.ac.uk/pub/worldforge/acorn/0.3/media/ \
|
||||
http://65.100.132.89/wf/downloads/clients/uclient/ \
|
||||
http://65.100.132.89/wf/downloads/acorn/0.3/media/ \
|
||||
ftp://two.woovis.com/pub/worldforge/clients/uclient/ \
|
||||
ftp://two.woovis.com/pub/worldforge/acorn/0.3/media/ \
|
||||
http://dreadnought.res.cmu.edu/worldforge/clients/uclient/ \
|
||||
http://dreadnought.res.cmu.edu/worldforge/acorn/0.3/media/
|
||||
DISTFILES= uclient-graphics-0.9.2.tar.gz \
|
||||
uclient-sound-0.9.2.tar.gz \
|
||||
${PORTNAME}-${PORTVERSION}-2.tar.gz
|
||||
|
||||
MAINTAINER= lehmann@ans-netz.de
|
||||
|
||||
BROKEN= "Does not find automake"
|
||||
|
||||
LIB_DEPENDS= uta:${PORTSDIR}/devel/libuta \
|
||||
sigc.1:${PORTSDIR}/devel/libsigc++ \
|
||||
xml:${PORTSDIR}/textproc/libxml \
|
||||
Atlas.0:${PORTSDIR}/devel/atlas \
|
||||
varconf.0:${PORTSDIR}/devel/varconf
|
||||
RUN_DEPENDS= ${LOCALBASE}/share/forge/media:${PORTSDIR}/games/acorn-media
|
||||
|
||||
USE_LIBTOOL= YES
|
||||
USE_AUTOMAKE= YES
|
||||
USE_GMAKE= YES
|
||||
USE_NEWGCC= YES
|
||||
WRKSRC= ${WRKDIR}/uclient-0.10.0
|
||||
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} --exec-prefix=${PREFIX}
|
||||
|
||||
CONFIGURE_SCRIPT= autogen.sh
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${PREFIX}/share/forge
|
||||
${CP} -r ${WRKDIR}/share/forge/* ${PREFIX}/share/forge
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,3 +0,0 @@
|
||||
MD5 (uclient-0.10.0-2.tar.gz) = 0030147ae41f834c0ac70fa5e35f6241
|
||||
MD5 (uclient-graphics-0.9.2.tar.gz) = b4317726fba3a1c150b4c19518d6a728
|
||||
MD5 (uclient-sound-0.9.2.tar.gz) = 623fb76ab1e8568241f4ae12cad31e2d
|
@ -1,29 +0,0 @@
|
||||
--- toolbox/ftos.cc.orig Wed Mar 28 02:14:23 2001
|
||||
+++ toolbox/ftos.cc Wed Mar 28 02:19:29 2001
|
||||
@@ -169,6 +169,10 @@
|
||||
// ecvt (double val, size_t ndigit, int *decpt, int *sign);
|
||||
// }
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <stdio.h>
|
||||
+#endif
|
||||
+
|
||||
#include "ftos.h"
|
||||
#include "dtags.h"
|
||||
|
||||
@@ -288,7 +292,14 @@
|
||||
// Get number's string rep, sign, and exponent
|
||||
int sign = 0;
|
||||
int decimal=0;
|
||||
- register char *p = ecvt(val, count, &decimal, &sign);
|
||||
+
|
||||
+#ifdef __FreeBSD__
|
||||
+ register char *p;
|
||||
+ asprintf(&p, "%.0f", val);
|
||||
+#else
|
||||
+ register char *p = ecvt(val, count, &decimal, &sign);
|
||||
+#endif
|
||||
+// register char *p = ecvt(val, count, &decimal, &sign);
|
||||
|
||||
D2TAG("*** string rep is", p);
|
||||
D2TAG("*** decimal is", itos(decimal));
|
@ -1,11 +0,0 @@
|
||||
--- modules/app.cc.orig Wed Mar 28 01:31:18 2001
|
||||
+++ modules/app.cc Wed Mar 28 01:31:29 2001
|
||||
@@ -32,7 +32,7 @@
|
||||
* ... probably fixed in SDL > 1.1.6
|
||||
*/
|
||||
extern "C" {
|
||||
-#include <SDL_version.h>
|
||||
+#include <SDL11/SDL_version.h>
|
||||
}
|
||||
|
||||
#include <varconf/Config.h>
|
@ -1,11 +0,0 @@
|
||||
--- uclient/app.cc.orig Wed Mar 28 01:31:43 2001
|
||||
+++ uclient/app.cc Wed Mar 28 01:31:52 2001
|
||||
@@ -25,7 +25,7 @@
|
||||
#include <uta/debug.h>
|
||||
#include <uta/resources.h>
|
||||
#include <uta/version.h>
|
||||
-#include <SDL_version.h>
|
||||
+#include <SDL11/SDL_version.h>
|
||||
|
||||
using namespace uta;
|
||||
#include "dii/dii.h"
|
@ -1,11 +0,0 @@
|
||||
--- modules/Makefile.in.orig Wed Mar 28 01:37:00 2001
|
||||
+++ modules/Makefile.in Wed Mar 28 01:37:11 2001
|
||||
@@ -118,7 +118,7 @@
|
||||
# Chat_la_LDFLAGS = -dynamic -export-dynamic -module -version-info 0:1:0
|
||||
|
||||
App_la_SOURCES = app.h app.cc
|
||||
-App_la_LDFLAGS = -dynamic -export-dynamic -module -version-info 0:1:0 -lSDL
|
||||
+App_la_LDFLAGS = -dynamic -export-dynamic -module -version-info 0:1:0 -lSDL-1.1 -L/usr/local/lib
|
||||
|
||||
Gui_la_SOURCES = gui.h gui.cc
|
||||
Gui_la_LDFLAGS = -dynamic -export-dynamic -module -version-info 0:1:0
|
@ -1,13 +0,0 @@
|
||||
--- modules/console.h.orig Wed Mar 28 01:59:27 2001
|
||||
+++ modules/console.h Wed Mar 28 01:59:17 2001
|
||||
@@ -30,10 +30,8 @@
|
||||
|
||||
#include <uta/multilineedit.h>
|
||||
|
||||
-#ifdef __WIN32__
|
||||
#undef stdout
|
||||
#undef stderr
|
||||
-#endif
|
||||
|
||||
///
|
||||
class LogWindow : public Screen
|
@ -1,11 +0,0 @@
|
||||
--- macros/autogen.sh.orig Thu Mar 29 18:53:41 2001
|
||||
+++ macros/autogen.sh Thu Mar 29 18:54:03 2001
|
||||
@@ -135,7 +135,7 @@
|
||||
fi
|
||||
done
|
||||
|
||||
-conf_flags="--enable-compile-warnings --enable-debug --enable-maintainer-mode --prefix=/opt/forge"
|
||||
+conf_flags="--enable-compile-warnings --enable-debug --enable-maintainer-mode --prefix=/usr/local --exec-prefix=/usr/local"
|
||||
|
||||
if test x$NOCONFIGURE = x; then
|
||||
# echo Running $srcdir/libltdl/configure $conf_flags --enable-ltdl-install "$@" ...
|
@ -1,6 +0,0 @@
|
||||
--- build_media_index.sh.orig Thu Mar 29 18:54:55 2001
|
||||
+++ build_media_index.sh Thu Mar 29 18:55:52 2001
|
||||
@@ -1,2 +1,2 @@
|
||||
#!/bin/sh
|
||||
-find ./media/ -follow -name "*.png" -type f -fprintf ./media.ind "%f %h/%f\n"
|
||||
+find ./media/ -follow -name "*.png" -type f |sed 's/\(.*\/\([^\/]*\)\)/\2 \1/' >media.ind
|
@ -1,11 +0,0 @@
|
||||
--- modules/Makefile.am.orig Thu Apr 5 17:45:39 2001
|
||||
+++ modules/Makefile.am Thu Apr 5 17:47:13 2001
|
||||
@@ -42,7 +42,7 @@
|
||||
# Chat_la_LDFLAGS = -dynamic -export-dynamic -module -version-info 0:1:0
|
||||
|
||||
App_la_SOURCES = app.h app.cc
|
||||
-App_la_LDFLAGS = -dynamic -export-dynamic -module -version-info 0:1:0 -lSDL
|
||||
+App_la_LDFLAGS = -dynamic -export-dynamic -module -version-info 0:1:0 -lSDL-1.1 -L/usr/local/lib
|
||||
|
||||
Gui_la_SOURCES = gui.h gui.cc
|
||||
Gui_la_LDFLAGS = -dynamic -export-dynamic -module -version-info 0:1:0
|
@ -1 +0,0 @@
|
||||
A 2D isometric WorldForge game client
|
@ -1,4 +0,0 @@
|
||||
UClient is a 2D isometric WorldForge game client,
|
||||
that uses libuta, SDL, and libAtlas-C++.
|
||||
|
||||
WWW: http://www.worldforge.org/website/clients/uclient/
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user