remove imlib2-tmp. now it's in real place(graphics/imlib2).
This commit is contained in:
parent
fe45a29866
commit
87751f1441
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39654
@ -1,47 +0,0 @@
|
||||
# New ports collection makefile for: imlib2
|
||||
# Date created: 16 Oct 2000
|
||||
# Whom: Jeremy Norris <ishmael27@home.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= imlib2
|
||||
PORTVERSION= 1.0.2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= enlightenment
|
||||
|
||||
MAINTAINER= ishmael27@home.com
|
||||
|
||||
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
ungif.5:${PORTSDIR}/graphics/libungif \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
edb.1:${PORTSDIR}/databases/edb
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_FREETYPE= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_MMX) && (${ARCH} == "i386")
|
||||
CONFIGURE_ARGS= --enable-mmx
|
||||
.endif
|
||||
|
||||
post-configure:
|
||||
@${PERL} -pi -e 's|\@localbase\@|${LOCALBASE}|g' ${WRKSRC}/imlib2-config
|
||||
|
||||
post-install:
|
||||
@strip ${PREFIX}/lib/libImlib2.so.1
|
||||
.for i in bump_map colormod testfilter
|
||||
@strip ${PREFIX}/lib/loaders/filter/${i}.so
|
||||
.endfor
|
||||
.for i in argb bmp db gif jpeg png pnm tga tiff xpm
|
||||
@strip ${PREFIX}/lib/loaders/image/${i}.so
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1 +0,0 @@
|
||||
MD5 (imlib2-1.0.2.tar.gz) = fd5e30e22b3fb237ea660070a24a8a85
|
@ -1,11 +0,0 @@
|
||||
--- imlib2-config.in.orig Tue Aug 22 16:38:40 2000
|
||||
+++ imlib2-config.in Sun Oct 29 21:38:09 2000
|
||||
@@ -45,7 +45,7 @@
|
||||
echo $includes @x_cflags@
|
||||
;;
|
||||
--libs)
|
||||
- libdirs=-L@libdir@
|
||||
+ libdirs="-L@libdir@ -L@localbase@/lib"
|
||||
echo $libdirs -lImlib2 -lttf -lm @dlopen_libs@ @x_ldflags@ @x_libs@
|
||||
;;
|
||||
*)
|
@ -1 +0,0 @@
|
||||
The next generation graphic library for enlightenment package
|
@ -1,3 +0,0 @@
|
||||
The next generation graphic library for enlightenment package.
|
||||
|
||||
WWW: http://www.us.rasterman.com/imlib.html
|
@ -1,21 +0,0 @@
|
||||
bin/imlib2-config
|
||||
include/Imlib2.h
|
||||
lib/libImlib2.a
|
||||
lib/libImlib2.so
|
||||
lib/libImlib2.so.1
|
||||
lib/loaders/filter/bump_map.so
|
||||
lib/loaders/filter/colormod.so
|
||||
lib/loaders/filter/testfilter.so
|
||||
lib/loaders/image/argb.so
|
||||
lib/loaders/image/bmp.so
|
||||
lib/loaders/image/db.so
|
||||
lib/loaders/image/gif.so
|
||||
lib/loaders/image/jpeg.so
|
||||
lib/loaders/image/png.so
|
||||
lib/loaders/image/pnm.so
|
||||
lib/loaders/image/tga.so
|
||||
lib/loaders/image/tiff.so
|
||||
lib/loaders/image/xpm.so
|
||||
@dirrm lib/loaders/filter
|
||||
@dirrm lib/loaders/image
|
||||
@dirrm lib/loaders
|
Loading…
Reference in New Issue
Block a user