graphics/libspiro: Use upstream release archive

Use upstream release archive as recommened by Porters Handbook
While at it do some minor changes to Makefile

PR:		261300
Reviewed by:	Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)
This commit is contained in:
Daniel Engberg 2022-01-19 08:45:59 +01:00
parent ec1800be04
commit 874013bded
4 changed files with 43 additions and 41 deletions

View File

@ -4,6 +4,8 @@ PORTNAME= libspiro
DISTVERSION= 20200505
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= https://github.com/fontforge/${PORTNAME}/releases/download/${DISTVERSION}/
DISTNAME= ${PORTNAME}-dist-${DISTVERSION}
MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= Library to convert clothoid splines into Bezier splines
@ -11,15 +13,14 @@ COMMENT= Library to convert clothoid splines into Bezier splines
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= autoreconf cpe gmake libtool pathfix
USES= cpe libtool pathfix
CPE_VENDOR= libspiro_project
USE_GITHUB= yes
GH_ACCOUNT= fontforge
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
INSTALL_TARGET= install-strip
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1609565019
SHA256 (fontforge-libspiro-20200505_GH0.tar.gz) = 00be530b5c0ea9274baadf6c05521f0b192d4c3c1db636ac8b08efd44aaea8f5
SIZE (fontforge-libspiro-20200505_GH0.tar.gz) = 98636
TIMESTAMP = 1642436312
SHA256 (libspiro-dist-20200505.tar.gz) = 06c69a1e8dcbcabcf009fd96fd90b1a244d0257246e376c2c4d57c4ea4af0e49
SIZE (libspiro-dist-20200505.tar.gz) = 422546

View File

@ -1,33 +0,0 @@
--- Makefile.am.orig 2020-05-05 07:46:37 UTC
+++ Makefile.am
@@ -1,6 +1,6 @@
# Makefile.am - Top level automakefile for libspiro
-SUBDIRS = . tests
+SUBDIRS = .
test_programs = call-test0 call-test1 call-test2 call-test3 call-test4 \
call-test5 call-test6 call-test7 call-test8 call-test9 \
@@ -19,7 +19,7 @@ AM_LDFLAGS = $(WLSLIB) $(LS_LIB) -no-undefined --mode=
LIBTOOL_DEPS = @LIBTOOL_DEPS@
DISTCLEANFILES = libspiro.pc
-DISTCHECK_CONFIGURE_FLAGS = --enable-verbose_lib --enable-test_inputs --enable-test-a-lot
+DISTCHECK_CONFIGURE_FLAGS = --enable-verbose_lib --disable-test_inputs --disable-test-a-lot
lib_LTLIBRARIES = libspiro.la
@@ -39,13 +39,6 @@ man_MANS = libspiro.3
libtool: $(LIBTOOL_DEPS)
$(SHELL) ./config.status libtool
-
-# test: run all tests in cwd and subdirs
-test: $(TEST_PROGS)
-
-.PHONY: test
-# run make test as part of make check
-check-local: test
check-valgrind:
if HAVEVALGRIND

View File

@ -0,0 +1,34 @@
--- Makefile.in.orig 2022-01-17 16:21:59 UTC
+++ Makefile.in
@@ -408,7 +408,7 @@ target_vendor = @target_vendor@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-SUBDIRS = . tests
+SUBDIRS = .
test_programs = call-test0 call-test1 call-test2 call-test3 call-test4 \
call-test5 call-test6 call-test7 call-test8 call-test9 \
call-test10 call-test11 call-test12 call-test13 \
@@ -421,7 +421,7 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
AM_CFLAGS = $(WCFLAGS) $(LS_CFLAGS)
AM_LDFLAGS = $(WLSLIB) $(LS_LIB) -no-undefined --mode=link
DISTCLEANFILES = libspiro.pc
-DISTCHECK_CONFIGURE_FLAGS = --enable-verbose_lib --enable-test_inputs --enable-test-a-lot
+DISTCHECK_CONFIGURE_FLAGS = --enable-verbose_lib --disable-test_inputs --disable-test-a-lot
lib_LTLIBRARIES = libspiro.la
libspiro_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LIBSPIRO_VERSION)
libspiro_la_SOURCES = spiro.c bezctx.c spiroentrypoints.c
@@ -1095,13 +1095,6 @@ libspiro_la.$(OBJEXT): bezctx.h bezctx_intf.h spiro.h
libtool: $(LIBTOOL_DEPS)
$(SHELL) ./config.status libtool
-
-# test: run all tests in cwd and subdirs
-test: $(TEST_PROGS)
-
-.PHONY: test
-# run make test as part of make check
-check-local: test
check-valgrind:
@HAVEVALGRIND_TRUE@ $(MAKE);