New port: shells/bash-completion

The shells/bash-completion port installs Ian Macdonald's
	programmable completion library for Bash 2.04 and above.
	This gives users context- sensitive tab-completion for such
	things as program arguments, SSH hostnames, NFS mounts, and
	so on.

PR:		ports/52790
Submitted by:	Kirk Strauser <kirk@strauser.com>
This commit is contained in:
Edwin Groothuis 2003-09-29 12:44:15 +00:00
parent c62519058d
commit 8707ef668e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=89798
13 changed files with 143 additions and 0 deletions

View File

@ -2,6 +2,7 @@
#
SUBDIR += 44bsd-csh
SUBDIR += bash-completion
SUBDIR += bash1
SUBDIR += bash2
SUBDIR += es

View File

@ -0,0 +1,32 @@
# New ports collection makefile for: bash_completion
# Date created: 29 May 2003
# Whom: kirk@strauser.com
#
# $FreeBSD$
#
PORTNAME= bash-completion
PORTVERSION= 20030527
CATEGORIES= shells
MASTER_SITES= http://www.caliban.org/files/bash/
MAINTAINER= kirk@strauser.com
COMMENT= Programmable completion library for Bash 2.04 and up
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
WRKSRC= ${WRKDIR}/bash_completion
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
pre-patch:
@${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message >${PKGMESSAGE}
do-install:
${INSTALL_DATA} ${WRKSRC}/bash_completion ${PREFIX}/etc/bash_completion
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (bash-completion-20030527.tar.gz) = 3b4de4c03804fa97fd3123443a9667c6

View File

@ -0,0 +1,21 @@
--- bash_completion.orig Mon May 26 22:22:44 2003
+++ bash_completion Wed Jun 4 18:02:33 2003
@@ -27,14 +27,14 @@
if [ -n "$FUNCNAME" ]; then
# we're being sourced from within a function, so we can't use
# 'declare', as this will create local variables within a function
- BASH_COMPLETION=${BASH_COMPLETION:-/etc/bash_completion} 2>/dev/null
- BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/etc/bash_completion.d} \
+ BASH_COMPLETION=${BASH_COMPLETION:-/usr/local/etc/bash_completion} 2>/dev/null
+ BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/usr/local/etc/bash_completion.d} \
2>/dev/null
else
- declare -r BASH_COMPLETION=${BASH_COMPLETION:-/etc/bash_completion} \
+ declare -r BASH_COMPLETION=${BASH_COMPLETION:-/usr/local/etc/bash_completion} \
2>/dev/null
declare -r \
- BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/etc/bash_completion.d} \
+ BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/usr/local/etc/bash_completion.d} \
2>/dev/null
fi

View File

@ -0,0 +1,7 @@
This is a programmable completion library for bash2 users. It features the
ability to tab-complete arguments for many common programs.
WWW: http://www.caliban.org/bash/index.shtml
- Kirk Strauser
kirk@strauser.com

View File

@ -0,0 +1,9 @@
The programmable completion library is not enabled by default for various
reasons. To use it, you should source %%PREFIX%%/etc/bash_completion from
your .bashrc file. For example:
if [ -f %%PREFIX%%/etc/bash_completion ]; then
. %%PREFIX%%/etc/bash_completion
fi

View File

@ -0,0 +1 @@
etc/bash_completion

View File

@ -0,0 +1,32 @@
# New ports collection makefile for: bash_completion
# Date created: 29 May 2003
# Whom: kirk@strauser.com
#
# $FreeBSD$
#
PORTNAME= bash-completion
PORTVERSION= 20030527
CATEGORIES= shells
MASTER_SITES= http://www.caliban.org/files/bash/
MAINTAINER= kirk@strauser.com
COMMENT= Programmable completion library for Bash 2.04 and up
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
WRKSRC= ${WRKDIR}/bash_completion
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
pre-patch:
@${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message >${PKGMESSAGE}
do-install:
${INSTALL_DATA} ${WRKSRC}/bash_completion ${PREFIX}/etc/bash_completion
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (bash-completion-20030527.tar.gz) = 3b4de4c03804fa97fd3123443a9667c6

View File

@ -0,0 +1,21 @@
--- bash_completion.orig Mon May 26 22:22:44 2003
+++ bash_completion Wed Jun 4 18:02:33 2003
@@ -27,14 +27,14 @@
if [ -n "$FUNCNAME" ]; then
# we're being sourced from within a function, so we can't use
# 'declare', as this will create local variables within a function
- BASH_COMPLETION=${BASH_COMPLETION:-/etc/bash_completion} 2>/dev/null
- BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/etc/bash_completion.d} \
+ BASH_COMPLETION=${BASH_COMPLETION:-/usr/local/etc/bash_completion} 2>/dev/null
+ BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/usr/local/etc/bash_completion.d} \
2>/dev/null
else
- declare -r BASH_COMPLETION=${BASH_COMPLETION:-/etc/bash_completion} \
+ declare -r BASH_COMPLETION=${BASH_COMPLETION:-/usr/local/etc/bash_completion} \
2>/dev/null
declare -r \
- BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/etc/bash_completion.d} \
+ BASH_COMPLETION_DIR=${BASH_COMPLETION_DIR:=/usr/local/etc/bash_completion.d} \
2>/dev/null
fi

View File

@ -0,0 +1,7 @@
This is a programmable completion library for bash2 users. It features the
ability to tab-complete arguments for many common programs.
WWW: http://www.caliban.org/bash/index.shtml
- Kirk Strauser
kirk@strauser.com

View File

@ -0,0 +1,9 @@
The programmable completion library is not enabled by default for various
reasons. To use it, you should source %%PREFIX%%/etc/bash_completion from
your .bashrc file. For example:
if [ -f %%PREFIX%%/etc/bash_completion ]; then
. %%PREFIX%%/etc/bash_completion
fi

View File

@ -0,0 +1 @@
etc/bash_completion