Update to 0.3.3.

This commit is contained in:
Jeremy Messenger 2005-04-13 21:14:38 +00:00
parent 573ad4e29d
commit 87011d5caf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=133271
5 changed files with 136 additions and 33 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= bless
PORTVERSION= 0.3.1
PORTREVISION= 1
PORTVERSION= 0.3.3
CATEGORIES= editors
MASTER_SITES= http://download.gna.org/bless/
@ -17,16 +16,26 @@ COMMENT= A high quality, full featured hex editor
BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GNOME= gnometarget
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
DOCS= AUTHORS Changelog NEWS README
DOCS= AUTHORS COPYING ChangeLog NEWS README
post-patch:
@${REINPLACE_CMD} -e 's|make|${GMAKE}|g ; s|config.gmake|config.make|g' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|data tests|data|g' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|[(]datadir[)]/applications|(prefix)/share/gnome/applications|g ; \
s|[(]datadir[)]/pixmaps|(prefix)/share/gnome/pixmaps|g' \
${WRKSRC}/data/Makefile.in
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|doc/$$(PACKAGE_NAME)-$$(PACKAGE_VERSION)|doc/$$(PACKAGE_NAME)|g'
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|src doc|src|g' \
${WRKSRC}/Makefile.in
.endif
.ifndef (NOPORTDOCS)
post-install:

View File

@ -1,2 +1,2 @@
MD5 (bless-0.3.1.tar.gz) = 91597bacbffbd24b3ff5b19de60f7a08
SIZE (bless-0.3.1.tar.gz) = 333150
MD5 (bless-0.3.3.tar.gz) = 24fdc56ce6ac8bf5124605b753b53026
SIZE (bless-0.3.3.tar.gz) = 471997

View File

@ -0,0 +1,78 @@
--- src/ByteBuffer/Makefile.in.orig Tue Apr 12 11:22:18 2005
+++ src/ByteBuffer/Makefile.in Tue Apr 12 11:22:52 2005
@@ -113,7 +113,7 @@
EXTRA_DIST = $(SRC)
DLL = Bless.Buffers.dll
CLEANFILES = $(DLL)
-REFS = -r:../util/Bless.Util.dll -pkg:gtk-sharp
+REFS = -r:../util/Bless.Util.dll $(shell pkg-config --libs gtk-sharp)
all: all-am
.SUFFIXES:
--- src/Makefile.in.orig Tue Apr 12 11:20:04 2005
+++ src/Makefile.in Tue Apr 12 11:20:44 2005
@@ -485,7 +485,7 @@
bless.exe: $(GUI_SRC) $(BB_SRC) $(GUI_DRAWERS_SRC) $(GUI_AREAS_SRC) $(GUI_DIALOGS_SRC) $(TOOLS_FIND_SRC) $(UTIL_SRC) $(MISC_DEPS)
- $(MCS) $(MCS_FLAGS) -o bless.exe -t:exe $(RESOURCES) -r:Mono.Posix -pkg:gtk-sharp -pkg:glade-sharp \
+ $(MCS) $(MCS_FLAGS) -o bless.exe -t:exe $(RESOURCES) -r:Mono.Posix $(shell pkg-config --libs gtk-sharp glade-sharp) \
$(GUI_SRC) $(BB_SRC) $(GUI_DRAWERS_SRC) $(GUI_AREAS_SRC) $(GUI_DIALOGS_SRC) $(TOOLS_FIND_SRC) $(UTIL_SRC)
install-exec-local: bless.exe
--- src/gui/Makefile.in.orig Tue Apr 12 11:24:11 2005
+++ src/gui/Makefile.in Tue Apr 12 11:24:40 2005
@@ -418,7 +418,7 @@
dll: $(DLL)
$(DLL): $(SRC)
- $(MCS) -target:library -r:$(REFS) -pkg:$(PKGS) -out:$(DLL) $(SRC)
+ $(MCS) -target:library -r:$(REFS) $(shell pkg-config --libs $(PKGS)) -out:$(DLL) $(SRC)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
--- src/gui/areas/Makefile.in.orig Tue Apr 12 11:27:20 2005
+++ src/gui/areas/Makefile.in Tue Apr 12 11:27:43 2005
@@ -270,7 +270,7 @@
all: $(DLL)
$(DLL): $(SRC)
- $(MCS) -target:library -r:$(REFS) -pkg:$(PKGS) -out:$(DLL) $(SRC)
+ $(MCS) -target:library -r:$(REFS) $(shell pkg-config --libs $(PKGS)) -out:$(DLL) $(SRC)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
--- src/gui/dialogs/Makefile.in.orig Tue Apr 12 11:28:49 2005
+++ src/gui/dialogs/Makefile.in Tue Apr 12 11:29:18 2005
@@ -123,8 +123,7 @@
-r:../../ByteBuffer/Bless.Buffers.dll \
-r:../../tools/find/Bless.Tools.Find.dll
-PKGS = -pkg:gtk-sharp \
- -pkg:glade-sharp
+PKGS = $(shell pkg-config --libs gtk-sharp glade-sharp)
all: all-am
--- src/gui/drawers/Makefile.in.orig Tue Apr 12 11:30:13 2005
+++ src/gui/drawers/Makefile.in Tue Apr 12 11:30:28 2005
@@ -269,7 +269,7 @@
all: $(DLL)
$(DLL): $(SRC)
- $(MCS) -target:library -pkg:$(PKGS) -out:$(DLL) $(SRC)
+ $(MCS) -target:library $(shell pkg-config --libs $(PKGS)) -out:$(DLL) $(SRC)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
--- src/util/Makefile.in.orig Tue Apr 12 11:32:07 2005
+++ src/util/Makefile.in Tue Apr 12 11:32:23 2005
@@ -268,7 +268,7 @@
dll: $(DLL)
$(DLL): $(SRC)
- $(MCS) -pkg:gtk-sharp -target:library -out:$(DLL) $(SRC)
+ $(MCS) $(shell pkg-config --libs gtk-sharp) -target:library -out:$(DLL) $(SRC)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:

View File

@ -1,17 +0,0 @@
--- src/Makefile.orig Sun Feb 6 04:32:01 2005
+++ src/Makefile Sun Feb 6 04:33:23 2005
@@ -65,12 +65,12 @@
bless.exe: $(GUI_SRC) $(BB_SRC) $(GUI_DRAWERS_SRC) $(GUI_AREAS_SRC) $(GUI_DIALOGS_SRC) $(TOOLS_FIND_SRC) $(UTIL_SRC) $(MISC_DEPS)
- $(MCS) -g -o bless.exe -t:exe -r:nunit.framework $(RESOURCES) -pkg:gtk-sharp -pkg:glade-sharp \
+ $(MCS) -g -o bless.exe -t:exe -r:nunit.framework $(RESOURCES) $(shell pkg-config --libs gtk-sharp glade-sharp) \
$(GUI_SRC) $(BB_SRC) $(GUI_DRAWERS_SRC) $(GUI_AREAS_SRC) $(GUI_DIALOGS_SRC) $(TOOLS_FIND_SRC) $(UTIL_SRC)
%.dll:%.cs
- $(MCS) -t:library -r:nunit.framework -pkg:gtk-sharp $<
+ $(MCS) -t:library -r:nunit.framework $(shell pkg-config --libs gtk-sharp) $<
install: bless.exe
install -c -d $(PREFIX)/lib/bless/bin/

View File

@ -1,13 +1,46 @@
bin/bless
lib/bless/bin/bless.exe
lib/bless/data/Makefile
lib/bless/data/bless-about.png
lib/bless/data/bless-icon.png
lib/bless-0.3.3/bin/bless.exe
lib/bless-0.3.3/data/bless-48x48.png
lib/bless-0.3.3/data/bless-about.png
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/Changelog
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/developer/Makefile
%%PORTDOCS%%%%DOCSDIR%%/developer/Makefile.am
%%PORTDOCS%%%%DOCSDIR%%/developer/Makefile.in
%%PORTDOCS%%%%DOCSDIR%%/developer/Makefile.in.bak
%%PORTDOCS%%%%DOCSDIR%%/developer/bless.xmi
%%PORTDOCS%%%%DOCSDIR%%/user/bless-manual.xml
%%PORTDOCS%%%%DOCSDIR%%/user/ch01.html
%%PORTDOCS%%%%DOCSDIR%%/user/ch02.html
%%PORTDOCS%%%%DOCSDIR%%/user/ch02s02.html
%%PORTDOCS%%%%DOCSDIR%%/user/ch03.html
%%PORTDOCS%%%%DOCSDIR%%/user/ch03s02.html
%%PORTDOCS%%%%DOCSDIR%%/user/ch04.html
%%PORTDOCS%%%%DOCSDIR%%/user/ch04s02.html
%%PORTDOCS%%%%DOCSDIR%%/user/ch04s03.html
%%PORTDOCS%%%%DOCSDIR%%/user/ch04s04.html
%%PORTDOCS%%%%DOCSDIR%%/user/ch05.html
%%PORTDOCS%%%%DOCSDIR%%/user/ch06.html
%%PORTDOCS%%%%DOCSDIR%%/user/figures/bless_area_focus.png
%%PORTDOCS%%%%DOCSDIR%%/user/figures/bless_display_tag.png
%%PORTDOCS%%%%DOCSDIR%%/user/figures/bless_edit_mode.png
%%PORTDOCS%%%%DOCSDIR%%/user/figures/bless_layout_example1.png
%%PORTDOCS%%%%DOCSDIR%%/user/figures/bless_layout_oha.png
%%PORTDOCS%%%%DOCSDIR%%/user/figures/bless_search_find.png
%%PORTDOCS%%%%DOCSDIR%%/user/figures/bless_search_replace.png
%%PORTDOCS%%%%DOCSDIR%%/user/figures/bless_start_window.png
%%PORTDOCS%%%%DOCSDIR%%/user/figures/bless_tab_close.png
%%PORTDOCS%%%%DOCSDIR%%/user/index.html
%%PORTDOCS%%%%DOCSDIR%%/user/legal.xml
share/gnome/applications/bless.desktop
share/gnome/pixmaps/bless-48x48.png
%%PORTDOCS%%@dirrm %%DOCSDIR%%/user/figures
%%PORTDOCS%%@dirrm %%DOCSDIR%%/user
%%PORTDOCS%%@dirrm %%DOCSDIR%%/developer
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/bless/data
@dirrm lib/bless/bin
@dirrm lib/bless
@dirrm lib/bless-0.3.3/data
@dirrm lib/bless-0.3.3/bin
@dirrm lib/bless-0.3.3