Update to 4.3.2

This commit is contained in:
Ganael LAPLANCHE 2011-09-20 09:09:57 +00:00
parent 95daa67471
commit 86fbaded05
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=282054
4 changed files with 12 additions and 22 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= lftp
PORTVERSION= 4.3.1
PORTVERSION= 4.3.2
CATEGORIES= ftp ipv6
MASTER_SITES= http://ftp.yars.free.net/pub/source/lftp/ \
http://ftp.yars.free.net/pub/source/lftp/old/ \

View File

@ -1,2 +1,2 @@
SHA256 (lftp-4.3.1.tar.gz) = becf369e5b79e613433234d6cdf8ed35c1df3897d672a05923d20c96253a41d6
SIZE (lftp-4.3.1.tar.gz) = 2351594
SHA256 (lftp-4.3.2.tar.gz) = 17f1df54646d415646cfa4c10b4300e31664189502f1e4ce46e09abe58a8e43d
SIZE (lftp-4.3.2.tar.gz) = 2394643

View File

@ -1,15 +1,15 @@
--- lib/Makefile.in.orig 2011-06-27 17:51:45.965708112 +0200
+++ lib/Makefile.in 2011-06-27 17:54:57.569892443 +0200
@@ -1333,8 +1333,6 @@
ARG_NONNULL_H = arg-nonnull.h
CXXDEFS_H = c++defs.h
--- lib/Makefile.in.orig 2011-09-20 10:20:00.632757147 +0200
+++ lib/Makefile.in 2011-09-20 10:22:27.434783661 +0200
@@ -1376,8 +1376,6 @@
libgnu_la_LDFLAGS = $(AM_LDFLAGS) -no-undefined $(INET_PTON_LIB) \
$(LIBSOCKET) $(LIB_CLOCK_GETTIME) $(LTLIBICONV) $(LTLIBINTL)
GPERF = gperf
-charset_alias = $(DESTDIR)$(libdir)/charset.alias
-charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
UNUSED_PARAMETER_H = unused-parameter.h
WARN_ON_USE_H = warn-on-use.h
all: $(BUILT_SOURCES) config.h
@@ -2263,31 +2261,10 @@
# Because this Makefile snippet defines a variable used by other
# gnulib Makefile snippets, it must be present in all Makefile.am that
@@ -2303,31 +2301,10 @@
fi ; \
if $$need_charset_alias; then \
$(mkinstalldirs) $(DESTDIR)$(libdir) ; \

View File

@ -1,10 +0,0 @@
--- src/Torrent.cc.orig 2009-09-16 18:02:13.808225067 +0000
+++ src/Torrent.cc 2009-09-16 18:02:27.236576994 +0000
@@ -24,6 +24,7 @@
#include <stdlib.h>
#include <assert.h>
#include <sys/socket.h>
+#include <sys/stat.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include <unistd.h>