- Fix build when Python version > 2.6

- Remove MD5 checksum from distinfo

PR:		ports/154965
Submitted by:	wen
This commit is contained in:
Nicola Vitale 2011-02-26 15:30:04 +00:00
parent 7433add2ea
commit 86db42a12a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=269812
2 changed files with 3 additions and 4 deletions

View File

@ -1,3 +1,2 @@
MD5 (kiwi-1.9.26.tar.gz) = 036cb5d9007d816bdc7b9fff9fc3215c
SHA256 (kiwi-1.9.26.tar.gz) = 1e37f7d993b1eb4fd33d320a7dc1e16cff84ca8d80467b59540ea2aafeacc6c9
SIZE (kiwi-1.9.26.tar.gz) = 749264

View File

@ -1,11 +1,11 @@
--- kiwi/dist.py 2009-07-14 19:01:15.000000000 +0200
+++ kiwi/dist.py.port 2009-08-18 10:28:06.000000000 +0200
--- ./kiwi/dist.py.orig 2009-07-14 19:01:15.000000000 +0200
+++ ./kiwi/dist.py 2011-02-26 14:52:14.000000000 +0100
@@ -159,7 +159,7 @@
python_version = sys.version_info[:2]
libdir = get_python_lib(plat_specific=False,
standard_lib=True, prefix='')
- if python_version < (2, 6):
+ if python_version <= (2, 6):
+ if python_version < (2, 6) or os.uname()[0] == 'FreeBSD':
site = 'site-packages'
else:
site = 'dist-packages'