deskutils/go-for-it: Updated to 1.6.5

Changhelog:
https://github.com/mank319/Go-For-It/releases/tag/1.6.5

Additional changes:
* Changed to DISTVERSION
* USES=cmake:outsource
* Removed post-install (not needed)
* Removed the unnecessary patch
* Added the patch to revert the app name to go-for-it (from com.xx...go-for-it)
* Plist now uses %%DATADIR%% + many additions

PR:		226257
Submitted by:	Neel Chauhan <neel@neelc.org> (maintainer)
Approved by:	tcberner (mentor, implicit)
This commit is contained in:
Yuri Victorovich 2018-02-28 22:20:06 +00:00
parent 929f5701d8
commit 86d49e87e4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=463266
5 changed files with 155 additions and 33 deletions

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= go-for-it
PORTVERSION= 1.5
DISTVERSIONPREFIX= release_v
DISTVERSION= 1.6.5
CATEGORIES= deskutils
MAINTAINER= neel@neelc.org
@ -14,17 +13,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= valac:lang/vala
LIB_DEPENDS= libnotify.so:devel/libnotify
USES= cmake gettext pkgconfig
USE_GNOME= cairo glib20 gtk30
USES= cmake:outsource gettext pkgconfig
GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= JMoerman
GH_PROJECT= Go-For-It
USE_GNOME= cairo glib20 gtk30 intltool
INSTALLS_ICONS= yes
USE_GITHUB= yes
GH_ACCOUNT= mank319
GH_PROJECT= Go-For-It
post-install:
${INSTALL_DATA} ${WRKSRC}/data/go-for-it.desktop \
${STAGEDIR}${PREFIX}/share/applications
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1482424426
SHA256 (mank319-Go-For-It-release_v1.5_GH0.tar.gz) = 5acba45690c999f3333eb615a0217e93b53a2f9f3e36f05c006067fdb134a1f1
SIZE (mank319-Go-For-It-release_v1.5_GH0.tar.gz) = 308566
TIMESTAMP = 1519773342
SHA256 (JMoerman-Go-For-It-1.6.5_GH0.tar.gz) = af3ba1529b45e697caf22e79821768c742903084c76eb2637a15ec51508b2e35
SIZE (JMoerman-Go-For-It-1.6.5_GH0.tar.gz) = 211288

View File

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2018-02-28 21:31:57 UTC
+++ CMakeLists.txt
@@ -8,7 +8,7 @@ include (GNUInstallDirs)
set (INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}")
set (DATADIR "${INSTALL_PREFIX}/share")
-set (APP_ID "com.github.jmoerman.go-for-it")
+set (APP_ID "go-for-it")
set (APP_SYSTEM_NAME ${APP_ID} CACHE STRING "Name to used for file names. For example the file name of the .desktop file.")
set (PKGDATADIR ${DATADIR}/${APP_SYSTEM_NAME})

View File

@ -1,14 +0,0 @@
--- src/TaskStore.vala.orig 2016-12-18 13:54:36 UTC
+++ src/TaskStore.vala
@@ -86,7 +86,11 @@ class TaskStore : Gtk.ListStore {
public void remove_task (Gtk.TreeIter iter) {
bool is_active_task = compare_tasks (iter);
var _active_task = active_task;
+#if VALA_0_36
+ this.remove (ref iter);
+#else
this.remove (iter);
+#endif
if (is_active_task && _active_task == active_task) {
active_task = null;
refresh_active_task ();

View File

@ -1,4 +1,6 @@
bin/go-for-it
share/applications/go-for-it.desktop
share/metainfo/go-for-it.appdata.xml
share/icons/hicolor/16x16/apps/go-for-it.svg
share/icons/hicolor/24x24/apps/go-for-it.svg
share/icons/hicolor/32x32/apps/go-for-it.svg
@ -6,25 +8,52 @@ share/icons/hicolor/48x48/apps/go-for-it.svg
share/icons/hicolor/64x64/apps/go-for-it.svg
share/icons/hicolor/128x128/apps/go-for-it.svg
share/icons/hicolor/24x24/actions/go-for-it-open-menu-fallback.svg
share/go-for-it/style/go-for-it-3.20.css
share/go-for-it/style/go-for-it-3.10.css
share/go-for-it/style/go-for-it-legacy.css
share/applications/go-for-it.desktop
%%DATADIR%%/style/go-for-it-3.10.css
%%DATADIR%%/style/go-for-it-3.10-dark.css
%%DATADIR%%/style/widgets-3.10.css
%%DATADIR%%/style/go-for-it-3.20.css
%%DATADIR%%/style/go-for-it-3.20-dark.css
%%DATADIR%%/style/widgets-3.20.css
%%DATADIR%%/style/colors.css
%%DATADIR%%/style/colors-dark.css
share/locale/aa/LC_MESSAGES/go-for-it.mo
share/locale/ab/LC_MESSAGES/go-for-it.mo
share/locale/ae/LC_MESSAGES/go-for-it.mo
share/locale/af/LC_MESSAGES/go-for-it.mo
share/locale/ak/LC_MESSAGES/go-for-it.mo
share/locale/am/LC_MESSAGES/go-for-it.mo
share/locale/an/LC_MESSAGES/go-for-it.mo
share/locale/ar/LC_MESSAGES/go-for-it.mo
share/locale/as/LC_MESSAGES/go-for-it.mo
share/locale/ast/LC_MESSAGES/go-for-it.mo
share/locale/av/LC_MESSAGES/go-for-it.mo
share/locale/ay/LC_MESSAGES/go-for-it.mo
share/locale/az/LC_MESSAGES/go-for-it.mo
share/locale/ba/LC_MESSAGES/go-for-it.mo
share/locale/be/LC_MESSAGES/go-for-it.mo
share/locale/bg/LC_MESSAGES/go-for-it.mo
share/locale/bh/LC_MESSAGES/go-for-it.mo
share/locale/bi/LC_MESSAGES/go-for-it.mo
share/locale/bm/LC_MESSAGES/go-for-it.mo
share/locale/bn/LC_MESSAGES/go-for-it.mo
share/locale/bo/LC_MESSAGES/go-for-it.mo
share/locale/br/LC_MESSAGES/go-for-it.mo
share/locale/bs/LC_MESSAGES/go-for-it.mo
share/locale/ca/LC_MESSAGES/go-for-it.mo
share/locale/ce/LC_MESSAGES/go-for-it.mo
share/locale/ch/LC_MESSAGES/go-for-it.mo
share/locale/ckb/LC_MESSAGES/go-for-it.mo
share/locale/co/LC_MESSAGES/go-for-it.mo
share/locale/cr/LC_MESSAGES/go-for-it.mo
share/locale/cs/LC_MESSAGES/go-for-it.mo
share/locale/cu/LC_MESSAGES/go-for-it.mo
share/locale/cv/LC_MESSAGES/go-for-it.mo
share/locale/cy/LC_MESSAGES/go-for-it.mo
share/locale/da/LC_MESSAGES/go-for-it.mo
share/locale/de/LC_MESSAGES/go-for-it.mo
share/locale/dv/LC_MESSAGES/go-for-it.mo
share/locale/dz/LC_MESSAGES/go-for-it.mo
share/locale/ee/LC_MESSAGES/go-for-it.mo
share/locale/el/LC_MESSAGES/go-for-it.mo
share/locale/en_AU/LC_MESSAGES/go-for-it.mo
share/locale/en_CA/LC_MESSAGES/go-for-it.mo
@ -34,51 +63,153 @@ share/locale/es/LC_MESSAGES/go-for-it.mo
share/locale/et/LC_MESSAGES/go-for-it.mo
share/locale/eu/LC_MESSAGES/go-for-it.mo
share/locale/fa/LC_MESSAGES/go-for-it.mo
share/locale/ff/LC_MESSAGES/go-for-it.mo
share/locale/fi/LC_MESSAGES/go-for-it.mo
share/locale/fj/LC_MESSAGES/go-for-it.mo
share/locale/fo/LC_MESSAGES/go-for-it.mo
share/locale/fr/LC_MESSAGES/go-for-it.mo
share/locale/fr_CA/LC_MESSAGES/go-for-it.mo
share/locale/fr_FR/LC_MESSAGES/go-for-it.mo
share/locale/fy/LC_MESSAGES/go-for-it.mo
share/locale/ga/LC_MESSAGES/go-for-it.mo
share/locale/gd/LC_MESSAGES/go-for-it.mo
share/locale/gl/LC_MESSAGES/go-for-it.mo
share/locale/gn/LC_MESSAGES/go-for-it.mo
share/locale/gu/LC_MESSAGES/go-for-it.mo
share/locale/gv/LC_MESSAGES/go-for-it.mo
share/locale/ha/LC_MESSAGES/go-for-it.mo
share/locale/he/LC_MESSAGES/go-for-it.mo
share/locale/hi/LC_MESSAGES/go-for-it.mo
share/locale/ho/LC_MESSAGES/go-for-it.mo
share/locale/hr/LC_MESSAGES/go-for-it.mo
share/locale/ht/LC_MESSAGES/go-for-it.mo
share/locale/hu/LC_MESSAGES/go-for-it.mo
share/locale/hy/LC_MESSAGES/go-for-it.mo
share/locale/hz/LC_MESSAGES/go-for-it.mo
share/locale/ia/LC_MESSAGES/go-for-it.mo
share/locale/id/LC_MESSAGES/go-for-it.mo
share/locale/ie/LC_MESSAGES/go-for-it.mo
share/locale/ig/LC_MESSAGES/go-for-it.mo
share/locale/ii/LC_MESSAGES/go-for-it.mo
share/locale/ik/LC_MESSAGES/go-for-it.mo
share/locale/io/LC_MESSAGES/go-for-it.mo
share/locale/is/LC_MESSAGES/go-for-it.mo
share/locale/it/LC_MESSAGES/go-for-it.mo
share/locale/iu/LC_MESSAGES/go-for-it.mo
share/locale/ja/LC_MESSAGES/go-for-it.mo
share/locale/jv/LC_MESSAGES/go-for-it.mo
share/locale/ka/LC_MESSAGES/go-for-it.mo
share/locale/kg/LC_MESSAGES/go-for-it.mo
share/locale/ki/LC_MESSAGES/go-for-it.mo
share/locale/kj/LC_MESSAGES/go-for-it.mo
share/locale/kk/LC_MESSAGES/go-for-it.mo
share/locale/kl/LC_MESSAGES/go-for-it.mo
share/locale/km/LC_MESSAGES/go-for-it.mo
share/locale/kn/LC_MESSAGES/go-for-it.mo
share/locale/ko/LC_MESSAGES/go-for-it.mo
share/locale/kr/LC_MESSAGES/go-for-it.mo
share/locale/ks/LC_MESSAGES/go-for-it.mo
share/locale/ku/LC_MESSAGES/go-for-it.mo
share/locale/kv/LC_MESSAGES/go-for-it.mo
share/locale/kw/LC_MESSAGES/go-for-it.mo
share/locale/ky/LC_MESSAGES/go-for-it.mo
share/locale/la/LC_MESSAGES/go-for-it.mo
share/locale/lb/LC_MESSAGES/go-for-it.mo
share/locale/lg/LC_MESSAGES/go-for-it.mo
share/locale/li/LC_MESSAGES/go-for-it.mo
share/locale/ln/LC_MESSAGES/go-for-it.mo
share/locale/lo/LC_MESSAGES/go-for-it.mo
share/locale/lt/LC_MESSAGES/go-for-it.mo
share/locale/lu/LC_MESSAGES/go-for-it.mo
share/locale/lv/LC_MESSAGES/go-for-it.mo
share/locale/mg/LC_MESSAGES/go-for-it.mo
share/locale/mh/LC_MESSAGES/go-for-it.mo
share/locale/mi/LC_MESSAGES/go-for-it.mo
share/locale/mk/LC_MESSAGES/go-for-it.mo
share/locale/ml/LC_MESSAGES/go-for-it.mo
share/locale/mn/LC_MESSAGES/go-for-it.mo
share/locale/mo/LC_MESSAGES/go-for-it.mo
share/locale/mr/LC_MESSAGES/go-for-it.mo
share/locale/ms/LC_MESSAGES/go-for-it.mo
share/locale/mt/LC_MESSAGES/go-for-it.mo
share/locale/my/LC_MESSAGES/go-for-it.mo
share/locale/na/LC_MESSAGES/go-for-it.mo
share/locale/nb/LC_MESSAGES/go-for-it.mo
share/locale/nd/LC_MESSAGES/go-for-it.mo
share/locale/ne/LC_MESSAGES/go-for-it.mo
share/locale/ng/LC_MESSAGES/go-for-it.mo
share/locale/nl/LC_MESSAGES/go-for-it.mo
share/locale/nn/LC_MESSAGES/go-for-it.mo
share/locale/no/LC_MESSAGES/go-for-it.mo
share/locale/nr/LC_MESSAGES/go-for-it.mo
share/locale/nv/LC_MESSAGES/go-for-it.mo
share/locale/ny/LC_MESSAGES/go-for-it.mo
share/locale/oc/LC_MESSAGES/go-for-it.mo
share/locale/oj/LC_MESSAGES/go-for-it.mo
share/locale/om/LC_MESSAGES/go-for-it.mo
share/locale/or/LC_MESSAGES/go-for-it.mo
share/locale/os/LC_MESSAGES/go-for-it.mo
share/locale/pa/LC_MESSAGES/go-for-it.mo
share/locale/pi/LC_MESSAGES/go-for-it.mo
share/locale/pl/LC_MESSAGES/go-for-it.mo
share/locale/ps/LC_MESSAGES/go-for-it.mo
share/locale/pt/LC_MESSAGES/go-for-it.mo
share/locale/pt_BR/LC_MESSAGES/go-for-it.mo
share/locale/qu/LC_MESSAGES/go-for-it.mo
share/locale/rm/LC_MESSAGES/go-for-it.mo
share/locale/rn/LC_MESSAGES/go-for-it.mo
share/locale/ro/LC_MESSAGES/go-for-it.mo
share/locale/ru/LC_MESSAGES/go-for-it.mo
share/locale/rue/LC_MESSAGES/go-for-it.mo
share/locale/rw/LC_MESSAGES/go-for-it.mo
share/locale/sa/LC_MESSAGES/go-for-it.mo
share/locale/sc/LC_MESSAGES/go-for-it.mo
share/locale/sd/LC_MESSAGES/go-for-it.mo
share/locale/se/LC_MESSAGES/go-for-it.mo
share/locale/sg/LC_MESSAGES/go-for-it.mo
share/locale/si/LC_MESSAGES/go-for-it.mo
share/locale/sk/LC_MESSAGES/go-for-it.mo
share/locale/sl/LC_MESSAGES/go-for-it.mo
share/locale/sm/LC_MESSAGES/go-for-it.mo
share/locale/sma/LC_MESSAGES/go-for-it.mo
share/locale/sn/LC_MESSAGES/go-for-it.mo
share/locale/so/LC_MESSAGES/go-for-it.mo
share/locale/sq/LC_MESSAGES/go-for-it.mo
share/locale/sr/LC_MESSAGES/go-for-it.mo
share/locale/ss/LC_MESSAGES/go-for-it.mo
share/locale/st/LC_MESSAGES/go-for-it.mo
share/locale/su/LC_MESSAGES/go-for-it.mo
share/locale/sv/LC_MESSAGES/go-for-it.mo
share/locale/sw/LC_MESSAGES/go-for-it.mo
share/locale/ta/LC_MESSAGES/go-for-it.mo
share/locale/te/LC_MESSAGES/go-for-it.mo
share/locale/tg/LC_MESSAGES/go-for-it.mo
share/locale/th/LC_MESSAGES/go-for-it.mo
share/locale/ti/LC_MESSAGES/go-for-it.mo
share/locale/tk/LC_MESSAGES/go-for-it.mo
share/locale/tl/LC_MESSAGES/go-for-it.mo
share/locale/tn/LC_MESSAGES/go-for-it.mo
share/locale/to/LC_MESSAGES/go-for-it.mo
share/locale/tr/LC_MESSAGES/go-for-it.mo
share/locale/ts/LC_MESSAGES/go-for-it.mo
share/locale/tt/LC_MESSAGES/go-for-it.mo
share/locale/tw/LC_MESSAGES/go-for-it.mo
share/locale/ty/LC_MESSAGES/go-for-it.mo
share/locale/ug/LC_MESSAGES/go-for-it.mo
share/locale/uk/LC_MESSAGES/go-for-it.mo
share/locale/ur/LC_MESSAGES/go-for-it.mo
share/locale/uz/LC_MESSAGES/go-for-it.mo
share/locale/ve/LC_MESSAGES/go-for-it.mo
share/locale/vi/LC_MESSAGES/go-for-it.mo
share/locale/vo/LC_MESSAGES/go-for-it.mo
share/locale/wa/LC_MESSAGES/go-for-it.mo
share/locale/wo/LC_MESSAGES/go-for-it.mo
share/locale/xh/LC_MESSAGES/go-for-it.mo
share/locale/yi/LC_MESSAGES/go-for-it.mo
share/locale/yo/LC_MESSAGES/go-for-it.mo
share/locale/za/LC_MESSAGES/go-for-it.mo
share/locale/zh/LC_MESSAGES/go-for-it.mo
share/locale/zh_CN/LC_MESSAGES/go-for-it.mo
share/locale/zh_HK/LC_MESSAGES/go-for-it.mo
share/locale/zh_TW/LC_MESSAGES/go-for-it.mo
share/locale/zu/LC_MESSAGES/go-for-it.mo