add beagle 2.1.3

An Evolutionary Computation Framework
This commit is contained in:
Ying-Chieh Liao 2004-06-09 06:52:06 +00:00
parent c251d5d494
commit 86c01e9853
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111134
11 changed files with 163 additions and 0 deletions

View File

@ -76,6 +76,7 @@
SUBDIR += avrdude
SUBDIR += bcc
SUBDIR += bcpp
SUBDIR += beagle
SUBDIR += bglibs
SUBDIR += bicyclerepair
SUBDIR += bin86

29
devel/beagle/Makefile Normal file
View File

@ -0,0 +1,29 @@
# ex:ts=8
# Ports collection makefile for: beagle
# Date created: Jun 9, 2004
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= beagle
PORTVERSION= 2.1.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An Evolutionary Computation Framework
USE_GCC= 3.3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-optimization
INSTALLS_SHLIB= yes
post-install:
@${FIND} ${PREFIX}/include/beagle ! -type d | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${PREFIX}/include/beagle -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.include <bsd.port.mk>

2
devel/beagle/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (beagle-2.1.3.tar.gz) = 6a816f55aec38ddacf556986397a7db4
SIZE (beagle-2.1.3.tar.gz) = 2787022

View File

@ -0,0 +1,15 @@
--- config/ltmain.sh.orig Wed Jun 9 14:13:42 2004
+++ config/ltmain.sh Wed Jun 9 14:13:51 2004
@@ -4330,10 +4330,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

12
devel/beagle/pkg-descr Normal file
View File

@ -0,0 +1,12 @@
Open BEAGLE is a C++ Evolutionary Computation (EC) framework. It provides an
high-level software environment to do any kind of EC, with support for
tree-based genetic programming, bit string and real-valued genetic algorithms,
and evolution strategy.
The Open BEAGLE architecture follows strong principles of object oriented
programming, where abstractions are represented by loosely coupled objects and
where it is common and easy to reuse code. Open BEAGLE is designed to provide
an EC environment that is generic, user friendly, portable, efficient, robust,
elegant and free.
WWW: http://beagle.sourceforge.net/

23
devel/beagle/pkg-plist Normal file
View File

@ -0,0 +1,23 @@
include/Threading/Condition.hpp
include/Threading/Exception.hpp
include/Threading/Mutex.hpp
include/Threading/Semaphore.hpp
include/Threading/Thread.hpp
include/Threading/Threading.hpp
@dirrm include/Threading
include/gzstream.h
lib/libThreading-2.1.3.so
lib/libThreading.a
lib/libThreading.so
lib/libbeagle-2.1.3.so
lib/libbeagle-Coev-2.1.3.so
lib/libbeagle-Coev.a
lib/libbeagle-Coev.so
lib/libbeagle-GA-2.1.3.so
lib/libbeagle-GA.a
lib/libbeagle-GA.so
lib/libbeagle-GP-2.1.3.so
lib/libbeagle-GP.a
lib/libbeagle-GP.so
lib/libbeagle.a
lib/libbeagle.so

View File

@ -0,0 +1,29 @@
# ex:ts=8
# Ports collection makefile for: beagle
# Date created: Jun 9, 2004
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= beagle
PORTVERSION= 2.1.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An Evolutionary Computation Framework
USE_GCC= 3.3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-optimization
INSTALLS_SHLIB= yes
post-install:
@${FIND} ${PREFIX}/include/beagle ! -type d | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${PREFIX}/include/beagle -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (beagle-2.1.3.tar.gz) = 6a816f55aec38ddacf556986397a7db4
SIZE (beagle-2.1.3.tar.gz) = 2787022

View File

@ -0,0 +1,15 @@
--- config/ltmain.sh.orig Wed Jun 9 14:13:42 2004
+++ config/ltmain.sh Wed Jun 9 14:13:51 2004
@@ -4330,10 +4330,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -0,0 +1,12 @@
Open BEAGLE is a C++ Evolutionary Computation (EC) framework. It provides an
high-level software environment to do any kind of EC, with support for
tree-based genetic programming, bit string and real-valued genetic algorithms,
and evolution strategy.
The Open BEAGLE architecture follows strong principles of object oriented
programming, where abstractions are represented by loosely coupled objects and
where it is common and easy to reuse code. Open BEAGLE is designed to provide
an EC environment that is generic, user friendly, portable, efficient, robust,
elegant and free.
WWW: http://beagle.sourceforge.net/

View File

@ -0,0 +1,23 @@
include/Threading/Condition.hpp
include/Threading/Exception.hpp
include/Threading/Mutex.hpp
include/Threading/Semaphore.hpp
include/Threading/Thread.hpp
include/Threading/Threading.hpp
@dirrm include/Threading
include/gzstream.h
lib/libThreading-2.1.3.so
lib/libThreading.a
lib/libThreading.so
lib/libbeagle-2.1.3.so
lib/libbeagle-Coev-2.1.3.so
lib/libbeagle-Coev.a
lib/libbeagle-Coev.so
lib/libbeagle-GA-2.1.3.so
lib/libbeagle-GA.a
lib/libbeagle-GA.so
lib/libbeagle-GP-2.1.3.so
lib/libbeagle-GP.a
lib/libbeagle-GP.so
lib/libbeagle.a
lib/libbeagle.so