Update to 1.1.5.

This commit is contained in:
Maxim Sobolev 2001-04-05 16:29:00 +00:00
parent 6b8216a241
commit 8699215ca2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40900
4 changed files with 48 additions and 35 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= moonshine
PORTVERSION= 1.1.3
PORTVERSION= 1.1.5
CATEGORIES= devel
MASTER_SITES= ftp://ftp.suite3220.com/pub/Moonshine/1.1/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@ -17,6 +17,7 @@ USE_QT_VER= 2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= QTDIR="${X11BASE}"
QTCPPFLAGS+= -I${X11BASE}/include
.include <bsd.port.pre.mk>

View File

@ -1 +1 @@
MD5 (moonshine-1.1.3-src.tar.gz) = 907851fc750cbc83fbbfe4bf229d4caf
MD5 (moonshine-1.1.5-src.tar.gz) = 3da0f0e27522c2b1d9fe609c1ac0afa5

View File

@ -1,6 +1,9 @@
--- configure.orig Thu Apr 20 21:14:45 2000
+++ configure Wed Apr 26 14:15:52 2000
@@ -1057,8 +1057,8 @@
$FreeBSD$
--- configure.orig Fri Dec 1 19:51:43 2000
+++ configure Thu Apr 5 17:17:27 2001
@@ -1056,8 +1056,8 @@
SET_MAKE="MAKE=${MAKE-make}"
fi
@ -9,35 +12,43 @@
+# Extract the first word of "moc2", so it can be a program name with args.
+set dummy moc2; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
echo "configure:1064: checking for $ac_word" >&5
echo "configure:1063: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_MOC'+set}'`\" = set"; then
@@ -1231,13 +1231,13 @@
do
echo $ac_n "checking "in $qtlib"""... $ac_c" 1>&6
echo "configure:1234: checking "in $qtlib"" >&5
- if test -r "$qtlib/libqt.a"; then
- checkversion=$(ar -t $qtlib/libqt.a qstringlist.o 2>&1)
+ if test -r "$qtlib/libqt2.a"; then
+ checkversion=$(ar -t $qtlib/libqt2.a qstringlist.o 2>&1)
if test "${checkversion}" = "qstringlist.o"; then
qt_lib_dir="$qtlib"
echo "$ac_t"""yes"" 1>&6
qt_lib_found=true
- QTLIB="-L${qt_lib_dir} -lqt -lX11 -lXext -static"
+ QTLIB="-L${qt_lib_dir} -lqt2 -lX11 -lXext -static"
break
fi
fi
@@ -1250,7 +1250,7 @@
fi
@@ -1213,10 +1213,10 @@
if test "${link_type}" = "static"; then
echo " Static link"
- libqt="libqt.a"
+ libqt="libqt2.a"
else
echo " Dynamic link"
- QTLIB="-lqt"
+ QTLIB="-lqt2"
- libqt="libqt.so.2"
+ libqt="libqt2.so"
fi
echo $ac_n "checking "for qt 2.0 or newer headers"""... $ac_c" 1>&6
echo "configure:1257: checking "for qt 2.0 or newer headers"" >&5
@@ -1258,15 +1258,15 @@
echo $ac_n "checking "for a qt 2.0 or newer library"""... $ac_c" 1>&6
echo "configure:1223: checking "for a qt 2.0 or newer library"" >&5
@@ -1238,7 +1238,7 @@
if test -r "$qtlib/$libqt"; then
if test "${link_type}" = "static"; then
ok="false"
- checkversion=$(ar -t $qtlib/libqt.a qstringlist.o 2>&1)
+ checkversion=$(ar -t $qtlib/libqt2.a qstringlist.o 2>&1)
if test "${checkversion}" = "qstringlist.o"; then
ok="true"
fi
@@ -1250,9 +1250,9 @@
echo "$ac_t"""yes"" 1>&6
qt_lib_found=true
if test "${link_type}" = "static"; then
- QTLIB="-L${qt_lib_dir} -lqt -L/usr/X11R6/lib -lX11 -lXext -lpng -static"
+ QTLIB="-L${qt_lib_dir} -lqt2 -L/usr/X11R6/lib -lX11 -lXext -lpng -static"
else
- QTLIB="-L${qt_lib_dir} -lqt"
+ QTLIB="-L${qt_lib_dir} -lqt2"
fi
break
fi
@@ -1270,15 +1270,15 @@
for qtinc in \
$qt_dir/include \
$QTDIR/include \
@ -60,12 +71,12 @@
/usr/local/qt/include \
/usr/lib/qt/include \
/usr/share/qt/include \
@@ -1292,7 +1292,7 @@
CXXFLAGS="-g"
@@ -1304,7 +1304,7 @@
CXXFLAGS="-g -pipe"
echo "will compile with debug symbols"
else
- CXXFLAGS="-O2"
+# CXXFLAGS="-O2"
- CXXFLAGS="-O2 -pipe"
+# CXXFLAGS="-O2 -pipe"
echo "will compile without debug symbols"
fi
INSTBIN="${bin_inst}"
if test -d ${qt_dir}; then

View File

@ -1,6 +1,7 @@
bin/moonshine
share/doc/moonshine/bugs.txt
share/doc/moonshine/changeLog.txt
share/doc/moonshine/doxyapi.cfg
share/doc/moonshine/ideas.txt
share/doc/moonshine/macroLanguageSpecs.txt
share/doc/moonshine/module.html