Update to 1.2.23.
This commit is contained in:
parent
8fc16efcd5
commit
863768a385
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=429965
@ -2,38 +2,52 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xmlsec1
|
||||
PORTVERSION= 1.2.22
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.2.23
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
|
||||
ftp://ftp.aleksey.com/pub/xmlsec/releases/ \
|
||||
ftp://ftp.xmlsoft.org/xmlsec/releases/ \
|
||||
ftp://ftp.rpmfind.net/pub/XML/xmlsec/releases/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= hrs@FreeBSD.org
|
||||
COMMENT= XML Security Library
|
||||
|
||||
LIB_DEPENDS= libltdl.so:devel/libltdl
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/Copyright
|
||||
|
||||
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
|
||||
libgpg-error.so:security/libgpg-error \
|
||||
libltdl.so:devel/libltdl
|
||||
|
||||
USES= libtool localbase pathfix pkgconfig ssl
|
||||
USE_GNOME= libxml2 libxslt
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-openssl="${OPENSSLBASE}" \
|
||||
--with-gcrypt="${LOCALBASE}"
|
||||
MAKE_ENV= ABS_BUILDDIR=${WRKSRC} TMPFOLDER=${WRKSRC}
|
||||
INSTALL_TARGET= install-strip
|
||||
PORTDOCS= api authors.html bugs.html c14n.html documentation.html \
|
||||
download.html faq.html favicon.ico images/bart.gif \
|
||||
images/libxml2-logo.png images/libxslt-logo.png \
|
||||
images/logo.gif images/openssl-logo.png \
|
||||
images/xmlsec-logo.gif index.html news.html related.html \
|
||||
xmldsig-verifier.html xmldsig.html xmlenc.html \
|
||||
xmlsec-man.html
|
||||
|
||||
OPTIONS_DEFINE= DOCS GNUTLS NSS
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
DOCS_MAKE_ENV= DOCS=docs
|
||||
GNUTLS_DESC= Enable GNUTLS support
|
||||
GNUTLS_CONFIGURE_WITH= gnutls="${LOCALBASE}"
|
||||
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
|
||||
NSS_DESC= Enable Mozilla's NSS support
|
||||
NSS_CONFIGURE_WITH= nss="${LOCALBASE}" nspr="${LOCALBASE}"
|
||||
NSS_LIB_DEPENDS= libnss3.so:security/nss
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
USES= libtool pathfix pkgconfig ssl
|
||||
USE_GNOME= libxml2 libxslt
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
MAKE_ENV+= ABS_BUILDDIR=${WRKSRC} TMPFOLDER=${WRKSRC} DOCS=docs
|
||||
CONFIGURE_ARGS+=--with-openssl="${OPENSSLBASE}"
|
||||
NSS_LIB_DEPENDS= libnss3.so:security/nss \
|
||||
libnspr4.so:devel/nspr \
|
||||
libplds4.so:devel/nspr \
|
||||
libplc4.so:devel/nspr
|
||||
|
||||
.if !defined(.PARSEDIR)
|
||||
MAKE_ARGS+= -EABS_BUILDDIR
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (xmlsec1-1.2.22.tar.gz) = 8c06bf161c565b907a499e6d906f0b640f063b2b4efd2b471048ac5b3c1ad527
|
||||
SIZE (xmlsec1-1.2.22.tar.gz) = 1792363
|
||||
TIMESTAMP = 1483094320
|
||||
SHA256 (xmlsec1-1.2.23.tar.gz) = 41d463d16c9894cd3317098d027c038039c6d896b9cbb9bad9c4e29959e10e9f
|
||||
SIZE (xmlsec1-1.2.23.tar.gz) = 1794694
|
||||
|
@ -1,32 +0,0 @@
|
||||
https://github.com/lsh123/xmlsec/pull/45
|
||||
|
||||
- LibreSSL:
|
||||
* defines OPENSSL_VERSION_NUMBER as 0x20000000L
|
||||
* deFines LIBRESS_VERSION_NUMBER in opensslv.h
|
||||
* was forked from 1.0.1f / 0x1000107fL
|
||||
|
||||
PR: https://bugs.freebsd.org/213301
|
||||
Reported by: Michael Gmelin <grembo@freebsd.org>
|
||||
|
||||
--- configure.ac.orig 2016-04-20 16:26:22 UTC
|
||||
+++ configure.ac
|
||||
@@ -495,7 +495,7 @@ if test "z$OPENSSL_FOUND" = "zyes" -a "z
|
||||
if test "z$OPENSSL_VERSION" = "z" ; then
|
||||
AC_EGREP_CPP(yes,[
|
||||
#include <openssl/opensslv.h>
|
||||
- #if OPENSSL_VERSION_NUMBER >= 0x10100000L
|
||||
+ #if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
|
||||
yes
|
||||
#endif
|
||||
],[
|
||||
--- configure.orig 2016-10-08 10:49:21 UTC
|
||||
+++ configure
|
||||
@@ -14258,7 +14258,7 @@ $as_echo_n "checking for openssl librari
|
||||
/* end confdefs.h. */
|
||||
|
||||
#include <openssl/opensslv.h>
|
||||
- #if OPENSSL_VERSION_NUMBER >= 0x10100000L
|
||||
+ #if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
|
||||
yes
|
||||
#endif
|
||||
|
@ -56,20 +56,20 @@ lib/libxmlsec1-gcrypt.so.1
|
||||
%%GNUTLS%%lib/libxmlsec1-gnutls.a
|
||||
%%GNUTLS%%lib/libxmlsec1-gnutls.so
|
||||
%%GNUTLS%%lib/libxmlsec1-gnutls.so.1
|
||||
%%GNUTLS%%lib/libxmlsec1-gnutls.so.1.2.22
|
||||
%%GNUTLS%%lib/libxmlsec1-gnutls.so.1.2.23
|
||||
%%NSS%%lib/libxmlsec1-nss.a
|
||||
%%NSS%%lib/libxmlsec1-nss.so
|
||||
%%NSS%%lib/libxmlsec1-nss.so.1
|
||||
%%NSS%%lib/libxmlsec1-nss.so.1.2.22
|
||||
lib/libxmlsec1-gcrypt.so.1.2.22
|
||||
%%NSS%%lib/libxmlsec1-nss.so.1.2.23
|
||||
lib/libxmlsec1-gcrypt.so.1.2.23
|
||||
lib/libxmlsec1-openssl.a
|
||||
lib/libxmlsec1-openssl.so
|
||||
lib/libxmlsec1-openssl.so.1
|
||||
lib/libxmlsec1-openssl.so.1.2.22
|
||||
lib/libxmlsec1-openssl.so.1.2.23
|
||||
lib/libxmlsec1.a
|
||||
lib/libxmlsec1.so
|
||||
lib/libxmlsec1.so.1
|
||||
lib/libxmlsec1.so.1.2.22
|
||||
lib/libxmlsec1.so.1.2.23
|
||||
libdata/pkgconfig/xmlsec1-gcrypt.pc
|
||||
%%GNUTLS%%libdata/pkgconfig/xmlsec1-gnutls.pc
|
||||
%%NSS%%libdata/pkgconfig/xmlsec1-nss.pc
|
||||
@ -78,142 +78,3 @@ libdata/pkgconfig/xmlsec1.pc
|
||||
man/man1/xmlsec1-config.1.gz
|
||||
man/man1/xmlsec1.1.gz
|
||||
share/aclocal/xmlsec1.m4
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/home.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/images/encryption-structure.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/images/key.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/images/keysmngr.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/images/sign-enc-model.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/images/signature-structure.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/images/structure.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/images/transform.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/images/transforms-chain.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/images/verif-dec-model.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/left.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/right.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/up.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-app.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-base64.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-bn.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-buffer.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-custom-keys-manager.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-decrypt-with-keys-mngr.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-decrypt-with-signle-key.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-dl.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-encrypt-dynamic-template.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-encrypt-template-file.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-encrypt-with-session-key.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-encryption-klasses.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-errors.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-examples-sign-dynamimc-template.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-examples-sign-template-file.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-examples-sign-x509.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-examples.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gcrypt-app.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gcrypt-crypto.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gcrypt-ref.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gnutls-app.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gnutls-crypto.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-gnutls-ref.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-io.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-keyinfo.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-keys.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-keysdata.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-keysmngr.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-list.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-membuf.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-app.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-certkeys.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-crypto.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-keysstore.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-ref.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-mscrypto-x509.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nodeset.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-compiling-others.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-compiling-unix.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-compiling-windows.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-compiling.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-contexts.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-custom-keys-store.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-decrypt.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-dynamic-encryption-templates.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-dynamic-signature-templates.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-encrypt.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-include-files.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-init-shutdown.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-keys-manager-sign-enc.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-keys-mngr-verify-decrypt.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-keys.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-keysmngr.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-functions.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-key-stores.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-keys.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-klasses.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-sharing-results.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-simple-keys-mngr.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-skeleton.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto-transforms.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-new-crypto.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-overview.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-sign-encrypt.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-sign-x509.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-sign.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-simple-keys-store.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-structure.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-templates.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-transforms.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-verify-decrypt.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-verify-x509.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-verify.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes-x509.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-notes.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-app.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-bignum.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-crypto.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-keysstore.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-pkikeys.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-ref.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-nss-x509.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-app.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-bn.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-crypto.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-evp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-ref.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-openssl-x509.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-parser.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-ref.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-reference.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-signature-klasses.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-templates.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-transforms.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-verify-with-key.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-verify-with-keys-mngr.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-verify-with-restrictions.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-verify-with-x509.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-version.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-x509.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-xmldsig.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-xmlenc.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-xmlsec.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/api/xmlsec-xmltree.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/authors.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/bugs.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/c14n.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/documentation.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/download.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/faq.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/favicon.ico
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/bart.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/libxml2-logo.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/libxslt-logo.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/logo.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/openssl-logo.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/xmlsec-logo.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/news.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/related.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/xmldsig-verifier.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/xmldsig.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/xmlenc.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/xmlsec-man.html
|
||||
|
Loading…
Reference in New Issue
Block a user