- Do not use imake for the build; use provided Makefile.noimake: this

allows to build it with bmake(1) (as well as other implementations)
- Unbreak the build against Clang (main() must return int)
- Sanitize formatting of the port description while I am here

Reported by:	marino
This commit is contained in:
Alexey Dokuchaev 2013-08-15 09:16:32 +00:00
parent cb1aaf68c6
commit 862f8cf6d4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=324755
3 changed files with 45 additions and 26 deletions

View File

@ -1,4 +1,4 @@
# Created by: shanee@augusta.de
# Created by: Andreas Kohout <shanee@rabbit.augusta.de>
# $FreeBSD$
PORTNAME= xtar
@ -11,11 +11,22 @@ MASTER_SITE_SUBDIR= utilities
MAINTAINER= ports@FreeBSD.org
COMMENT= View and manipulate contents of a tar file
USES= imake motif
USES= motif
USE_XORG= ice sm x11 xext xp xt
MAKE_ARGS= XMLIB="${MOTIFLIB}"
MAKEFILE= Makefile.noimake
ALL_TARGET= ${PORTNAME}
MAKE_ARGS= XINC="-I${LOCALBASE}/include" XMLIB="${MOTIFLIB}" \
APPDIR="${PREFIX}/lib/X11/app-defaults" \
BINDIR="${PREFIX}/bin" LIBDIR="${PREFIX}/lib/X11/xtar" \
MANDIR="${MAN1PREFIX}/man/man1" OPTIMISATION="${CFLAGS}" \
ANSIFLAG=-ansi CC="${CC}" RANLIB=:
MAN1= xtar.1
PLIST_FILES= bin/xtar lib/X11/xtar/xtar.doc lib/X11/app-defaults/XTar
PLIST_DIRS= lib/X11/xtar
post-patch:
@${REINPLACE_CMD} -e 's/pipe\.c/& regexpr.c/' \
${WRKSRC}/common/Makefile.noimake
.include <bsd.port.mk>

View File

@ -1,19 +1,28 @@
*** xtar.c.orig Wed Jul 31 18:16:22 1996
--- xtar.c Wed Jul 31 18:15:30 1996
***************
*** 1164,1170 ****
static int xtar_attributes(TAR_FILE *tf, char *filename)
{
int retval = 0;
! struct utimbuf utimbuf;
/* If the file type is not a directory then try and set the access
permissions. We exclude directories because if write permission
--- 1164,1170 ----
static int xtar_attributes(TAR_FILE *tf, char *filename)
{
int retval = 0;
! struct utimbuf {char utimbuf;} utimbuf;
/* If the file type is not a directory then try and set the access
permissions. We exclude directories because if write permission
--- xtar.c.orig 1995-07-17 19:44:19.000000000 +0800
+++ xtar.c 2013-08-15 17:00:58.000000000 +0800
@@ -33,6 +33,7 @@
#include <sys/stat.h>
#include <string.h>
#include <unistd.h>
+#include <stdlib.h>
#include <Xm/Xm.h>
#include <Xm/Form.h>
@@ -408,7 +409,7 @@
int argc = 1;
char **argv;
#else
-void main(int argc, char *argv[])
+int main(int argc, char *argv[])
{
char *mappings;
#endif
@@ -1164,7 +1165,7 @@
static int xtar_attributes(TAR_FILE *tf, char *filename)
{
int retval = 0;
- struct utimbuf utimbuf;
+ struct utimbuf {char utimbuf;} utimbuf;
/* If the file type is not a directory then try and set the access
permissions. We exclude directories because if write permission

View File

@ -1,4 +1,3 @@
XTar is a Motif program for viewing and manipulating tar
archives (which may be compressed). The contents of the
archive are displayed in the main window and various
options are available from pulldown and popup menus.
XTar is a Motif program for viewing and manipulating tar archives (which
may be compressed). The contents of the archive are displayed in the main
window and various options are available from pulldown and popup menus.