Update to version 1.99.5.
PR: 31722 Submitted by: KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
parent
9c45f91fe6
commit
860f319f2b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=49553
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= smalltalk
|
||||
PORTVERSION= 1.95.4
|
||||
PORTVERSION= 1.95.5
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -15,24 +15,17 @@ MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
ALL_TARGET= all optimize
|
||||
CONFIGURE_TARGET= # none
|
||||
CONFIGURE_ARGS= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
MAN1= gst.1
|
||||
|
||||
PLIST_SUB= VERSION=${PORTVERSION}
|
||||
|
||||
post-extract:
|
||||
@${RM} ${WRKSRC}/doc/gst.info*
|
||||
|
||||
pre-patch:
|
||||
@${PERL} -pi -e 's|-lregex|-lgnuregex|g ; \
|
||||
s|\$$\OPT_CFLAGS||g' ${WRKSRC}/configure
|
||||
|
||||
@find ${WRKSRC} -name 'Makefile.in' | xargs ${PERL} -pi -e \
|
||||
's|make mostlyclean|\$$\(MAKE\) mostlyclean|g ; \
|
||||
's| -release \$$\(VERSION\)| -avoid-version|g ; \
|
||||
s|\@MAKEINFO\@|\@MAKEINFO\@ --no-split|g'
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/libgst/.libs/libgst.a ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (smalltalk-1.95.4.tar.gz) = a8decec609613bfa4e41998f3cb1aacf
|
||||
MD5 (smalltalk-1.95.5.tar.gz) = 5f3464aa38a25afccc130e66cb390566
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- libgst/lex.c.orig Wed Dec 27 18:43:24 2000
|
||||
+++ libgst/lex.c Sat Feb 10 10:11:18 2001
|
||||
@@ -52,6 +52,9 @@
|
||||
#include <stdio.h>
|
||||
#include <ctype.h>
|
||||
#include <math.h>
|
||||
+#if defined(__FreeBSD__)
|
||||
+#include <floatingpoint.h>
|
||||
+#endif
|
||||
|
||||
#ifdef HAVE_READLINE
|
||||
#include <readline/readline.h>
|
||||
@@ -764,6 +767,9 @@
|
||||
if (isNegative) {
|
||||
num = -num;
|
||||
}
|
||||
+#if defined(__FreeBSD__)
|
||||
+ fpsetmask(0);
|
||||
+#endif
|
||||
|
||||
if (isFloat) {
|
||||
lvalp->fval = num;
|
20
lang/smalltalk/files/patch-ltmain.sh
Normal file
20
lang/smalltalk/files/patch-ltmain.sh
Normal file
@ -0,0 +1,20 @@
|
||||
--- ltmain.sh.orig Thu Apr 26 19:21:26 2001
|
||||
+++ ltmain.sh Fri Nov 2 02:58:37 2001
|
||||
@@ -961,6 +961,7 @@
|
||||
;;
|
||||
|
||||
-avoid-version)
|
||||
+ build_old_libs=no
|
||||
avoid_version=yes
|
||||
continue
|
||||
;;
|
||||
@@ -2424,6 +2425,9 @@
|
||||
;;
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
+ ;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
@ -7,248 +7,245 @@ include/gstpub.h
|
||||
info/gst.info
|
||||
@exec install-info %D/info/gst.info %D/info/dir
|
||||
lib/libgst.a
|
||||
lib/gnu-smalltalk/libregex-%%VERSION%%.so
|
||||
lib/gnu-smalltalk/libregex.a
|
||||
lib/gnu-smalltalk/libregex.la
|
||||
lib/gnu-smalltalk/libregex.so
|
||||
lib/gnu-smalltalk/libtcp-%%VERSION%%.so
|
||||
lib/gnu-smalltalk/libtcp.a
|
||||
lib/gnu-smalltalk/libtcp.la
|
||||
lib/gnu-smalltalk/libtcp.so
|
||||
share/gnu-smalltalk/Load.st
|
||||
share/gnu-smalltalk/Reload.st
|
||||
share/gnu-smalltalk/blox/BrowShell.st
|
||||
share/gnu-smalltalk/blox/BrowserMain.st
|
||||
share/gnu-smalltalk/blox/ClassBrow.st
|
||||
share/gnu-smalltalk/blox/Colors.txt
|
||||
share/gnu-smalltalk/blox/CtxtInspect.st
|
||||
share/gnu-smalltalk/blox/DictInspect.st
|
||||
share/gnu-smalltalk/blox/GuiData.st
|
||||
share/gnu-smalltalk/blox/Inspector.st
|
||||
share/gnu-smalltalk/blox/Load.st
|
||||
share/gnu-smalltalk/blox/Manager.st
|
||||
share/gnu-smalltalk/blox/Menu.st
|
||||
share/gnu-smalltalk/blox/MethInspect.st
|
||||
share/gnu-smalltalk/blox/MethSetBrow.st
|
||||
share/gnu-smalltalk/blox/ModalDialog.st
|
||||
share/gnu-smalltalk/blox/Notifier.st
|
||||
share/gnu-smalltalk/blox/PCode.st
|
||||
share/gnu-smalltalk/blox/PList.st
|
||||
share/gnu-smalltalk/blox/PText.st
|
||||
share/gnu-smalltalk/blox/RadioForm.st
|
||||
share/gnu-smalltalk/blox/Run.st
|
||||
share/gnu-smalltalk/blox/StrcInspect.st
|
||||
share/gnu-smalltalk/blox/View.st
|
||||
share/gnu-smalltalk/blox/bear.gif
|
||||
share/gnu-smalltalk/blox/test.st
|
||||
share/gnu-smalltalk/blox/tk/Blox.st
|
||||
share/gnu-smalltalk/blox/tk/BloxBasic.st
|
||||
share/gnu-smalltalk/blox/tk/BloxCanvas.st
|
||||
share/gnu-smalltalk/blox/tk/BloxExtend.st
|
||||
share/gnu-smalltalk/blox/tk/BloxText.st
|
||||
share/gnu-smalltalk/blox/tk/BloxWidgets.st
|
||||
share/gnu-smalltalk/compiler/Load.st
|
||||
share/gnu-smalltalk/compiler/STCompLit.st
|
||||
share/gnu-smalltalk/compiler/STCompiler.st
|
||||
share/gnu-smalltalk/compiler/STFormatter.st
|
||||
share/gnu-smalltalk/compiler/STParseNodes.st
|
||||
share/gnu-smalltalk/compiler/STParser.st
|
||||
share/gnu-smalltalk/compiler/STSymTable.st
|
||||
share/gnu-smalltalk/compiler/STTok.st
|
||||
share/gnu-smalltalk/compiler/STToken.st
|
||||
share/gnu-smalltalk/compiler/STVisitor.st
|
||||
share/gnu-smalltalk/compiler/StartCompiler.st
|
||||
share/gnu-smalltalk/examples/Application.st
|
||||
share/gnu-smalltalk/examples/Bench.st
|
||||
share/gnu-smalltalk/examples/Buffers.st
|
||||
share/gnu-smalltalk/examples/Case.st
|
||||
share/gnu-smalltalk/examples/CompFileSeg.st
|
||||
share/gnu-smalltalk/examples/DBFile.st
|
||||
share/gnu-smalltalk/examples/Debugger.st
|
||||
share/gnu-smalltalk/examples/Dinner.st
|
||||
share/gnu-smalltalk/examples/EditStream.st
|
||||
share/gnu-smalltalk/examples/GenClasses.st
|
||||
share/gnu-smalltalk/examples/Lisp.st
|
||||
share/gnu-smalltalk/examples/MemUsage.st
|
||||
share/gnu-smalltalk/examples/Prolog.st
|
||||
share/gnu-smalltalk/examples/PrtHier.st
|
||||
share/gnu-smalltalk/examples/Publish.st
|
||||
share/gnu-smalltalk/examples/PushBack.st
|
||||
share/gnu-smalltalk/examples/Queens.st
|
||||
share/gnu-smalltalk/examples/README
|
||||
share/gnu-smalltalk/examples/RandomInt.st
|
||||
share/gnu-smalltalk/examples/RecursLit.st
|
||||
share/gnu-smalltalk/examples/RegExp.st
|
||||
share/gnu-smalltalk/examples/Richards.st
|
||||
share/gnu-smalltalk/examples/SortCriter.st
|
||||
share/gnu-smalltalk/examples/Timer.st
|
||||
share/gnu-smalltalk/examples/Tokenizer.st
|
||||
share/gnu-smalltalk/examples/Watchdog.st
|
||||
share/gnu-smalltalk/examples/blox/Man.st
|
||||
share/gnu-smalltalk/examples/blox/Tetris.st
|
||||
share/gnu-smalltalk/examples/modules/gdbm-c.st
|
||||
share/gnu-smalltalk/examples/modules/gdbm.st
|
||||
share/gnu-smalltalk/examples/modules/regex.st
|
||||
share/gnu-smalltalk/examples/shell
|
||||
share/gnu-smalltalk/gst.im
|
||||
share/gnu-smalltalk/i18n/Collation.st
|
||||
share/gnu-smalltalk/i18n/GetText.st
|
||||
share/gnu-smalltalk/i18n/Load.st
|
||||
share/gnu-smalltalk/i18n/Locale.st
|
||||
share/gnu-smalltalk/i18n/Numbers.st
|
||||
share/gnu-smalltalk/i18n/Set-0208.st
|
||||
share/gnu-smalltalk/i18n/Set-BIG5.st
|
||||
share/gnu-smalltalk/i18n/Set-EUC.st
|
||||
share/gnu-smalltalk/i18n/Set-GB.st
|
||||
share/gnu-smalltalk/i18n/Set-SBCS.st
|
||||
share/gnu-smalltalk/i18n/Set-SJIS.st
|
||||
share/gnu-smalltalk/i18n/Sets.st
|
||||
share/gnu-smalltalk/i18n/Times.st
|
||||
share/gnu-smalltalk/kernel/AnsiDates.st
|
||||
share/gnu-smalltalk/kernel/AnsiExcept.st
|
||||
share/gnu-smalltalk/kernel/Array.st
|
||||
share/gnu-smalltalk/kernel/ArrayColl.st
|
||||
share/gnu-smalltalk/kernel/Association.st
|
||||
share/gnu-smalltalk/kernel/Autoload.st
|
||||
share/gnu-smalltalk/kernel/Bag.st
|
||||
share/gnu-smalltalk/kernel/Behavior.st
|
||||
share/gnu-smalltalk/kernel/BlkClosure.st
|
||||
share/gnu-smalltalk/kernel/BlkContext.st
|
||||
share/gnu-smalltalk/kernel/Boolean.st
|
||||
share/gnu-smalltalk/kernel/Browser.st
|
||||
share/gnu-smalltalk/kernel/Builtins.st
|
||||
share/gnu-smalltalk/kernel/ByteArray.st
|
||||
share/gnu-smalltalk/kernel/ByteStream.st
|
||||
share/gnu-smalltalk/kernel/CFuncs.st
|
||||
share/gnu-smalltalk/kernel/CObject.st
|
||||
share/gnu-smalltalk/kernel/CStruct.st
|
||||
share/gnu-smalltalk/kernel/CType.st
|
||||
share/gnu-smalltalk/kernel/CharArray.st
|
||||
share/gnu-smalltalk/kernel/Character.st
|
||||
share/gnu-smalltalk/kernel/Class.st
|
||||
share/gnu-smalltalk/kernel/ClassDesc.st
|
||||
share/gnu-smalltalk/kernel/Collection.st
|
||||
share/gnu-smalltalk/kernel/CompildCode.st
|
||||
share/gnu-smalltalk/kernel/CompildMeth.st
|
||||
share/gnu-smalltalk/kernel/CompiledBlk.st
|
||||
share/gnu-smalltalk/kernel/ContextPart.st
|
||||
share/gnu-smalltalk/kernel/DLD.st
|
||||
share/gnu-smalltalk/kernel/Date.st
|
||||
share/gnu-smalltalk/kernel/Delay.st
|
||||
share/gnu-smalltalk/kernel/Dictionary.st
|
||||
share/gnu-smalltalk/kernel/DirMessage.st
|
||||
share/gnu-smalltalk/kernel/Directory.st
|
||||
share/gnu-smalltalk/kernel/ExcHandling.st
|
||||
share/gnu-smalltalk/kernel/False.st
|
||||
share/gnu-smalltalk/kernel/File.st
|
||||
share/gnu-smalltalk/kernel/FileSegment.st
|
||||
share/gnu-smalltalk/kernel/FileStream.st
|
||||
share/gnu-smalltalk/kernel/Float.st
|
||||
share/gnu-smalltalk/kernel/Fraction.st
|
||||
share/gnu-smalltalk/kernel/HashedColl.st
|
||||
share/gnu-smalltalk/kernel/IdentDict.st
|
||||
share/gnu-smalltalk/kernel/IdentitySet.st
|
||||
share/gnu-smalltalk/kernel/Integer.st
|
||||
share/gnu-smalltalk/kernel/Interval.st
|
||||
share/gnu-smalltalk/kernel/LargeInt.st
|
||||
share/gnu-smalltalk/kernel/Link.st
|
||||
share/gnu-smalltalk/kernel/LinkedList.st
|
||||
share/gnu-smalltalk/kernel/LookupKey.st
|
||||
share/gnu-smalltalk/kernel/LookupTable.st
|
||||
share/gnu-smalltalk/kernel/Magnitude.st
|
||||
share/gnu-smalltalk/kernel/MappedColl.st
|
||||
share/gnu-smalltalk/kernel/Memory.st
|
||||
share/gnu-smalltalk/kernel/Message.st
|
||||
share/gnu-smalltalk/kernel/Metaclass.st
|
||||
share/gnu-smalltalk/kernel/MethodDict.st
|
||||
share/gnu-smalltalk/kernel/MethodInfo.st
|
||||
share/gnu-smalltalk/kernel/MthContext.st
|
||||
share/gnu-smalltalk/kernel/Namespace.st
|
||||
share/gnu-smalltalk/kernel/Number.st
|
||||
share/gnu-smalltalk/kernel/ObjDumper.st
|
||||
share/gnu-smalltalk/kernel/Object.st
|
||||
share/gnu-smalltalk/kernel/OrderColl.st
|
||||
share/gnu-smalltalk/kernel/OtherArrays.st
|
||||
share/gnu-smalltalk/kernel/PkgLoader.st
|
||||
share/gnu-smalltalk/kernel/Point.st
|
||||
share/gnu-smalltalk/kernel/PosStream.st
|
||||
share/gnu-smalltalk/kernel/ProcSched.st
|
||||
share/gnu-smalltalk/kernel/Process.st
|
||||
share/gnu-smalltalk/kernel/RWStream.st
|
||||
share/gnu-smalltalk/kernel/Random.st
|
||||
share/gnu-smalltalk/kernel/ReadStream.st
|
||||
share/gnu-smalltalk/kernel/Rectangle.st
|
||||
share/gnu-smalltalk/kernel/RootNamespc.st
|
||||
share/gnu-smalltalk/kernel/RunArray.st
|
||||
share/gnu-smalltalk/kernel/ScaledDec.st
|
||||
share/gnu-smalltalk/kernel/Semaphore.st
|
||||
share/gnu-smalltalk/kernel/SeqCollect.st
|
||||
share/gnu-smalltalk/kernel/Set.st
|
||||
share/gnu-smalltalk/kernel/SharedQueue.st
|
||||
share/gnu-smalltalk/kernel/SmallInt.st
|
||||
share/gnu-smalltalk/kernel/SortCollect.st
|
||||
share/gnu-smalltalk/kernel/Stream.st
|
||||
share/gnu-smalltalk/kernel/String.st
|
||||
share/gnu-smalltalk/kernel/SymLink.st
|
||||
share/gnu-smalltalk/kernel/Symbol.st
|
||||
share/gnu-smalltalk/kernel/SysDict.st
|
||||
share/gnu-smalltalk/kernel/Time.st
|
||||
share/gnu-smalltalk/kernel/TokenStream.st
|
||||
share/gnu-smalltalk/kernel/Transcript.st
|
||||
share/gnu-smalltalk/kernel/True.st
|
||||
share/gnu-smalltalk/kernel/UndefObject.st
|
||||
share/gnu-smalltalk/kernel/ValueAdapt.st
|
||||
share/gnu-smalltalk/kernel/WeakObjects.st
|
||||
share/gnu-smalltalk/kernel/WriteStream.st
|
||||
share/gnu-smalltalk/kernel/initialize.st
|
||||
share/gnu-smalltalk/packages
|
||||
share/gnu-smalltalk/sunit/SUnit.st
|
||||
share/gnu-smalltalk/sunit/SUnitPreload.st
|
||||
share/gnu-smalltalk/sunit/SUnitScript.st
|
||||
share/gnu-smalltalk/sunit/SUnitTests.st
|
||||
share/gnu-smalltalk/tcp/AbstractSocketImpl.st
|
||||
share/gnu-smalltalk/tcp/ContentHandler.st
|
||||
share/gnu-smalltalk/tcp/Datagram.st
|
||||
share/gnu-smalltalk/tcp/IPSocketImpl.st
|
||||
share/gnu-smalltalk/tcp/SocketAddress.st
|
||||
share/gnu-smalltalk/tcp/Sockets.st
|
||||
share/gnu-smalltalk/tcp/TCP.st
|
||||
share/gnu-smalltalk/tcp/Tests.st
|
||||
share/gnu-smalltalk/tcp/URL.st
|
||||
share/gnu-smalltalk/tcp/UnixStream.st
|
||||
share/gnu-smalltalk/tcp/cfuncs.st
|
||||
share/gnu-smalltalk/tcp/init.st
|
||||
share/gnu-smalltalk/web/FileServer.st
|
||||
share/gnu-smalltalk/web/Haiku.st
|
||||
share/gnu-smalltalk/web/Load.st
|
||||
share/gnu-smalltalk/web/NetServer.st
|
||||
share/gnu-smalltalk/web/WebServer.st
|
||||
share/gnu-smalltalk/web/WikiServer.st
|
||||
share/gnu-smalltalk/web/edit.jpg
|
||||
share/gnu-smalltalk/web/find.jpg
|
||||
share/gnu-smalltalk/web/head.jpg
|
||||
share/gnu-smalltalk/web/help.jpg
|
||||
share/gnu-smalltalk/web/history.jpg
|
||||
share/gnu-smalltalk/web/next.jpg
|
||||
share/gnu-smalltalk/web/prev.jpg
|
||||
share/gnu-smalltalk/web/recent.jpg
|
||||
share/gnu-smalltalk/web/rename.jpg
|
||||
share/gnu-smalltalk/web/test.st
|
||||
share/gnu-smalltalk/web/top.jpg
|
||||
share/gnu-smalltalk/xml/Id-DOM.st
|
||||
share/gnu-smalltalk/xml/Id-XWalker.st
|
||||
share/gnu-smalltalk/xml/XML.st
|
||||
@dirrm share/gnu-smalltalk/xml
|
||||
@dirrm share/gnu-smalltalk/web
|
||||
@dirrm share/gnu-smalltalk/tcp
|
||||
@dirrm share/gnu-smalltalk/sunit
|
||||
@dirrm share/gnu-smalltalk/kernel
|
||||
@dirrm share/gnu-smalltalk/i18n
|
||||
@dirrm share/gnu-smalltalk/examples/modules
|
||||
@dirrm share/gnu-smalltalk/examples/blox
|
||||
@dirrm share/gnu-smalltalk/examples
|
||||
@dirrm share/gnu-smalltalk/compiler
|
||||
@dirrm share/gnu-smalltalk/blox/tk
|
||||
@dirrm share/gnu-smalltalk/blox
|
||||
@dirrm share/gnu-smalltalk
|
||||
@dirrm lib/gnu-smalltalk
|
||||
lib/libgst.la
|
||||
lib/smalltalk/md5.la
|
||||
lib/smalltalk/md5.so
|
||||
lib/smalltalk/regex.la
|
||||
lib/smalltalk/regex.so
|
||||
lib/smalltalk/tcp.la
|
||||
lib/smalltalk/tcp.so
|
||||
share/smalltalk/Load.st
|
||||
share/smalltalk/Reload.st
|
||||
share/smalltalk/blox/BrowShell.st
|
||||
share/smalltalk/blox/BrowserMain.st
|
||||
share/smalltalk/blox/ClassBrow.st
|
||||
share/smalltalk/blox/Colors.txt
|
||||
share/smalltalk/blox/CtxtInspect.st
|
||||
share/smalltalk/blox/DictInspect.st
|
||||
share/smalltalk/blox/GuiData.st
|
||||
share/smalltalk/blox/Inspector.st
|
||||
share/smalltalk/blox/Load.st
|
||||
share/smalltalk/blox/Manager.st
|
||||
share/smalltalk/blox/Menu.st
|
||||
share/smalltalk/blox/MethInspect.st
|
||||
share/smalltalk/blox/MethSetBrow.st
|
||||
share/smalltalk/blox/ModalDialog.st
|
||||
share/smalltalk/blox/Notifier.st
|
||||
share/smalltalk/blox/PCode.st
|
||||
share/smalltalk/blox/PList.st
|
||||
share/smalltalk/blox/PText.st
|
||||
share/smalltalk/blox/RadioForm.st
|
||||
share/smalltalk/blox/Run.st
|
||||
share/smalltalk/blox/StrcInspect.st
|
||||
share/smalltalk/blox/View.st
|
||||
share/smalltalk/blox/bear.gif
|
||||
share/smalltalk/blox/test.st
|
||||
share/smalltalk/blox/tk/Blox.st
|
||||
share/smalltalk/blox/tk/BloxBasic.st
|
||||
share/smalltalk/blox/tk/BloxCanvas.st
|
||||
share/smalltalk/blox/tk/BloxExtend.st
|
||||
share/smalltalk/blox/tk/BloxText.st
|
||||
share/smalltalk/blox/tk/BloxWidgets.st
|
||||
share/smalltalk/compiler/Load.st
|
||||
share/smalltalk/compiler/STCompLit.st
|
||||
share/smalltalk/compiler/STCompiler.st
|
||||
share/smalltalk/compiler/STFormatter.st
|
||||
share/smalltalk/compiler/STParseNodes.st
|
||||
share/smalltalk/compiler/STParser.st
|
||||
share/smalltalk/compiler/STSymTable.st
|
||||
share/smalltalk/compiler/STTok.st
|
||||
share/smalltalk/compiler/STToken.st
|
||||
share/smalltalk/compiler/STVisitor.st
|
||||
share/smalltalk/compiler/StartCompiler.st
|
||||
share/smalltalk/examples/Application.st
|
||||
share/smalltalk/examples/Bench.st
|
||||
share/smalltalk/examples/Buffers.st
|
||||
share/smalltalk/examples/Case.st
|
||||
share/smalltalk/examples/CompFileSeg.st
|
||||
share/smalltalk/examples/DBFile.st
|
||||
share/smalltalk/examples/Debugger.st
|
||||
share/smalltalk/examples/Dinner.st
|
||||
share/smalltalk/examples/EditStream.st
|
||||
share/smalltalk/examples/GenClasses.st
|
||||
share/smalltalk/examples/Lisp.st
|
||||
share/smalltalk/examples/MemUsage.st
|
||||
share/smalltalk/examples/Prolog.st
|
||||
share/smalltalk/examples/PrtHier.st
|
||||
share/smalltalk/examples/Publish.st
|
||||
share/smalltalk/examples/PushBack.st
|
||||
share/smalltalk/examples/Queens.st
|
||||
share/smalltalk/examples/README
|
||||
share/smalltalk/examples/RandomInt.st
|
||||
share/smalltalk/examples/RecursLit.st
|
||||
share/smalltalk/examples/RegExp.st
|
||||
share/smalltalk/examples/Richards.st
|
||||
share/smalltalk/examples/SortCriter.st
|
||||
share/smalltalk/examples/Timer.st
|
||||
share/smalltalk/examples/Tokenizer.st
|
||||
share/smalltalk/examples/Watchdog.st
|
||||
share/smalltalk/examples/blox/Man.st
|
||||
share/smalltalk/examples/blox/Tetris.st
|
||||
share/smalltalk/examples/modules/gdbm-c.st
|
||||
share/smalltalk/examples/modules/gdbm.st
|
||||
share/smalltalk/examples/modules/md5.st
|
||||
share/smalltalk/examples/modules/regex.st
|
||||
share/smalltalk/examples/pepe.sed
|
||||
share/smalltalk/examples/shell
|
||||
share/smalltalk/examples/xml.sed
|
||||
share/smalltalk/gst.im
|
||||
share/smalltalk/i18n/Collation.st
|
||||
share/smalltalk/i18n/GetText.st
|
||||
share/smalltalk/i18n/Load.st
|
||||
share/smalltalk/i18n/Locale.st
|
||||
share/smalltalk/i18n/Numbers.st
|
||||
share/smalltalk/i18n/Sets.st
|
||||
share/smalltalk/i18n/Times.st
|
||||
share/smalltalk/kernel/AnsiDates.st
|
||||
share/smalltalk/kernel/AnsiExcept.st
|
||||
share/smalltalk/kernel/Array.st
|
||||
share/smalltalk/kernel/ArrayColl.st
|
||||
share/smalltalk/kernel/Association.st
|
||||
share/smalltalk/kernel/Autoload.st
|
||||
share/smalltalk/kernel/Bag.st
|
||||
share/smalltalk/kernel/Behavior.st
|
||||
share/smalltalk/kernel/BlkClosure.st
|
||||
share/smalltalk/kernel/BlkContext.st
|
||||
share/smalltalk/kernel/Boolean.st
|
||||
share/smalltalk/kernel/Browser.st
|
||||
share/smalltalk/kernel/Builtins.st
|
||||
share/smalltalk/kernel/ByteArray.st
|
||||
share/smalltalk/kernel/ByteStream.st
|
||||
share/smalltalk/kernel/CFuncs.st
|
||||
share/smalltalk/kernel/CObject.st
|
||||
share/smalltalk/kernel/CStruct.st
|
||||
share/smalltalk/kernel/CType.st
|
||||
share/smalltalk/kernel/CharArray.st
|
||||
share/smalltalk/kernel/Character.st
|
||||
share/smalltalk/kernel/Class.st
|
||||
share/smalltalk/kernel/ClassDesc.st
|
||||
share/smalltalk/kernel/Collection.st
|
||||
share/smalltalk/kernel/CompildCode.st
|
||||
share/smalltalk/kernel/CompildMeth.st
|
||||
share/smalltalk/kernel/CompiledBlk.st
|
||||
share/smalltalk/kernel/ContextPart.st
|
||||
share/smalltalk/kernel/DLD.st
|
||||
share/smalltalk/kernel/Date.st
|
||||
share/smalltalk/kernel/Delay.st
|
||||
share/smalltalk/kernel/Dictionary.st
|
||||
share/smalltalk/kernel/DirMessage.st
|
||||
share/smalltalk/kernel/Directory.st
|
||||
share/smalltalk/kernel/ExcHandling.st
|
||||
share/smalltalk/kernel/False.st
|
||||
share/smalltalk/kernel/File.st
|
||||
share/smalltalk/kernel/FileDescr.st
|
||||
share/smalltalk/kernel/FileSegment.st
|
||||
share/smalltalk/kernel/FileStream.st
|
||||
share/smalltalk/kernel/Float.st
|
||||
share/smalltalk/kernel/Fraction.st
|
||||
share/smalltalk/kernel/HashedColl.st
|
||||
share/smalltalk/kernel/IdentDict.st
|
||||
share/smalltalk/kernel/IdentitySet.st
|
||||
share/smalltalk/kernel/Integer.st
|
||||
share/smalltalk/kernel/Interval.st
|
||||
share/smalltalk/kernel/LargeInt.st
|
||||
share/smalltalk/kernel/Link.st
|
||||
share/smalltalk/kernel/LinkedList.st
|
||||
share/smalltalk/kernel/LookupKey.st
|
||||
share/smalltalk/kernel/LookupTable.st
|
||||
share/smalltalk/kernel/Magnitude.st
|
||||
share/smalltalk/kernel/MappedColl.st
|
||||
share/smalltalk/kernel/Memory.st
|
||||
share/smalltalk/kernel/Message.st
|
||||
share/smalltalk/kernel/Metaclass.st
|
||||
share/smalltalk/kernel/MethodDict.st
|
||||
share/smalltalk/kernel/MethodInfo.st
|
||||
share/smalltalk/kernel/MthContext.st
|
||||
share/smalltalk/kernel/Namespace.st
|
||||
share/smalltalk/kernel/Number.st
|
||||
share/smalltalk/kernel/ObjDumper.st
|
||||
share/smalltalk/kernel/ObjMemory.st
|
||||
share/smalltalk/kernel/Object.st
|
||||
share/smalltalk/kernel/OrderColl.st
|
||||
share/smalltalk/kernel/OtherArrays.st
|
||||
share/smalltalk/kernel/PkgLoader.st
|
||||
share/smalltalk/kernel/Point.st
|
||||
share/smalltalk/kernel/PosStream.st
|
||||
share/smalltalk/kernel/ProcSched.st
|
||||
share/smalltalk/kernel/Process.st
|
||||
share/smalltalk/kernel/RWStream.st
|
||||
share/smalltalk/kernel/Random.st
|
||||
share/smalltalk/kernel/ReadStream.st
|
||||
share/smalltalk/kernel/Rectangle.st
|
||||
share/smalltalk/kernel/RootNamespc.st
|
||||
share/smalltalk/kernel/RunArray.st
|
||||
share/smalltalk/kernel/ScaledDec.st
|
||||
share/smalltalk/kernel/Semaphore.st
|
||||
share/smalltalk/kernel/SeqCollect.st
|
||||
share/smalltalk/kernel/Set.st
|
||||
share/smalltalk/kernel/SharedQueue.st
|
||||
share/smalltalk/kernel/SmallInt.st
|
||||
share/smalltalk/kernel/SortCollect.st
|
||||
share/smalltalk/kernel/Stream.st
|
||||
share/smalltalk/kernel/String.st
|
||||
share/smalltalk/kernel/SymLink.st
|
||||
share/smalltalk/kernel/Symbol.st
|
||||
share/smalltalk/kernel/SysDict.st
|
||||
share/smalltalk/kernel/Time.st
|
||||
share/smalltalk/kernel/TokenStream.st
|
||||
share/smalltalk/kernel/Transcript.st
|
||||
share/smalltalk/kernel/True.st
|
||||
share/smalltalk/kernel/UndefObject.st
|
||||
share/smalltalk/kernel/ValueAdapt.st
|
||||
share/smalltalk/kernel/WeakObjects.st
|
||||
share/smalltalk/kernel/WriteStream.st
|
||||
share/smalltalk/packages
|
||||
share/smalltalk/sunit/SUnit.st
|
||||
share/smalltalk/sunit/SUnitPreload.st
|
||||
share/smalltalk/sunit/SUnitScript.st
|
||||
share/smalltalk/sunit/SUnitTests.st
|
||||
share/smalltalk/tcp/AbstractSocketImpl.st
|
||||
share/smalltalk/tcp/ContentHandler.st
|
||||
share/smalltalk/tcp/Datagram.st
|
||||
share/smalltalk/tcp/IPSocketImpl.st
|
||||
share/smalltalk/tcp/SocketAddress.st
|
||||
share/smalltalk/tcp/Sockets.st
|
||||
share/smalltalk/tcp/TCP.st
|
||||
share/smalltalk/tcp/Tests.st
|
||||
share/smalltalk/tcp/URL.st
|
||||
share/smalltalk/tcp/cfuncs.st
|
||||
share/smalltalk/tcp/init.st
|
||||
share/smalltalk/web/FileServer.st
|
||||
share/smalltalk/web/Haiku.st
|
||||
share/smalltalk/web/Load.st
|
||||
share/smalltalk/web/NetServer.st
|
||||
share/smalltalk/web/WebServer.st
|
||||
share/smalltalk/web/WikiServer.st
|
||||
share/smalltalk/web/edit.jpg
|
||||
share/smalltalk/web/find.jpg
|
||||
share/smalltalk/web/head.jpg
|
||||
share/smalltalk/web/help.jpg
|
||||
share/smalltalk/web/history.jpg
|
||||
share/smalltalk/web/next.jpg
|
||||
share/smalltalk/web/prev.jpg
|
||||
share/smalltalk/web/recent.jpg
|
||||
share/smalltalk/web/rename.jpg
|
||||
share/smalltalk/web/test.st
|
||||
share/smalltalk/web/top.jpg
|
||||
share/smalltalk/xml/Id-DOM.st
|
||||
share/smalltalk/xml/Id-XWalker.st
|
||||
share/smalltalk/xml/XML.st
|
||||
@dirrm share/smalltalk/xml
|
||||
@dirrm share/smalltalk/web
|
||||
@dirrm share/smalltalk/tcp
|
||||
@dirrm share/smalltalk/sunit
|
||||
@dirrm share/smalltalk/kernel
|
||||
@dirrm share/smalltalk/i18n
|
||||
@dirrm share/smalltalk/examples/modules
|
||||
@dirrm share/smalltalk/examples/blox
|
||||
@dirrm share/smalltalk/examples
|
||||
@dirrm share/smalltalk/compiler
|
||||
@dirrm share/smalltalk/blox/tk
|
||||
@dirrm share/smalltalk/blox/gtk
|
||||
@dirrm share/smalltalk/blox
|
||||
@dirrm share/smalltalk
|
||||
@dirrm lib/smalltalk
|
||||
|
Loading…
Reference in New Issue
Block a user