- Add master site SF

- Take maintainership
- Add licenses (GPLv2)
- Use the new format for LIB_DEPENDS
- Add USES desktop-file-utils
- Disable all warnings with -w
- Support STAGEDIR
- Add DOCS and Option
- Use REINPLACE_CMD instead of simple patches
- Recreate patches with make makepatch
- Change pkg-descr, use only one WWW

PR:		ports/173350
Submitted by:	nemysis (self)
This commit is contained in:
Rusmir Dusko 2014-01-16 15:46:26 +00:00
parent 0101c45d3d
commit 85d8420fa4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=339924
4 changed files with 35 additions and 33 deletions

View File

@ -5,26 +5,39 @@ PORTNAME= ppracer
DISTVERSION= 0.5alpha
PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= BERLIOS
MASTER_SITES= BERLIOS \
SF/${PORTNAME}.berlios/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= nemysis@FreeBSD.org
COMMENT= 3D downhill racing game... kind of like TuxRacer Improved
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2
LICENSE= GPLv2
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USES= gmake pkgconfig dos2unix
USES= gmake pkgconfig dos2unix desktop-file-utils
DOS2UNIX_REGEX= .*\.(c|cpp|h)
USE_SDL= mixer sdl
USE_GL= gl
GNU_CONFIGURE= yes
DOS2UNIX_REGEX= .*\.(c|cpp|h)
USE_XORG= x11 xi xext xmu xt
GNU_CONFIGURE= yes
CFLAGS+= -w
PORTDOCS= AUTHORS ChangeLog ChangeLog-pre0.3.9 ChangeLog-tuxracer
OPTIONS_DEFINE= DOCS
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
-e 's,libpng12,libpng15,g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's,RacingMode::,,' ${WRKSRC}/src/racingmode.h
@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' \
-e 's|libpng12|libpng15|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|RacingMode::||' ${WRKSRC}/src/racingmode.h
@${REINPLACE_CMD} -e 's|int SQHash|long SQHash|' \
${WRKSRC}/src/squirrel/squirrel.h
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View File

@ -1,11 +0,0 @@
--- src/squirrel/squirrel.h.orig 2007-08-12 19:46:49.000000000 +0200
+++ src/squirrel/squirrel.h 2007-08-12 19:47:31.000000000 +0200
@@ -44,7 +44,7 @@
typedef int SQInt32; //must be 32 bits(also on 64bits processors)
typedef void* SQUserPointer;
typedef unsigned int SQUnsignedInteger;
-typedef unsigned int SQHash; //should be the same size of a pointer
+typedef unsigned long SQHash; //should be the same size of a pointer
typedef SQUnsignedInteger SQBool;
typedef SQInteger SQRESULT;

View File

@ -1,5 +1,5 @@
--- src/squirrel/squtils.h.orig 2013-08-28 21:59:50.137272814 +0400
+++ src/squirrel/squtils.h 2013-08-28 22:00:43.376227477 +0400
--- ./src/squirrel/squtils.h.orig 2014-01-16 15:30:36.000000000 +0100
+++ ./src/squirrel/squtils.h 2014-01-16 15:30:36.000000000 +0100
@@ -2,6 +2,10 @@
#ifndef _SQUTILS_H_
#define _SQUTILS_H_

View File

@ -1,13 +1,13 @@
PlanetPenguin Racer is an OpenGL racing game featuring Tux, the
Linux mascot. The goal of the game is to slide down a snow- and
ice-covered mountain as quickly as possible. It is based on the
GPL version of TuxRacer.
PlanetPenguin Racer is an OpenGL racing game featuring Tux, the Linux mascot.
The goal of the game is to slide down a snow- and ice-covered mountain as
quickly as possible. The goal of the game is to slide down a snow- and
ice-covered mountain as quickly as possible. It is based on the GPL version
of TuxRacer 0.6.1.
Differences from TuxRacer include:
* Course progress bar
* Themes
* New terrain types (lava, etc.)
* Actively developed!
* Course progress bar
* Themes
* New terrain types (lava, etc.)
WWW: http://developer.berlios.de/projects/ppracer/
WWW: https://sourceforge.net/projects/ppracer.berlios/