- Fix under clang11
This commit is contained in:
parent
b83961e1e3
commit
85bbd3327f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=546107
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= codec2
|
||||
DISTVERSION= 0.8.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= audio hamradio
|
||||
MASTER_SITES= https://hobbes1069.fedorapeople.org/freetel/codec2/
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- CMakeLists.txt.orig 2018-09-04 06:22:53 UTC
|
||||
--- CMakeLists.txt.orig 2020-08-24 16:23:49 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -14,6 +14,7 @@ mark_as_advanced(CLEAR
|
||||
CMAKE_INSTALL_BINDIR
|
||||
@ -8,7 +8,7 @@
|
||||
)
|
||||
|
||||
#
|
||||
@@ -114,7 +115,7 @@ option(INSTALL_EXAMPLES "Install example
|
||||
@@ -114,7 +115,7 @@ option(INSTALL_EXAMPLES "Install example code." OFF)
|
||||
if(INSTALL_EXAMPLES)
|
||||
install(DIRECTORY octave raw script wav
|
||||
USE_SOURCE_PERMISSIONS
|
||||
@ -17,10 +17,13 @@
|
||||
endif()
|
||||
|
||||
|
||||
@@ -179,6 +180,18 @@ if(UNITTEST)
|
||||
endif()
|
||||
|
||||
#
|
||||
@@ -176,6 +177,18 @@ if(UNITTEST)
|
||||
message(STATUS " Speex DSP library: ${SPEEXDSP_LIBRARY}")
|
||||
if(NOT SPEEXDSP_INCLUDE_DIR AND NOT SPEEXDSP_LIBRARY)
|
||||
message(FATAL_ERROR "Speex DSP library not found!")
|
||||
+ endif()
|
||||
+
|
||||
+ #
|
||||
+ # Find samplerate library
|
||||
+ #
|
||||
+ message(STATUS "Looking for samplerate library.")
|
||||
@ -30,9 +33,6 @@
|
||||
+ message(STATUS " samplerate library: ${SAMPLERATE_LIBRARY}")
|
||||
+ if(NOT SAMPLERATE_INCLUDE_DIR AND NOT SAMPLERATE_LIBRARY)
|
||||
+ message(FATAL_ERROR "samplerate library not found!")
|
||||
+ endif()
|
||||
+
|
||||
+ #
|
||||
# Samplerate Library
|
||||
endif()
|
||||
|
||||
#
|
||||
message(STATUS "Looking for samplerate...")
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- src/freedv_api.c.orig 2018-05-24 09:41:22 UTC
|
||||
--- src/freedv_api.c.orig 2020-08-24 17:11:35 UTC
|
||||
+++ src/freedv_api.c
|
||||
@@ -36,7 +36,7 @@
|
||||
#ifdef __APPLE__
|
||||
#include <malloc/malloc.h>
|
||||
#else
|
||||
-#include <malloc.h>
|
||||
+#include <sys/malloc.h>
|
||||
#endif /* __APPLE__ */
|
||||
@@ -76,6 +76,8 @@
|
||||
|
||||
#include "fsk.h"
|
||||
/* OFDM payload data test frame for 700D */
|
||||
|
||||
+extern const struct OFDM_CONFIG * OFDM_CONFIG_700D;
|
||||
+
|
||||
extern int payload_data_bits[];
|
||||
|
||||
/*---------------------------------------------------------------------------*\
|
||||
|
14
audio/codec2/files/patch-src_codec2__ofdm.h
Normal file
14
audio/codec2/files/patch-src_codec2__ofdm.h
Normal file
@ -0,0 +1,14 @@
|
||||
--- src/codec2_ofdm.h.orig 2018-05-24 01:33:34 UTC
|
||||
+++ src/codec2_ofdm.h
|
||||
@@ -49,9 +49,10 @@ extern "C" {
|
||||
#define OFDM_SYNC_MANUAL 2 /* fall out of sync only under operator control */
|
||||
|
||||
struct OFDM;
|
||||
+struct OFDM_CONFIG;
|
||||
|
||||
/* Default configuration for '700D' mode */
|
||||
-const struct OFDM_CONFIG * OFDM_CONFIG_700D;
|
||||
+//const struct OFDM_CONFIG * OFDM_CONFIG_700D;
|
||||
|
||||
/* create and destroy modem states */
|
||||
|
11
audio/codec2/files/patch-src_ofdm__demod.c
Normal file
11
audio/codec2/files/patch-src_ofdm__demod.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/ofdm_demod.c.orig 2020-08-24 16:51:44 UTC
|
||||
+++ src/ofdm_demod.c
|
||||
@@ -49,6 +49,8 @@
|
||||
#define NFRAMES 100 /* just log the first 100 frames */
|
||||
#define NDISCARD 20 /* BER2measure disctrds first 20 frames */
|
||||
|
||||
+const struct OFDM_CONFIG * OFDM_CONFIG_700D;
|
||||
+
|
||||
extern int payload_data_bits[];
|
||||
extern int test_bits_ofdm[];
|
||||
|
11
audio/codec2/files/patch-src_ofdm__get__test__bits.c
Normal file
11
audio/codec2/files/patch-src_ofdm__get__test__bits.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/ofdm_get_test_bits.c.orig 2020-08-24 17:10:37 UTC
|
||||
+++ src/ofdm_get_test_bits.c
|
||||
@@ -36,6 +36,8 @@
|
||||
#include "ofdm_internal.h"
|
||||
#include "test_bits_ofdm.h"
|
||||
|
||||
+extern const struct OFDM_CONFIG * OFDM_CONFIG_700D;
|
||||
+
|
||||
int main(int argc, char *argv[])
|
||||
{
|
||||
struct OFDM *ofdm;
|
10
audio/codec2/files/patch-src_ofdm__mod.c
Normal file
10
audio/codec2/files/patch-src_ofdm__mod.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/ofdm_mod.c.orig 2020-08-24 17:09:09 UTC
|
||||
+++ src/ofdm_mod.c
|
||||
@@ -41,6 +41,7 @@
|
||||
|
||||
extern int payload_data_bits[];
|
||||
extern int test_bits_ofdm[];
|
||||
+extern const struct OFDM_CONFIG * OFDM_CONFIG_700D;
|
||||
|
||||
int opt_exists(char *argv[], int argc, char opt[]) {
|
||||
int i;
|
11
audio/codec2/files/patch-src_ofdm__put__test__bits.c
Normal file
11
audio/codec2/files/patch-src_ofdm__put__test__bits.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/ofdm_put_test_bits.c.orig 2020-08-24 17:20:41 UTC
|
||||
+++ src/ofdm_put_test_bits.c
|
||||
@@ -36,6 +36,8 @@
|
||||
#include "codec2_ofdm.h"
|
||||
#include "test_bits_ofdm.h"
|
||||
|
||||
+extern const struct OFDM_CONFIG * OFDM_CONFIG_700D;
|
||||
+
|
||||
#define LOG_FRAMES 100
|
||||
#define NDISCARD 20
|
||||
|
Loading…
Reference in New Issue
Block a user