Further pre-update cleanups for `lang/ocaml':

- Do not suppress .bak-files when patching things with ``sed(1) -i'',
  those can be useful for debugging and catching no-ops
- Drop `files/manfiles', it is no longer used (looks like a relic from
  pre-staging times)
- Do not pass ``-as "${AS} ${ASFLAGS}"'' in the initial CONFIGURE_ARGS:
  when ARM support was added in r361233, appropriate values are passed
  conditionally (subject to ${ARCH}), see line 69
- Simplify handling of CFLAGS (obtained from RedHat package): rather
  than passing them as part of the compiler and "fixing" one generated
  Makefile in `post-configure', teach the configure script about them
This commit is contained in:
Alexey Dokuchaev 2017-12-18 14:48:49 +00:00
parent a44b787110
commit 854e293062
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=456636
3 changed files with 14 additions and 109 deletions

View File

@ -28,7 +28,6 @@ BROKEN_mips= No ASM support
USES= cpe gmake tar:xz
USE_LDCONFIG= yes
CPE_VENDOR= inria
REINPLACE_ARGS= -i ""
HAS_CONFIGURE= yes
ALL_TARGET= world.opt
STRIP=
@ -36,8 +35,7 @@ SSP_UNSAFE= yes
MAKE_JOBS_UNSAFE= yes
CONFIGURE_ARGS= -verbose -prefix "${PREFIX}" \
-cc "${CC} ${CFLAGS}" \
-as "${AS} ${ASFLAGS}" \
-cc "${CC}" \
-aspp "${CC} -c" \
-partialld "${LD} -r"
@ -96,7 +94,6 @@ CONFIGURE_ARGS+=-no-graph
.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manfiles"
.if defined(NO_PROFILE) || ${ARCH:Mpowerpc} || ${ARCH:Mamd64}
PLIST_SUB+= PROF="@comment "
@ -128,10 +125,7 @@ post-patch:
${WRKSRC}/testsuite/tests/asmcomp/Makefile
post-configure:
# CFLAGS safeness
@${REINPLACE_CMD} -E \
-e 's|(BYTECCCOMPOPTS[ \t]*=.*)|\1 ${CFLAGS}|' \
-e 's|(NATIVECCCOMPOPTS[ \t]*=.*)|\1 ${CFLAGS}|' \
-e '/^PTHREAD_LINK/s,-pthread,${THR_LD},g' \
${WRKSRC}/config/Makefile

View File

@ -1,101 +0,0 @@
MAN1= ocaml.1 \
ocamlbuild.1 \
ocamlc.1 \
ocamlcp.1 \
ocamldebug.1 \
ocamldep.1 \
ocamldoc.1 \
ocamllex.1 \
ocamlmktop.1 \
ocamlopt.1 \
ocamloptp.1 \
ocamlprof.1 \
ocamlrun.1 \
ocamlyacc.1
MANN= Arg.3o \
Array.3o \
ArrayLabels.3o \
Bigarray.3o \
Bigarray.Array1.3o \
Bigarray.Array2.3o \
Bigarray.Array3.3o \
Bigarray.Genarray.3o \
Buffer.3o \
Callback.3o \
CamlinternalLazy.3o \
CamlinternalMod.3o \
CamlinternalOO.3o \
Complex.3o \
Digest.3o \
Filename.3o \
Format.3o \
Gc.3o \
Genlex.3o \
Hashtbl.3o \
Hashtbl.HashedType.3o \
Hashtbl.Make.3o \
Hashtbl.MakeSeeded.3o \
Hashtbl.S.3o \
Hashtbl.SeededHashedType.3o \
Hashtbl.SeededS.3o \
Int32.3o \
Int64.3o \
Lexing.3o \
List.3o \
ListLabels.3o \
Map.3o \
Map.Make.3o \
Map.OrderedType.3o \
Map.S.3o \
Marshal.3o \
MoreLabels.3o \
MoreLabels.Hashtbl.3o \
MoreLabels.Hashtbl.HashedType.3o \
MoreLabels.Hashtbl.Make.3o \
MoreLabels.Hashtbl.MakeSeeded.3o \
MoreLabels.Hashtbl.S.3o \
MoreLabels.Hashtbl.SeededHashedType.3o \
MoreLabels.Hashtbl.SeededS.3o \
MoreLabels.Map.3o \
MoreLabels.Map.Make.3o \
MoreLabels.Map.OrderedType.3o \
MoreLabels.Map.S.3o \
MoreLabels.Set.3o \
MoreLabels.Set.Make.3o \
MoreLabels.Set.OrderedType.3o \
MoreLabels.Set.S.3o \
Nativeint.3o \
Num.3o \
Obj.3o \
Oo.3o \
Parsing.3o \
Pervasives.3o \
Pervasives.LargeFile.3o \
Printexc.3o \
Printf.3o \
Queue.3o \
Random.3o \
Random.State.3o \
Scanf.3o \
Scanf.Scanning.3o \
Set.Make.3o \
Set.OrderedType.3o \
Set.S.3o \
Sort.3o \
Stack.3o \
StdLabels.3o \
StdLabels.Array.3o \
StdLabels.List.3o \
StdLabels.String.3o \
Str.3o \
Stream.3o \
StringLabels.3o \
Sys.3o \
Unix.3o \
Unix.LargeFile.3o \
Weak.3o \
Weak.Make.3o \
Weak.S.3o
MLINKS= ocamlc.1 ocamlc.opt.1 ocamlopt.1 ocamlopt.opt.1

View File

@ -146,7 +146,19 @@
# Final twiddling of compiler options to work around known bugs
nativeccprofopts="$nativecccompopts"
@@ -1723,7 +1730,7 @@ SYSLIB=-l\$(1)
@@ -1701,6 +1708,11 @@ case "$buggycc" in
nativecccompopts="$nativecccompopts -fomit-frame-pointer";;
esac
+# Allow user-defined C compiler flags
+
+bytecccompopts="$bytecccompopts $CFLAGS"
+nativecccompopts="$nativecccompopts $CFLAGS"
+
# Finish generated files
cclibs="$cclibs $mathlib"
@@ -1723,7 +1735,7 @@ SYSLIB=-l\$(1)
MKLIB=${TOOLPREF}ar rc \$(1) \$(2); ${TOOLPREF}ranlib \$(1)
#ml let mklib out files opts = Printf.sprintf "${TOOLPREF}ar rc %s %s %s; ${TOOLPREF}ranlib %s" out opts files out;;
EOF